Jump to content


Photo

Video Afspelen


  • Please log in to reply
114 replies to this topic

#1 Staricovek

  • Member
  • 143 posts

0
Neutral

Posted 27 September 2021 - 11:34

Het valt mij op dat het afspelen van geripte DVD's en andere video , filmpjes op mijn harde schijf zet deze vrij vaak niet kunnen worden afgespeeld via mediacentrum in PLI. Ga ik via de plugin file explorer na de bestanden dan worden ze wel afgespeeld. Waar ligt dit aan. Of heb ik daar alleen last van.


:) Andreas LG 55 en PLI Testing

Re: Video Afspelen #2 WanWizard

  • PLi® Core member
  • 60,479 posts

+1,376
Excellent

Posted 27 September 2021 - 11:37

Meest voor de hand liggende is een andere player. Ik ken file explorer niet, dus verder geen idee.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: Video Afspelen #3 40H3X

  • Forum Moderator
    PLi® Contributor
  • 4,722 posts

+145
Excellent

Posted 27 September 2021 - 16:28

Misschien serviceapp installeren en even extplayer proberen ipv gstreamer


Hardware: Vu+ Uno 4K SE - Vu+ Duo 4K  - Fuba 78 cm - Tripleblock LNB Quad 19.2/23.5/28.2 - DS918+Software : OpenPLi - OScam - Settings van Hans - Autotimer - EPGImport

---------------------------------------------------------------------------------------------------------------------------------------

Remember: Upvote with the rep_up.png button for any user/post you find to be helpful, informative, or deserving of recognition!

---------------------------------------------------------------------------------------------------------------------------------------

Many answers to your question can be found in our new and improved wiki

Note: I do not provide support via PM !.


Re: Video Afspelen #4 rantanplan

  • Senior Member
  • 851 posts

+38
Good

Posted 27 September 2021 - 19:21

DVD should be MPEG stream and should therefore be played internally via hardware.
If I understand correctly, the DVD player's plug-in is simply missing.



Re: Video Afspelen #5 WanWizard

  • PLi® Core member
  • 60,479 posts

+1,376
Excellent

Posted 27 September 2021 - 20:01

That depends on how the DVD was "ripped". Lots of rips are in DIVX format for example.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: Video Afspelen #6 rantanplan

  • Senior Member
  • 851 posts

+38
Good

Posted 27 September 2021 - 20:29

I don't see anything of the 'rip',
I suspect that it is original ISO files, but it is true that there is not enough information



Re: Video Afspelen #7 WanWizard

  • PLi® Core member
  • 60,479 posts

+1,376
Excellent

Posted 27 September 2021 - 20:58

The TS wrote "ripped DVD's".

 

For standard copies of DVD, if you have removed DVD support and click on the VIDEO_TS directory, it will show you the files instead of the DVD menu. And the .VOB files in there are mpeg files and should just play.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: Video Afspelen #8 Staricovek

  • Member
  • 143 posts

0
Neutral

Posted 28 September 2021 - 18:46

Video_TS bestanden zijn leesbaar met de explorer van PLI maar met de mediaspeler intern van PLI herkend hij de directory niet waarin het bestand staat. 


:) Andreas LG 55 en PLI Testing

Re: Video Afspelen #9 WanWizard

  • PLi® Core member
  • 60,479 posts

+1,376
Excellent

Posted 28 September 2021 - 19:19

Het moet wel VIDEO_TS zijn, volledig in hoofdletters. Is dat wellicht het probleem?

 

Als ik hier even kijk, heb ik:

root@vuduo4k:~# ls -l /media/nas/DVD/
drwxrwxr-x    1 openpli  users            16 May 20  2020 Wim Kan - Compleet DVD 1 van 3
drwxrwxr-x    1 openpli  users            16 Apr 14  2014 Wim Kan - Compleet DVD 2 van 3
drwxrwxr-x    1 openpli  users            16 Apr 14  2014 Wim Kan - Compleet DVD 3 van 3
root@vuduo4k:~# ls -l /media/nas/DVD/Wim\ Kan\ -\ Compleet\ DVD\ 3\ van\ 3/
drwxrwxr-x    1 openpli  users           240 Jun  1  2015 VIDEO TS
root@vuduo4k:~# ls -l /media/nas/DVD/Wim\ Kan\ -\ Compleet\ DVD\ 3\ van\ 3/VIDEO\ TS/
-rw-rw-r--    1 openpli  users         12288 Oct 10  2013 VIDEO_TS.BUP
-rw-rw-r--    1 openpli  users         12288 Oct 10  2013 VIDEO_TS.IFO
-rw-rw-r--    1 openpli  users      18001920 Oct 10  2013 VIDEO_TS.VOB
-rw-rw-r--    1 openpli  users         55296 Oct 10  2013 VTS_01_0.BUP
-rw-rw-r--    1 openpli  users         55296 Oct 10  2013 VTS_01_0.IFO
-rw-rw-r--    1 openpli  users        229376 Oct 10  2013 VTS_01_0.VOB
-rw-rw-r--    1 openpli  users    1073709056 Oct 10  2013 VTS_01_1.VOB
-rw-rw-r--    1 openpli  users    1073709056 Oct 10  2013 VTS_01_2.VOB
-rw-rw-r--    1 openpli  users    1073709056 Oct 10  2013 VTS_01_3.VOB
-rw-rw-r--    1 openpli  users      13500416 Oct 10  2013 VTS_01_4.VOB

En dit start gewoon als ik in de playlist een van de DVD's kies:

Attached File  1_0_19_5225_C99_3_EB0000_0_0_0_20210928191913.jpg   105.67KB   2 downloads


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: Video Afspelen #10 rantanplan

  • Senior Member
  • 851 posts

+38
Good

Posted 28 September 2021 - 20:03

:) DVD

I think this is VU +.
I think the other receivers do not have this menu, but it should also be made available for.



Re: Video Afspelen #11 WanWizard

  • PLi® Core member
  • 60,479 posts

+1,376
Excellent

Posted 28 September 2021 - 20:16

Afaik DVD support is built-in.

 

But if I remember correctly it only works on BCM boxes, I think because it requires gstreamer.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: Video Afspelen #12 rantanplan

  • Senior Member
  • 851 posts

+38
Good

Posted 28 September 2021 - 21:40

I have to take a closer look at it, but I mean that for whatever reason it is only activated for VU + in the image.



Re: Video Afspelen #13 rantanplan

  • Senior Member
  • 851 posts

+38
Good

Posted 28 September 2021 - 22:07

defcobfig?



Re: Video Afspelen #14 WanWizard

  • PLi® Core member
  • 60,479 posts

+1,376
Excellent

Posted 28 September 2021 - 22:36

I have to take a closer look at it, but I mean that for whatever reason it is only activated for VU + in the image.


No, it's not, it works fine on my Amiko Viper too.


Edited by WanWizard, 28 September 2021 - 22:40.

Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: Video Afspelen #15 WanWizard

  • PLi® Core member
  • 60,479 posts

+1,376
Excellent

Posted 28 September 2021 - 22:52

Movielist triggering is here: https://github.com/O...ection.py#L1157

 

DVD control interface: https://github.com/O.../Screens/DVD.py

 

I think the issue is that the HiSil player doesn't know how to handle "video/x-dvd", it is not mentioned in servicehisilicon. On BCM, it is supported by servicemp3.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: Video Afspelen #16 rantanplan

  • Senior Member
  • 851 posts

+38
Good

Posted 29 September 2021 - 11:20

Plugin dvd need libddvd

 

https://github.com/O.../Makefile.am#L5

otherwise no dvd.

That's what I mean by defconfig

 

with this

https://github.com/n...e/amiko.inc#L11



Re: Video Afspelen #17 WanWizard

  • PLi® Core member
  • 60,479 posts

+1,376
Excellent

Posted 29 September 2021 - 12:14

Afaik DVD Player and cdfs are only required if you have a physical CD or DVD player connected (like in a DM8000, or via USB).

 

My Duo 4K also doesn't have kernel-module-cdfs, but the DVD rip from my NAS plays fine.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: Video Afspelen #18 rantanplan

  • Senior Member
  • 851 posts

+38
Good

Posted 29 September 2021 - 12:18

I'm looking for the libddvd, it has to come from somewhere so that the dvd player can also be created.
To compare the OE-Alliance Image, it is not included here everywhere.
The instruction in e2 is the same.
So I suspected kernel modules or defconfig



Re: Video Afspelen #19 WanWizard

  • PLi® Core member
  • 60,479 posts

+1,376
Excellent

Posted 29 September 2021 - 12:21

Is is supplied by libdreamdvd, https://github.com/O...onfigure.ac#L35


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: Video Afspelen #20 rantanplan

  • Senior Member
  • 851 posts

+38
Good

Posted 29 September 2021 - 12:55

yes, i know...
 

https://github.com/m...ter/main.c#L145

 

and this is exactly what makes me suspect defconfig or modules.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users