Jump to content


Photo

new error in 8.2 when starting automatic backup


  • Please log in to reply
5 replies to this topic

#1 gspock

  • Senior Member
  • 85 posts

+2
Neutral

Posted 22 June 2022 - 10:22

Hello,

I just noticed an error when starting manually an automatic backup (see annex) ; as a result, some of the files I choose to backup are not (keymap.xml) and then I have to recopy it after any "monday" upgrade.

Please note this worked OK in 8.1

Thanks,

GS

 

Attached Files


Edited by gspock, 22 June 2022 - 10:24.

VU+ DUO-4K-SE with 1 DBV-C and 1TB Hitachi HDD, OpenPLi 8.1


Re: new error in 8.2 when starting automatic backup #2 WanWizard

  • PLi® Core member
  • 62,670 posts

+1,476
Excellent

Posted 22 June 2022 - 12:02

Looks like you have added a file or directory to your backup configuration with a space in it.

 

This has never been supported, that bit of the settings-backup.sh script is 9 years old...

 

edit: This should fix it: https://github.com/E...9f5da070a35960e, can you confirm?


Edited by WanWizard, 22 June 2022 - 12:08.

Currently in use: VU+ Duo 4K (2xFBC S2), VU+ Solo 4K (1xFBC S2), SAB AlphaTriple HD (S2+T2), (Octagon SF8008 (S2+T2), Zgemma H9.2H (S2+T2)

Due to my bad health, I will have periods of inactivity, during which I won't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: new error in 8.2 when starting automatic backup #3 gspock

  • Senior Member
  • 85 posts

+2
Neutral

Posted 22 June 2022 - 12:26

Looks like you have added a file or directory to your backup configuration with a space in it.

 

This has never been supported, that bit of the settings-backup.sh script is 9 years old...

 

edit: This should fix it: https://github.com/E...9f5da070a35960e, can you confirm?

Thanks - I checked 3 times and no, sorry, there are no directories/files with space in it !!!

As for your question about the fix, I am sorry I do not know what to do with this link .... quite limitied skills but ready to try if I would know what to do with this piece of code ... Would it mean editing in vi a sh script (that  I can do)


Edited by gspock, 22 June 2022 - 12:30.

VU+ DUO-4K-SE with 1 DBV-C and 1TB Hitachi HDD, OpenPLi 8.1


Re: new error in 8.2 when starting automatic backup #4 WanWizard

  • PLi® Core member
  • 62,670 posts

+1,476
Excellent

Posted 22 June 2022 - 13:44

An empty line in your backup.cfg file could also cause the error.

 

It would require editing the file /usr/lib/enigma2/python/Plugins/Extensions/AutoBackup/settings-backup.sh and make the change on line 49 als the link shows ( i.e. put $file in double quotes ).


Currently in use: VU+ Duo 4K (2xFBC S2), VU+ Solo 4K (1xFBC S2), SAB AlphaTriple HD (S2+T2), (Octagon SF8008 (S2+T2), Zgemma H9.2H (S2+T2)

Due to my bad health, I will have periods of inactivity, during which I won't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: new error in 8.2 when starting automatic backup #5 gspock

  • Senior Member
  • 85 posts

+2
Neutral

Posted 22 June 2022 - 14:19

@WanWizard thanks. I confirm the update of setting-backup.sh has resolved the issue and I confirm there were no names with space in it ; on the other hand, I found a directory that was tagged for bakcup but was empty .... may be that was the issue.

Anyway, many thanks for your quick reaction and solution.

GS


VU+ DUO-4K-SE with 1 DBV-C and 1TB Hitachi HDD, OpenPLi 8.1


Re: new error in 8.2 when starting automatic backup #6 WanWizard

  • PLi® Core member
  • 62,670 posts

+1,476
Excellent

Posted 22 June 2022 - 15:13

Quite likely, thanks for confirming it, I'll backport the fix to 8.2-release.


Currently in use: VU+ Duo 4K (2xFBC S2), VU+ Solo 4K (1xFBC S2), SAB AlphaTriple HD (S2+T2), (Octagon SF8008 (S2+T2), Zgemma H9.2H (S2+T2)

Due to my bad health, I will have periods of inactivity, during which I won't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users