Jump to content


Photo

Time not updated after daylight saving time

zgmmea Open PLi 9.0 H9Combo Time Sync Daylight Saving

  • Please log in to reply
21 replies to this topic

#1 smith

  • Senior Member
  • 56 posts

0
Neutral

Posted 2 April 2024 - 08:58

Hi,

Following the weekend Daylight savings changes to the local time normally the time on my receivers updates automtically. I have three Zgemma H9Combo's and two have updated okay but the third is an hour behind. I noticed that it will not update automatically from the internet and when set to look at the transponder it is always one hour behind. I can overwrite the time using the date -s command but will not read the time from pool.ntp.org.

Thanks 


Zgemma H9 Combo 4K, VU+ Duo2, Xtrend ET8500, DM800SE.


Re: Time not updated after daylight saving time #2 Tech

  • Forum Moderator
    PLi® Core member
  • 14,752 posts

+468
Excellent

Posted 2 April 2024 - 11:02

Are you sure that pool.ntp.org can also be reached for that receiver, perhaps something is not set up correctly in the DNS settings?


Aan de rand van de afgrond is een stap voorwaarts niet altijd vooruitgang....

On the edge of the abyss, a step forward is not always progress....


Hardware: 2x Daily used Vu+ Ultimo 4K - Vu+ Duo 4K SE and a lot more.... - VisioSat BiBigsat - Jultec Unicable Multiswitch 4 positions: 19.2/23.5/28.2 East - Diseqc motorized flatdish antenna

Software : HomeBuild OpenPLi Develop and Kirkstone builds, local cards driven by OsCam

 

Press the rep_up.png button on the buttom right of this message ;)


Have you tried our wiki yet? Many answers can be found in our OpenPLi wiki


Re: Time not updated after daylight saving time #3 smith

  • Senior Member
  • 56 posts

0
Neutral

Posted 2 April 2024 - 12:12

More testing:-

 

Time zone Area > Europe

Time Zone > London

Time Synchronisation method > Internet (ntp)

NTP Hostname > pool.ntp.org

 

So I set the time from telenet to say 09:00

Box updates to 09:00

Flick between channels BBC One / Two (Astra 2 Satellite)

Box updates the time to 11:00

So it is -1 hour out and it looks like it is applying an offset. I cannot tell where the update is being applied from but I am assuming it is from the Transponder even though it is set to 'Internet' rather than 'Auto'.  


Zgemma H9 Combo 4K, VU+ Duo2, Xtrend ET8500, DM800SE.


Re: Time not updated after daylight saving time #4 smith

  • Senior Member
  • 56 posts

0
Neutral

Posted 2 April 2024 - 12:15

root@h9combo:~# ping pool.ntp.org
PING pool.ntp.org (195.171.43.10): 56 data bytes
64 bytes from 195.171.43.10: seq=0 ttl=55 time=31.305 ms
64 bytes from 195.171.43.10: seq=1 ttl=55 time=29.903 ms
64 bytes from 195.171.43.10: seq=2 ttl=55 time=28.532 ms
64 bytes from 195.171.43.10: seq=3 ttl=55 time=28.491 ms
64 bytes from 195.171.43.10: seq=4 ttl=55 time=29.557 ms
64 bytes from 195.171.43.10: seq=5 ttl=55 time=30.905 ms
64 bytes from 195.171.43.10: seq=6 ttl=55 time=28.431 ms
64 bytes from 195.171.43.10: seq=7 ttl=55 time=27.940 ms
64 bytes from 195.171.43.10: seq=8 ttl=55 time=28.113 ms
64 bytes from 195.171.43.10: seq=9 ttl=55 time=30.517 ms
64 bytes from 195.171.43.10: seq=10 ttl=55 time=39.286 ms
64 bytes from 195.171.43.10: seq=11 ttl=55 time=27.175 ms
64 bytes from 195.171.43.10: seq=12 ttl=55 time=27.471 ms

Zgemma H9 Combo 4K, VU+ Duo2, Xtrend ET8500, DM800SE.


Re: Time not updated after daylight saving time #5 WanWizard

  • PLi® Core member
  • 69,105 posts

+1,763
Excellent

Posted 2 April 2024 - 12:26

9.0-release has a bug that causes transponder time not to be disabled with you select "ntp", so basically "ntp" behaves the same as "auto". Which is why you get transponder time now.

 

Being able to ping says nothing about being able to make an ntp connection, for that UDP port 123 needs to be open.

 

You can check what the box is doing using

grep ntp /var/log/messages

the box itself uses

/usr/bin/ntpdate-sync silent

to do a time update, using the configuration in

/etc/default/ntpdate

 

 


Currently in use: VU+ Duo 4K (2xFBC S2), VU+ Solo 4K (1xFBC S2), uClan Usytm 4K Ultimate (S2+T2), Octagon SF8008 (S2+T2), Zgemma H9.2H (S2+T2)

Due to my bad health, I will not be very active at times and may be slow to respond. I will not read the forum or PM on a regular basis.

Many answers to your question can be found in our new and improved wiki.


Re: Time not updated after daylight saving time #6 Pr2

  • PLi® Contributor
  • 6,112 posts

+260
Excellent

Posted 2 April 2024 - 12:33

Check the setup for your time settings, you can decide to only use NTP, or only use the Transponder Time or use both.

It is probably better to use NTP only.


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)

AB-Com: PULSe 4K 1*DVB-S2X (+ DVB-C/T/T2)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: Time not updated after daylight saving time #7 WanWizard

  • PLi® Core member
  • 69,105 posts

+1,763
Excellent

Posted 2 April 2024 - 12:35

@Pr2,

 

Time Synchronisation method > Internet (ntp)

NTP Hostname > pool.ntp.org

 

Is already set correctly.


Currently in use: VU+ Duo 4K (2xFBC S2), VU+ Solo 4K (1xFBC S2), uClan Usytm 4K Ultimate (S2+T2), Octagon SF8008 (S2+T2), Zgemma H9.2H (S2+T2)

Due to my bad health, I will not be very active at times and may be slow to respond. I will not read the forum or PM on a regular basis.

Many answers to your question can be found in our new and improved wiki.


Re: Time not updated after daylight saving time #8 smith

  • Senior Member
  • 56 posts

0
Neutral

Posted 2 April 2024 - 12:59

root@h9combo:~# grep ntp /var/log/messages
Jan  1 00:00:11 h9combo user.info kernel: Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
Apr  2 08:21:56 h9combo daemon.notice ntpdate[1687]: step time server 81.128.218.110 offset +1712046096.635665 sec
Apr  2 08:30:00 h9combo cron.info crond[1716]: USER root pid 1883 cmd /usr/bin/ntpdate-sync silent
Apr  2 08:30:09 h9combo daemon.notice ntpdate[1892]: step time server 185.177.149.33 offset +2.001515 sec
Apr  2 09:30:00 h9combo cron.info crond[1716]: USER root pid 1961 cmd /usr/bin/ntpdate-sync silent
Apr  2 09:30:10 h9combo daemon.notice ntpdate[1970]: step time server 77.104.162.218 offset +2.013473 sec
Apr  2 10:30:00 h9combo cron.info crond[1716]: USER root pid 2039 cmd /usr/bin/ntpdate-sync silent
Apr  2 10:30:09 h9combo daemon.notice ntpdate[2048]: step time server 217.114.59.3 offset +2.011938 sec
Apr  2 11:30:00 h9combo cron.info crond[1716]: USER root pid 2260 cmd /usr/bin/ntpdate-sync silent
Apr  2 11:30:09 h9combo daemon.notice ntpdate[2269]: adjust time server 159.65.53.52 offset +0.020038 sec

Zgemma H9 Combo 4K, VU+ Duo2, Xtrend ET8500, DM800SE.


Re: Time not updated after daylight saving time #9 WanWizard

  • PLi® Core member
  • 69,105 posts

+1,763
Excellent

Posted 2 April 2024 - 13:11

That's good, that means ntp works fine, it picked up the correct time from NTP 11 seconds after the box started.

 

The box uses /etc/timezone:

root@ustym4kpro:~# cat /etc/timezone 
Europe/London

root@ustym4kpro:~# date
Tue Apr  2 13:11:32 BST 2024

Is this set correctly? Does it report the time in BST ?


Currently in use: VU+ Duo 4K (2xFBC S2), VU+ Solo 4K (1xFBC S2), uClan Usytm 4K Ultimate (S2+T2), Octagon SF8008 (S2+T2), Zgemma H9.2H (S2+T2)

Due to my bad health, I will not be very active at times and may be slow to respond. I will not read the forum or PM on a regular basis.

Many answers to your question can be found in our new and improved wiki.


Re: Time not updated after daylight saving time #10 smith

  • Senior Member
  • 56 posts

0
Neutral

Posted 2 April 2024 - 13:18

root@h9combo:~# cat /etc/timezone
Europe/London
 
root@h9combo:~# date
Tue Apr  2 12:14:06 UTC 2024

Zgemma H9 Combo 4K, VU+ Duo2, Xtrend ET8500, DM800SE.


Re: Time not updated after daylight saving time #11 WanWizard

  • PLi® Core member
  • 69,105 posts

+1,763
Excellent

Posted 2 April 2024 - 13:26

That is EXTREMELY weird. At least, it explains the issue you have.

 

The question is now, WHY? I have to think about that. I assume restarting the box doesn't fix it?


Currently in use: VU+ Duo 4K (2xFBC S2), VU+ Solo 4K (1xFBC S2), uClan Usytm 4K Ultimate (S2+T2), Octagon SF8008 (S2+T2), Zgemma H9.2H (S2+T2)

Due to my bad health, I will not be very active at times and may be slow to respond. I will not read the forum or PM on a regular basis.

Many answers to your question can be found in our new and improved wiki.


Re: Time not updated after daylight saving time #12 WanWizard

  • PLi® Core member
  • 69,105 posts

+1,763
Excellent

Posted 2 April 2024 - 13:27

Does the zoneinfo file exist?

root@ustym4kpro:~# ls -l /usr/share/zoneinfo/Europe/London
-rw-r--r--    1 root     root          1599 Apr 28  2023 /usr/share/zoneinfo/Europe/London

 


Currently in use: VU+ Duo 4K (2xFBC S2), VU+ Solo 4K (1xFBC S2), uClan Usytm 4K Ultimate (S2+T2), Octagon SF8008 (S2+T2), Zgemma H9.2H (S2+T2)

Due to my bad health, I will not be very active at times and may be slow to respond. I will not read the forum or PM on a regular basis.

Many answers to your question can be found in our new and improved wiki.


Re: Time not updated after daylight saving time #13 smith

  • Senior Member
  • 56 posts

0
Neutral

Posted 2 April 2024 - 13:37

root@h9combo:~# ls -l /usr/share/zoneinfo/Europe/London
-rw-r--r--    1 root     root             0 Jul 31  2023 /usr/share/zoneinfo/Europe/London

Zgemma H9 Combo 4K, VU+ Duo2, Xtrend ET8500, DM800SE.


Re: Time not updated after daylight saving time #14 WanWizard

  • PLi® Core member
  • 69,105 posts

+1,763
Excellent

Posted 2 April 2024 - 13:46

That's the problem found.

 

For some reason, the file size of the zoneinfo file is zero. That can be fixed by

opkg install tzdata-europe --force-reinstall

but it begs the question what has caused this, and what else is corrupt.

 

I'd flash the box again, from the menu so you can make a backup on USB before the flash.

 

Unless you have installed all sorts of stuff manually (i.e. not from the plugins download), this will bring your box up after the flash automatically.
 


Currently in use: VU+ Duo 4K (2xFBC S2), VU+ Solo 4K (1xFBC S2), uClan Usytm 4K Ultimate (S2+T2), Octagon SF8008 (S2+T2), Zgemma H9.2H (S2+T2)

Due to my bad health, I will not be very active at times and may be slow to respond. I will not read the forum or PM on a regular basis.

Many answers to your question can be found in our new and improved wiki.


Re: Time not updated after daylight saving time #15 smith

  • Senior Member
  • 56 posts

0
Neutral

Posted 2 April 2024 - 15:17

Hi,
 
Yes the 0 filesize do not look correct at all!
 
The command:-
 
opkg install tzdata-europe --force-reinstall
 
Did not work for me unfortunately! I did flash two of these boxes in January with Open PLi 9.0 and copied the file from that box and replaced the version on this box with these results:- 
 
root@h9combo:~# ls -l /usr/share/zoneinfo/Europe/London
-rw-r--r--    1 root     root          1599 Apr  2 14:09 /usr/share/zoneinfo/Europe/London
root@h9combo:~# date
Tue Apr  2 14:11:39 BST 2024
 
So that has fixed it, thanks. Of the files in the /zoneinfo/Europe folder three were showing as 0 filesize, London, Paris, Moscow. Now I have been doing some experimenting to try and force things to work so I may have tried those other time zones, I can't say for certain. Even so, I wouldn't expect them to become corrupted simply by a setting change?
 
Just wondering if it was due to running the date -s command, but just tested it and its okay, the time is auto updated again after a few seconds.

Zgemma H9 Combo 4K, VU+ Duo2, Xtrend ET8500, DM800SE.


Re: Time not updated after daylight saving time #16 WanWizard

  • PLi® Core member
  • 69,105 posts

+1,763
Excellent

Posted 2 April 2024 - 19:01

So why did it not fix it? It should just replaced the corrupt files with the correct ones. What was the output?

 

Nothing else uses the files, only the OS, which reads the file /etc/timezone is pointing to.


Currently in use: VU+ Duo 4K (2xFBC S2), VU+ Solo 4K (1xFBC S2), uClan Usytm 4K Ultimate (S2+T2), Octagon SF8008 (S2+T2), Zgemma H9.2H (S2+T2)

Due to my bad health, I will not be very active at times and may be slow to respond. I will not read the forum or PM on a regular basis.

Many answers to your question can be found in our new and improved wiki.


Re: Time not updated after daylight saving time #17 smith

  • Senior Member
  • 56 posts

0
Neutral

Posted 2 April 2024 - 19:36

 

So that has fixed it, thanks. Of the files in the /zoneinfo/Europe folder three were showing as 0 filesize, London, Paris, Moscow. Now I have been doing some experimenting to try and force things to work so I may have tried those other time zones, I can't say for certain. Even so, I wouldn't expect them to become corrupted simply by a setting change?
 

 

 

It did fix it, thanks. Apologies, bit of a waffling reply. I was just thinking about testing it fully and determining the cause.

:thumbs-up:  :D


Edited by smith, 2 April 2024 - 19:36.

Zgemma H9 Combo 4K, VU+ Duo2, Xtrend ET8500, DM800SE.


Re: Time not updated after daylight saving time #18 WanWizard

  • PLi® Core member
  • 69,105 posts

+1,763
Excellent

Posted 2 April 2024 - 19:38

I'm lost.

 

You wrote the reinstall didn't fix it, and manually copying files did. So that wasn't true?

 

Just trying to understand what the problem was.


Currently in use: VU+ Duo 4K (2xFBC S2), VU+ Solo 4K (1xFBC S2), uClan Usytm 4K Ultimate (S2+T2), Octagon SF8008 (S2+T2), Zgemma H9.2H (S2+T2)

Due to my bad health, I will not be very active at times and may be slow to respond. I will not read the forum or PM on a regular basis.

Many answers to your question can be found in our new and improved wiki.


Re: Time not updated after daylight saving time #19 smith

  • Senior Member
  • 56 posts

0
Neutral

Posted 2 April 2024 - 20:45

You wrote the reinstall didn't fix it, and manually copying files did.

 

 

Yes that's right.


Zgemma H9 Combo 4K, VU+ Duo2, Xtrend ET8500, DM800SE.


Re: Time not updated after daylight saving time #20 WanWizard

  • PLi® Core member
  • 69,105 posts

+1,763
Excellent

Posted 3 April 2024 - 14:07

In which case this is still a valid question:

 

So why did it not fix it? It should just replaced the corrupt files with the correct ones. What was the output?

 

Nothing else uses the files, only the OS, which reads the file /etc/timezone is pointing to.

 


Currently in use: VU+ Duo 4K (2xFBC S2), VU+ Solo 4K (1xFBC S2), uClan Usytm 4K Ultimate (S2+T2), Octagon SF8008 (S2+T2), Zgemma H9.2H (S2+T2)

Due to my bad health, I will not be very active at times and may be slow to respond. I will not read the forum or PM on a regular basis.

Many answers to your question can be found in our new and improved wiki.




Also tagged with one or more of these keywords: zgmmea, Open PLi 9.0, H9Combo, Time Sync, Daylight Saving

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users