Jump to content


MastaG

Member Since 16 May 2009
Offline Last Active 30 Sep 2019 08:01
*****

#898090 Howto build unofficial pli for your unsupported receiver

Posted by MastaG on 14 June 2018 - 11:36

Don't say such things out loud.. you might wake-up gutemine..




#875617 Howto build unofficial pli for your unsupported receiver

Posted by MastaG on 23 April 2018 - 16:21

@everyone the directfb compile issues have been fixed.

Simply run ./pli-extras/update.sh

 

@dreamce

I only have a spark7162, but are you sure it's not related to reception?

Anyways I've reverted back to Taapat's changes.. so hopefully the next spark image will be better.

I'll release a new image when I'm done :)




#875047 Howto build unofficial pli for your unsupported receiver

Posted by MastaG on 22 April 2018 - 19:58

Yes I know I f'ed up.. Will fix the directfb thing tomorrow ;)


#866060 Howto build unofficial pli for your unsupported receiver

Posted by MastaG on 4 April 2018 - 13:35

@joni3333

Yes, I'm using Tapaat's driver as well and I have merged joeuser's public bits:

https://github.com/P.../commits/master

 

So I've added the cases for CA_SET_DESCR_MODE and CA_SET_DESCR_DATA.

And I've added the pti hal dummy functions for pti_hal_descrambler_set_aes and pti_hal_descrambler_set_mode.

 

But these are only dummy funcions and don't support descrambling of channels.

 

For this I need the non-public sources for pti_np which supports DES encryption for PowerVu.

And I don't have these.

 

Instead I have the pti_np from OE-Alliance which doesn't support DES (PowerVu) but CI+ instead.

So that one does feature pti_hal_descrambler_set_aes for CI+, but it has pti_hal_descrambler_set_mode stubbed out.

 

So get me the pti_np sources for PowerVu and I'll build a new image for you :)




#863813 Howto build unofficial pli for your unsupported receiver

Posted by MastaG on 30 March 2018 - 10:54

Yeah, you've updated the original patch instead of adding a new one :)

Great job!

Merged :)




#863324 Howto build unofficial pli for your unsupported receiver

Posted by MastaG on 29 March 2018 - 12:35

* New unofficial test build for Fulan sh4 (spark/spark7162)

Download: https://mega.nz/#F!v...DLHfab11t5_y5Sg

- Now built using -O2 instead of -Os, it feels a bit faster now

- Disabled zram by default as it slows down things

- Includes gstreamer 1.14 as well (thx Taapat)

- Uchardet upgraded to git version

- Merged PLi's latest enigma2 rev: 9310a05

- Built using latest openpli-oe-core rev: ab347d9

- Many cleanups and fixes

- Removed serviceapp

 

* Note: zram is disabled by default since we're using extra memory from video ram.

  This breaks PIP, but that was limited to SD-channels anyways.

  If you still want to use zram, login using telnet and issue the following commands:

 

touch /etc/.zram
reboot

 

* Note2: serviceapp has been removed in favor of Taapats service-player for libeplayer3 and gstreamer.

  The playback system is set to libeplayer3 by default, which provides the same playback functionality as serviceapp + exteplayer3 as default player.

  If you'd like to swtich to gstreamer 1.14, you can do this by going to: Menu -> Settings -> System -> Usage Setup (this requires a restart of enigma2)

  Exteplayer3 (and now also gstplayer) is still included for use with IPTV Player :)




#862871 Youtube Error

Posted by MastaG on 28 March 2018 - 10:47

@pzanone can you be a little bit more specific regarding your home build?

e.g. are you building your zgemma h5 image from vanilla openpli-oe-core from here https://github.com/O...pli-oe-core.git ?

Or are you also using the unofficial pli-extras ?

Did you run make update, prior to building your image ?

What OS are you building on ?

 

If your receiver hangs, you could try to login in with telnet, init 4 and start enigma2 with ENIGMA_DEBUG_LVL=4 and see some more info..




#862217 Youtube Error

Posted by MastaG on 26 March 2018 - 18:32

Yes I know.. still didnt have time to update the broken recipes/patches..


#861617 Howto build unofficial pli for your unsupported receiver

Posted by MastaG on 24 March 2018 - 20:00

MACHINE=dm800 bitbake -c cleanall -f linux-dreambox


#861590 Youtube Error

Posted by MastaG on 24 March 2018 - 18:55

Ahhhhh thanks fairbird and hains.. please submit a PR asap.. as I will not be able to use a computer in the following days :)


#861233 Youtube Error

Posted by MastaG on 23 March 2018 - 10:49

this is probably due to the recent upgrade to gstreamer 1.14

I'll test this later this weekend :)

Thanks for reporting.




#860744 Howto build unofficial pli for your unsupported receiver

Posted by MastaG on 22 March 2018 - 07:38

I got a failure for building odroid c2

 

ERROR: Task (/home/openvix/openpli-oe-core/pli-extras/recipes-connectivity/mediatek/rt7777_3.0.0.4.bb:do_compile) failed with exit code '1'

 

Any help would be greatly appreciated

 

What is your machine name?

e.g. MACHINE=what?

 

EDIT: nevermind, just run pli-extras/update.sh and your odroid image should build fine :)




#860729 Howto build unofficial pli for your unsupported receiver

Posted by MastaG on 21 March 2018 - 23:45

I don't get it, when I commited meta-meson I did test wetek-play2 without any ffmpeg or kernel problem so what has been changed?

My build server is always an Ubuntu LTS native.

I was able to reproduce the ffmpeg build error on aarch64 (raspberrypi3 64bit) architecture.

This is because arm64 will need: --enable-armv8 but also --enable-neon and --enable-vfp.. and none of the other (mipsel) related flags.

See my commit: https://github.com/O...e5e13b440e7ec63

 

For his other kernel patch, I think it fixes some usb-port related problems.. but it's not a build-issue.

 

 

In other news I've upgraded the gstreamer recipes to version 1.14: https://github.com/O...747a435d4fff9e0

This will require a reflash

It's because some plugins like mpg123 and lame have been promoted to the -good package.. and an upgrade from 1.12 -> 1.14 will not fix it.

 

So this will require massive testing on all official supported receivers, to make sure all supported media still works.

so everybody, please test the next nightly version and report back any problems!




#860597 Howto build unofficial pli for your unsupported receiver

Posted by MastaG on 21 March 2018 - 15:19

 

please submit a PR then :)

I have never submitted a PR on github. A new user of github.

But have submitted now, can you do me a favour to check and let me know that have I done it correct?

 

 

You've committed a new patch with a new name.. but didn't change the kernel recipe (.bb file) to include the new file in the SRC_URI.




#860573 Howto build unofficial pli for your unsupported receiver

Posted by MastaG on 21 March 2018 - 14:32

please submit a PR then :)