Jump to content


theparasol

Member Since 14 Nov 2009
Offline Last Active 21 Jun 2021 18:40
*****

#819902 Receiver no longer time synced

Posted by theparasol on 29 December 2017 - 21:40

Is there a config value to disable this behaviour? This needs to be addressed and fixed at the linux level, not in any user binary (and that includes Enigma).

 

http://www.streamboa...trunk/config.sh

 

default: CONFIG_CLOCKFIX=y

 

All oscam builds with clockfix have "Clockfix with realtime clock: yes" (you can check in webif -> files -> oscam-version)

 

To have it removed: this can only be done at compiletime... so before compiling the oscam bin flip it to CONFIG_CLOCKFIX=n

 

Is it a unusual and dirty thing: yes, I agree but hey it works and fixes things (even on my setup hence the default on)

If anyone can improve the oscam code the right way just do it. But be warned you will enter a fucing rabbithole.

 

BTW I'm more than happy to commit a sound and clean solution to fix this properly in oscam but only problem is it needs to be made first...

Till then the second best option is in effect and all complains are ignored.

 

Ignore mode on again... ;)




#786608 Oscam problem with OpenPli 6 Release.

Posted by theparasol on 23 October 2017 - 18:28

oscam-1.20-HPB-r732-EMU-r397-746-r11391

 

So you reverted back to begin 2017 version of emu patch to get it stable again.

 

 

What's the difference between a EMU version of oscam and the one without that EMU?

 

Read it here: https://github.com/oscam-emu/oscam-emu

 

From my point of view: emu patch contains all the code that endangers the legal status of the oscam project.

Using emupatch on top of oscam code is for sure illegal since you can watch pay tv with it without the need of a valid subscription.

 

Some would say Oscam it self is already illegal since you can watch pay tv with it using a solotion not supported and approved by the providers.

I would say I have a valid subscription so I can and want to watch the content I paid for. How I accomplish that it is my personal struggle.

If there are folks out there using oscam to watch without a valid subscription is their personal problem.

You cant forbid sales of crowbars either since some burglars use them.




#686300 full ci+ support

Posted by theparasol on 17 March 2017 - 13:41

Ten years ago oscam didn't work for my personal usage. After raising some tickets no one seems interested in fixing.

So I started changing things myself and contribute them to oscam. Now it works fine for my usage.

 

So if it doesnt work ok for your usage:improve the code and contribute!




#658416 Ziggo NagraVision smartcard word niet herkend in dm800se / dm8000

Posted by theparasol on 27 January 2017 - 20:04

De providers zijn overigens *niet* degenen die afdwingen.

Het zijn echt de zenders en content leveranciers zelf die hoge beveiligingseisen stellen aan de distributie van hun "kostbare" content.

Kan een provider niet voorzien in bepaald veiligheidsniveau van distributie dan mogen ze de content of niet distribueren of tegen een aanzienlijk hogere prijs. 

De dwingelanden tref je dus niet door over te stappen naar een andere provider.

Die pak je alleen door massaal te bedanken voor hun zogenaamde premium content.




#648930 Xtrend 10000 mulltituner + oscam probleem

Posted by theparasol on 12 January 2017 - 16:04

https://github.com/O...15e36f09c997453




#603643 UP/DOWNLINK 2016, nummer 10 (18 oktober)

Posted by theparasol on 21 October 2016 - 17:12

Wordt altijd met veel plezier gelezen hier :)




#578431 Canal Digitaal software update for DSR ontvangers

Posted by theparasol on 18 August 2016 - 22:40

In zelfde bericht stond ook een opmerking over niet meer werken van smart wi en clone+ adapters....

 

Dus lijkt mij uitfasering van de seca layer op alle officiele ontvangers en omschakeling naar de nagra merlin layer zoals bv de M7 801 al deed.

Als de omschakeling van de officiële ontvangers lukt dan kunnen ze vervolgens met een druk op de knop direct alle cardservers en softcams op zwart zetten door de seca layer te deactiveren. Of alleen deactiveren voor bepaalde "premium" kanalen.

 

Enfin, koffiedik kijken voor iedereen. Maar hier zat ik aan te denken toen ik het bewuste emailje las ;)




#546648 Ecm window on OSD

Posted by theparasol on 7 May 2016 - 18:05

Well sure I can add support to oscam to output it to some kind of file but why not implement it in engima2 code? That way everyone can benefit from it, even the setups not

using oscam at all. Therefor I think enigma is a far better place to implement this.




#546631 Ecm window on OSD

Posted by theparasol on 7 May 2016 - 16:49

The exact same data is used by oscam to fetch caid, provid and ecmpid.

But provid is not always communicated in pmt by the provider in that case oscam zero's it too.

 

this code is used in dvbapi to parse it: (I stripped away already some silly stuff you dont need)

 

void dvbapi_parse_descriptor(int32_t demux_id, uint32_t info_length, unsigned char *buffer)
{
    // int32_t ca_pmt_cmd_id = buffer[i + 5];
    uint32_t descriptor_length = 0;
    uint32_t j, u, k;
    
    if(info_length < 1)
        { return; }

    for(j = 0; j + 1 < info_length; j += descriptor_length + 2)
    {
        descriptor_length = buffer[j + 1];
        
        if(buffer[j] != 0x09) { continue; }
        
        if(demux[demux_id].ECMpidcount >= ECM_PIDS) { break; }

        int32_t descriptor_ca_system_id = b2i(2, buffer + j + 2);
        int32_t descriptor_ca_pid = b2i(2, buffer + j + 4)&0x1FFF;
        int32_t descriptor_ca_provider = 0;

        if(descriptor_ca_system_id >> 8 == 0x01)
        {
            for(u = 2; u < descriptor_length; u += 15)
            {
                descriptor_ca_pid = b2i(2, buffer + j + u + 2)&0x1FFF;
                descriptor_ca_provider = b2i(2, buffer + j + u + 4);
                dvbapi_add_ecmpid(demux_id, descriptor_ca_system_id, descriptor_ca_pid, descriptor_ca_provider);
            }
        }
        else
        {
            if(caid_is_viaccess(descriptor_ca_system_id) && descriptor_length == 0x0F && buffer[j + 12] == 0x14)
                { descriptor_ca_provider = b2i(3, buffer + j + 14) &0xFFFFF0; }

            if(caid_is_nagra(descriptor_ca_system_id) && descriptor_length == 0x07)
                { descriptor_ca_provider = b2i(2, buffer + j + 7); }
            
            if((descriptor_ca_system_id >> 8 == 0x4A || descriptor_ca_system_id == 0x2710) && descriptor_length > 0x04 )
                { descriptor_ca_provider = buffer[j + 6]; }

            dvbapi_add_ecmpid(demux_id, descriptor_ca_system_id, descriptor_ca_pid, descriptor_ca_provider);            
        }
    }



#540321 VPN throughput not sufficient for HD streaming

Posted by theparasol on 1 April 2016 - 20:37

And even that is not correct.... I measured my boxes while they where in action.... this is with quad+ in init 4 mode, oscam killed:

aes-128-cbc      16496.25k    20222.17k    21363.80k    21673.98k    21738.84k



#536465 Nas mounten over wan

Posted by theparasol on 12 March 2016 - 15:59

Gauw gaan leren dan zou ik zeggen want ook je laatste bijdrage smijt je weer met dingen daar gaan mij de rugharen van overeind staan.




#532017 Welke fabrikant heeft een CI+ licentie voor zijn Enigma hardware.

Posted by theparasol on 19 February 2016 - 09:45

Absoluut niet, is volledig officieel, je kunt zelfs nakijken dat hun certificering officieel is hier:

 

http://www.symantec....stomers#secTab2

 

Device manufacturer host -> "Impex-Sat GmbH & Co. KG"




#526076 2016/01/10 Online update blijft hangen bij bootlogo

Posted by theparasol on 19 January 2016 - 22:23

En een keer overschrijven en daarna dan kun je alles: image updaten, rebooten... bedenk het maar!

Loopt bij mij al meer dan een week stabiel, ik durf het nog bouter te zeggen: reboot en opstarten gaat zelfs sneller :blink:




#524080 2016/01/10 Online update blijft hangen bij bootlogo

Posted by theparasol on 11 January 2016 - 19:48

modprobe van de drivers gedaan + dmesg output?

 

XP1000_3 en XP1000_4 worden niet correct geinstalleerd.

Op gegeven moment ging zelfs ipv6 (netwerk driver) niet meer geinstalleerd worden.

 

Het lijkt erop dat de nieuwe kernel de drivers te vlot aftrapt, ik denk dat de eerste ronde goed gaat omdat er dan nog van alles uitgezocht en goed gezet moet worden qua modules.

De volgende ronde (reboot!) trapt hij het pijlsnel achter elkaar af en dan gaat het blijkbaar fout.

 

Als diry fix heb ik /etc/init.d/modutils.sh aangepast en overal 3 seconden pauze tussen gezet en dan werkt het prima.

 

Kortom na flashen dit bestand vervangen en je kunt de box weer betrouwbaar gebruiken totdat er een permanente oplossing voor gekomen is.

Attached Files




#523484 2016/1/8 STB blijft hangen na huidige update

Posted by theparasol on 9 January 2016 - 12:41

bij XP1000 is dit terug in orde.

 

En ik heb de indruk dat door de nieuwe 4.0.1 kernel het netwerk verkeer ook veel beter afgehandeld wordt.

FTP gaat lekker vlot en mijn "radiostreams" starten ook veel sneller.