Springen naar inhoud


engineerkhan15

Lid geworden: 12 dec 2010
Offline Laatste activiteit: 26 jun 2020 07:11
-----

#920067 Howto build unofficial pli for your unsupported receiver

Geplaatst door engineerkhan15 aan 16 augustus 2018 - 16:09

Feedback on K1 Pro, today's test image:

 

Boot: OK

Resolution: Full screen display with Fullnight HD skin (not on default skin).

Remote: Working

Wifi: Working , network scan OK, connected successfully (hurray!). The only issue now is in entering password for wifi network because the remote does not work as it should do. On pressing number keys, it only types numerals, no alphabets typing possible. I was able to give password by using wireless keyboard.

Tuner: 4 tuner modes visible. DVB-S scan done, found channels on some initial TPs. No video or audio on saved channels. PAT error message after few seconds, as earlier. Channels and tuner settings lost after reboot.

 

Hats off to Persian Prince and moham96 for their efforts in this regard :) :) :).

root@k1pro:~# lsmod
Module                  Size  Used by
mali                  241508  0
e2_procfs              23242  0
dhd                   723159  0
r848a                  34309  1
avl6862               266253  1
aml_fe                  5178  0
aml                    91002  1 aml_fe



#910840 Howto build unofficial pli for your unsupported receiver

Geplaatst door engineerkhan15 aan 24 juli 2018 - 15:25

Here are new test images for K1 Pro, K2 Pro (S905) & K3 Pro, compiled after latest changes.

 

K1 Pro:

http://www.mediafire...24-2_sdcard.zip

 

K2 Pro (S905):

http://www.mediafire...24-1_sdcard.zip

 

K3 Pro:

http://www.mediafire...24-1_sdcard.zip




#910556 Howto build unofficial pli for your unsupported receiver

Geplaatst door engineerkhan15 aan 23 juli 2018 - 18:47

http://www.mediafire...sdcard.zip/file




#891094 Q: OpenMultiboot & Zgemma H5

Geplaatst door engineerkhan15 aan 24 mei 2018 - 20:20

Try this one.

Bijgevoegde Bestanden




#886234 Howto build unofficial pli for your unsupported receiver

Geplaatst door engineerkhan15 aan 14 mei 2018 - 18:13

 

May be we add usb tuner alien5 config of kernel but I dont know e2procfs support usb tuner. ─░ merge DST alien5 and k1 pro. Only dvb part is different

 

root@alien5:~#lsusb

Bus 001 Device 002: ID 05e3:0610
Bus 001 Device 001: ID 1d6b:0002
Bus 002 Device 001: ID 1d6b:0003
Bus 001 Device 003: ID 734c:5925 (TBS 5925)
Bus 001 Device 004: ID 187f:0600 (ISDB TUNER MYGICA S270) = same GENIATEK S880)

Bus 001 Device 005: ID 1a2c:0023
root@alien5:~#

root@alien5:~#
opkg install kernel-module-smsdvb kernel-module-smsmdtv kernel-mod
dule-smssdio kernel-module-smsusb \
> enigma2-plugin-drivers-dvb-usb-siano firmware-dvb-siano


Couldn't find anything to satisfy 'kernel-module-smssdio'.

Unknown package 'kernel-module-smsdvb'.
Unknown package 'kernel-module-smsmdtv'.

Unknown package 'kernel-module-smssdio'.
Unknown package 'kernel-module-smsusb'.
Package enigma2-plugin-drivers-dvb-usb-siano (1.0-r0) installed in root is up to date.
Package firmware-dvb-siano (1.0-r0) installed in root is up to date.

Collected errors:

 * opkg_solver_install: Cannot install package kernel-module-smsdvb.
 * opkg_solver_install: Cannot install package kernel-module-smsmdtv.
 * opkg_solver_install: Cannot install package kernel-module-smssdio.
 * opkg_solver_install: Cannot install package kernel-module-smsusb.
root@alien5:~#

 

My ftp don't work. I have all missing ipk files to test usb dvb ISDB-T tuner.

 

Sometimes, FTP does not connect successfully. I my case it first connected successfully but after making some modifications to the filesystem it did not connect and only telnet was connecting. Then I re-installed the image on sd card again and it was all OK again. You may also try by re-installing it.




#884887 Howto build unofficial pli for your unsupported receiver

Geplaatst door engineerkhan15 aan 12 mei 2018 - 18:54

user: root

pass: pure2




#884665 Howto build unofficial pli for your unsupported receiver

Geplaatst door engineerkhan15 aan 12 mei 2018 - 13:20

Here is the new link:

https://mega.nz/#!G4...GVSEigidTcBuh1A




#884488 Howto build unofficial pli for your unsupported receiver

Geplaatst door engineerkhan15 aan 12 mei 2018 - 05:41

Last night, I tried Enigma2 image of other team build for Amiko Alien 5 on my KI Pro (both have same chip, S905D).

Here are my test results:

The box booted well through SD card without doing any modification (adding or replacing anything extra on the SD card).

KI Pro remote did not work.

But I was able to go through initial setup by using wireless keyboard.

After setup, I was able to access OpenWebIF and use remote control in it.

I was also able to access filesystem by using FTP (DCC) on LAN connection.

Tuner used in the Alien 5 is different, so there were no drivers for KI Pro tuner Avl6862 in this Enigma2.

I tried to add the tuner driver (ko) files to the path "/lib/modules/3.14.29/kernel/drivers" but it did not work.

Any suggestions, for adding drivers for tuner in this image?




#881377 Howto build unofficial pli for your unsupported receiver

Geplaatst door engineerkhan15 aan 4 mei 2018 - 02:26

A new Amlogic box is coming soon "Amiko Alien 5" with specs "Amlogic 905D, 2GB RAM, DVB-S2/T2/C combo Tuner & wifi" (seems similar to Mecool KI Pro). Moreover, it will be supporting Enigma2 and testing of a Pur-E2 image is under progress. So we may have some lead for Mecool devices from this.

 

2470885ae9a80ddedeb.jpg




#879964 Howto build unofficial pli for your unsupported receiver

Geplaatst door engineerkhan15 aan 1 mei 2018 - 14:43

My laptop pentium D and ver pain compile openpli 2-3 days. I use ubuntu 16.04.

I can help you in compilation process, I am free in the evenings. I have Dell Desktop with Core i5 and 8 GB RAM and 2MBPs DSL connection. Please prepare meta and send me the link with instructions to compile. 




#879187 Howto build unofficial pli for your unsupported receiver

Geplaatst door engineerkhan15 aan 29 april 2018 - 20:48

WeTek not update meta and no support wp2 enigma from one year. Amlogic company not support enigma kernel and any dev want to help in her

Please try to make meta layer for at least K I Pro, K II Pro and KIII Pro.




#877441 Howto build unofficial pli for your unsupported receiver

Geplaatst door engineerkhan15 aan 26 april 2018 - 18:54

Still I don't get it when there is no dvb driver for these boxes what are you going to do with enigma2? You can't watch dvb-t or dvb-s ...

Can't we use these drivers? These are dvb drivers for tuner Avl-6862 and are working very well in LibreELEC:

https://github.com/e...amlogic/dvb-avl




#876142 Howto build unofficial pli for your unsupported receiver

Geplaatst door engineerkhan15 aan 24 april 2018 - 12:17

@Persian Prince:

 

In order to add generic machine configuration for KI Plus (S905), KII Pro (S905), KI Pro (S905D) and KIII ProI (S912), I have tried to create an s905.conf file which is available here:

http://github.com/en...op/conf/machine

 

Moreover, I have also tried to clone other necessary files here:

http://github.com/en...amlogic-3.14.29 

 

In addition to those, I want to use following files (dvb drivers and device tree files) in the build:

http://github.com/kszaq/dvb_tv-aml

 

http://github.com/ks...05-device-trees

 

Can you look at all these and help me in adding these to your meta-amlogic (if possible)?

 




#872737 Howto build unofficial pli for your unsupported receiver

Geplaatst door engineerkhan15 aan 18 april 2018 - 12:50

Error while compiling for Wetek Play2:

WARNING: firmware-ap6210-1.0-r0 do_populate_lic: Could not copy license file /home/tahir/openpli-oe-core/build/tmp/work/all-oe-linux/firmware-ap6210/1.0-r0/LICENSE-CLOSE to /home/tahir/openpli-oe-core/build/tmp/work/all-oe-linux/firmware-ap6210/1.0-r0/license-destdir/firmware-ap6210/LICENSE-CLOSE: [Errno 2] No such file or directory: '/home/tahir/openpli-oe-core/build/tmp/work/all-oe-linux/firmware-ap6210/1.0-r0/LICENSE-CLOSE'
ERROR: firmware-ap6210-1.0-r0 do_populate_lic: QA Issue: firmware-ap6210: LIC_FILES_CHKSUM points to an invalid file: /home/tahir/openpli-oe-core/build/tmp/work/all-oe-linux/firmware-ap6210/1.0-r0/LICENSE-CLOSE [license-checksum]
WARNING: amremote-1.0-r0 do_package_qa: QA Issue: No GNU_HASH in the elf binary: '/home/tahir/openpli-oe-core/build/tmp/work/aarch64-oe-linux/amremote/1.0-r0/packages-split/amremote/usr/bin/remotecfg' [ldflags]
ERROR: firmware-ap6210-1.0-r0 do_package_write_ipk: The recipe firmware-ap6210 is trying to install files into a shared area when those files already exist. Those files and their manifest location are:
  /home/tahir/openpli-oe-core/build/tmp/deploy/ipk/all/firmware-ap6210_1.0-r0_all.ipk
    (matched in manifest-allarch-firmware-ap6210.package_write_ipk)
Please verify which recipe should provide the above files.

The build has stopped, as continuing in this scenario WILL break things - if not now, possibly in the future (we've seen builds fail several months later). If the system knew how to recover from this automatically it would, however there are several different scenarios which can result in this and we don't know which one this is. It may be you have switched providers of something like virtual/kernel (e.g. from linux-yocto to linux-yocto-dev), in that case you need to execute the clean task for both recipes and it will resolve this error. It may be you changed DISTRO_FEATURES from systemd to udev or vice versa. Cleaning those recipes should again resolve this error, however switching DISTRO_FEATURES on an existing build directory is not supported - you should really clean out tmp and rebuild (reusing sstate should be safe). It could be the overlapping files detected are harmless in which case adding them to SSTATE_DUPWHITELIST may be the correct solution. It could also be your build is including two different conflicting versions of things (e.g. bluez 4 and bluez 5 and the correct solution for that would be to resolve the conflict. If in doubt, please ask on the mailing list, sharing the error and filelist above.
ERROR: firmware-ap6210-1.0-r0 do_package_write_ipk: If the above message is too much, the simpler version is you're advised to wipe out tmp and rebuild (reusing sstate is fine). That will likely fix things in most (but not all) cases.
ERROR: firmware-ap6210-1.0-r0 do_package_write_ipk: Function failed: sstate_task_postfunc
ERROR: Logfile of failure stored in: /home/tahir/openpli-oe-core/build/tmp/work/all-oe-linux/firmware-ap6210/1.0-r0/temp/log.do_package_write_ipk.31142
ERROR: Task (/home/tahir/openpli-oe-core/pli-extras/meta-amlogic/recipes-linux/linux-firmwares/firmware-ap6210.bb:do_package_write_ipk) failed with exit code '1'
ERROR: firmware-ap6210-1.0-r0 do_populate_sysroot: The recipe firmware-ap6210 is trying to install files into a shared area when those files already exist. Those files and their manifest location are:
  /home/tahir/openpli-oe-core/build/tmp/sysroots-components/all/firmware-ap6210/lib/firmware/brcm/ap6210-nvram.txt
    (matched in manifest-allarch-firmware-ap6210.populate_sysroot)
  /home/tahir/openpli-oe-core/build/tmp/sysroots-components/all/firmware-ap6210/lib/firmware/brcm/fw_bcm40181a2.bin
    (matched in manifest-allarch-firmware-ap6210.populate_sysroot)
  /home/tahir/openpli-oe-core/build/tmp/sysroots-components/all/firmware-ap6210/sysroot-providers/firmware-ap6210
    (matched in manifest-allarch-firmware-ap6210.populate_sysroot)
Please verify which recipe should provide the above files.

The build has stopped, as continuing in this scenario WILL break things - if not now, possibly in the future (we've seen builds fail several months later). If the system knew how to recover from this automatically it would, however there are several different scenarios which can result in this and we don't know which one this is. It may be you have switched providers of something like virtual/kernel (e.g. from linux-yocto to linux-yocto-dev), in that case you need to execute the clean task for both recipes and it will resolve this error. It may be you changed DISTRO_FEATURES from systemd to udev or vice versa. Cleaning those recipes should again resolve this error, however switching DISTRO_FEATURES on an existing build directory is not supported - you should really clean out tmp and rebuild (reusing sstate should be safe). It could be the overlapping files detected are harmless in which case adding them to SSTATE_DUPWHITELIST may be the correct solution. It could also be your build is including two different conflicting versions of things (e.g. bluez 4 and bluez 5 and the correct solution for that would be to resolve the conflict. If in doubt, please ask on the mailing list, sharing the error and filelist above.
ERROR: firmware-ap6210-1.0-r0 do_populate_sysroot: If the above message is too much, the simpler version is you're advised to wipe out tmp and rebuild (reusing sstate is fine). That will likely fix things in most (but not all) cases.
ERROR: firmware-ap6210-1.0-r0 do_populate_sysroot: Function failed: sstate_task_postfunc
ERROR: Logfile of failure stored in: /home/tahir/openpli-oe-core/build/tmp/work/all-oe-linux/firmware-ap6210/1.0-r0/temp/log.do_populate_sysroot.30311
ERROR: Task (/home/tahir/openpli-oe-core/pli-extras/meta-amlogic/recipes-linux/linux-firmwares/firmware-ap6210.bb:do_populate_sysroot) failed with exit code '1'
NOTE: Tasks Summary: Attempted 5766 tasks of which 5585 didn't need to be rerun and 2 failed.

Summary: 2 tasks failed:
  /home/tahir/openpli-oe-core/pli-extras/meta-amlogic/recipes-linux/linux-firmwares/firmware-ap6210.bb:do_package_write_ipk
  /home/tahir/openpli-oe-core/pli-extras/meta-amlogic/recipes-linux/linux-firmwares/firmware-ap6210.bb:do_populate_sysroot
Summary: There were 6 WARNING messages shown.
Summary: There were 7 ERROR messages shown, returning a non-zero exit code.
Makefile:125: recipe for target 'image' failed
make: *** [image] Error 1




#871735 Howto build unofficial pli for your unsupported receiver

Geplaatst door engineerkhan15 aan 16 april 2018 - 14:29

Here is today's compiled image for Wetek Play 2 if anyone is interested.

http://www.mediafire...rd-16042018.zip