Jump to content


Non Disclosed

Member Since 2 Feb 2011
Offline Last Active 10 Oct 2012 12:54
-----

#252244 Oscam ervaringen, vragen en antwoorden

Posted by Non Disclosed on 5 February 2012 - 18:46

Sorry maar mensen moeten COOLDOWN NIET GEBRUIKEN!!! Het is een bullshit commando dat dient voor overclockte kaarten!!
Haal het eruit, want het zet je kaart tijdelijk uit!!! Vandaar dat je problemen hebt.
Zet gewoon de limieten 3ECM om 10SEC en je hebt geen enkel probleem.
We hebben COOLDOWN getest en na 50 seconden gaat je kaart UIT voor 1,2 seconde!!! Moet de source nog nakijken, maar 1200 = 1,2 seconden, ben ik zeker van, dus heb je haperingen.
Veel OScam funkties hebben een max van 99 sec, waarna het msec wordt, dus 100 is geen 100sec maar 100msec!!!
DAT is WAAROM HET HAPERT!!!, elke 50 seconden gaat de kaart 1,2sec UIT...moet de source-code nalezen, maar ben er vrij zeker van, als je het eruit haalt is het probleem weg.


#231218 Openpli naar SH4 ontvangers porten?

Posted by Non Disclosed on 13 November 2011 - 17:27

@ bas..
Werkt ie al?????


Nog niet mee bezig geweest, het spul zit heel anders ineen en ik heb ondertussen een goede image voor mijn doosje gevonden en die ben ik aan het bewerken zodat hij doet wat ik wil :)


#227319 Openpli naar SH4 ontvangers porten?

Posted by Non Disclosed on 29 October 2011 - 12:37

Werken is een groot woord, het is meer van de ene crash naar de andere lopen.


#227218 Openpli naar SH4 ontvangers porten?

Posted by Non Disclosed on 28 October 2011 - 18:15

Hij is nu goed bezig zodat hij, ondanks zijn slechte start, nu wel een pijltje omhoog kan krijgen van mij.


Dank je, om een of andere reden start ik altijd slecht, te ongeduldig misschien? :huh:

Anyway, ben de OpenPli source aan het downloaden, zal het uitpakken en op mijn eigen server opnieuw online zetten, want het duurt steeds langer om een stukje te downloaden.


#227001 Openpli naar SH4 ontvangers porten?

Posted by Non Disclosed on 27 October 2011 - 12:00

Ok, ga ik aanpassen en nog eens 2 uur de hond uitlaten.
Ik krijg stilaan het zware vermoeden dat de code van die mannen enorm veel oude zaken bevat.


#226907 Openpli naar SH4 ontvangers porten?

Posted by Non Disclosed on 26 October 2011 - 23:59

Ben al een eind verder, maar nu krijg ik dit....wat is dit??

configure: found dvb version 5
checking pkg-config is at least version 0.9.0... yes
checking for BASE... no
configure: error: Package requirements (freetype2 fribidi gstreamer-0.10 gstreamer-pbutils-0.10 libdvbsi++ libpng libxml-2.0 sigc++-1.2) were not met:
No package 'gstreamer-0.10' found
No package 'gstreamer-pbutils-0.10' found
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
Alternatively, you may set the environment variables BASE_CFLAGS
and BASE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
make: *** [/home/bas/tdt/cvs/apps/enigma2-nightly/config.status] Fout 1
root@workstation:~/tdt/cvs/cdk#
root@workstation:~/tdt-amiko/tdt/cvs/cdk#

Ik denk dat ik die packages ergens moet gaan halen.
Maar waar?
En waar moet ik ze steken?


#226848 Openpli naar SH4 ontvangers porten?

Posted by Non Disclosed on 26 October 2011 - 20:54

Juist een vriend gebeld die zeer goed thuis is in C en compilers, die zei me de makefile te onderzoeken en domweg alle wget regels eruit te lichten.
Mijn probleem is de onbekendheid met C compilers, gewoonlijk volg ik domweg de instructies en is het ook niet zo omvangrijk als dit.
Wel ooit een Cobalt Raq2 image gemaakt, maar die wou direct compileren :)
Ik wou toch altijd eens C leren, dus dit is een mooie gelegenheid eraan te beginnen, heb de boeken al een tijdje liggen.
Met wget en gewone linux commando's red ik me wel, dacht aan iets als "cat makefile | grep wget...... > filecheck.sh" maar dat gaat wel lukken ;)


#226831 Openpli naar SH4 ontvangers porten?

Posted by Non Disclosed on 26 October 2011 - 20:15

Heel fijn!! Zal eens een scriptje maken van die file en dan zien op welke een error verschijnt.

BEDANKT KEREL!!

Want het gaat vaak over verplaatste directories of de files zijn domweg niet meer op die bewuste servers.
Een voorbeeld is deze: http://www.mplayerhq...ses/dvdnav-old/ de reqest van het compilescript is een andere directory.

Ik heb nu 3 files met de hand moeten halen, en er is weer een compile bezig, hopenlijk is dat het laatste anders wordt het scripten om ze allemaal te halen op voorhand.


#226543 Openpli naar SH4 ontvangers porten?

Posted by Non Disclosed on 25 October 2011 - 13:53

Daar staat het inderdaad tussen, maar als ik diezelfde file bekijk die ik via git heb gehaald dan staat hij er niet in.

git clone git://gitorious.org/open-duckbox-project-sh4/tdt.git

Ook op de repo's van andere images is mc en nano niet terug te vinden.
Waarom zouden ze het niet mee compileren (in geen enkele image) als het bestaat? ;)


#226508 Openpli naar SH4 ontvangers porten?

Posted by Non Disclosed on 25 October 2011 - 10:21

Niemand tips? Want daar was het me om te doen.


#226497 Openpli naar SH4 ontvangers porten?

Posted by Non Disclosed on 25 October 2011 - 09:25

Ben me al aan het inlezen, want ik moet enkel de top-layer hebben. http://www.saunalaht...ment_toolchain/
De onderliggende Linux is er al lang, dus moet het mogelijk zijn de top van OpenPli te gebruiken op de basis die er al is.
Aangezien die allang Enigma2 draait, maar verre van zoals ik het wil, zit er dus niets anders op dan eens deftig te gaan lezen en dan de boel op een hoop te smijten en door de compiler te jassen.


#226460 Openpli naar SH4 ontvangers porten?

Posted by Non Disclosed on 24 October 2011 - 22:58

Ik zit niet te wachten op zeveraars, ik zeg dat OpenPli op de Mips werkt, de Amiko kan Mips verwerken, Little en Big Indian = Compatibel.
Aangezien OpenPli op Mips werkt is er geen reden dat hij op de Sh4 zou kunnen werken.
Tot hiertoe hoor ik enkel zeveraars aan die een mening hebben.
Sorry die mening kan me geen kloten schelen.

Ik heb een paar dingen gevraagd:

1 Is het mogelijk?

2 Hoe kan ik het compileren?

3 Kan dit?

Het enige wat ik terug krijg is een zooitje gezever van lieden die een mening hebben maar verder zonder antwoord.
Als je het niet weet of niet kan helpen, jemig hou dan je mond!
Ik heb geen intresse in opinies, ik heb enkel interesse in pogingen OpenPli daar te krijgen.

En aan de gasten alla WanWizzard, het heeft NIETS met fabrikanten te maken, die drivers zijn er allang!! Zoek even op RSP Amiko en je vind genoeg images en code.
Er is geen reden dat OpenPli dit niet opvolgt of een poging wil wagen.

Sorry ik heb geen interesse te zeveren met mensen die niet OpenPli programmeren.
Ik test graag of compileer graag, geef me de gasten die OpenPli maken, ik help graag.
En stop met te zeuren over drivers, die zijn er overal, gewoon een RSP_Image bekijken, heel de zooi is opensource, net als OpenPli.

Als ik dit gezeur geweten had over OpenPli dan had ik nooit 20 euro gegeven, want ik gaf het om iets te steunen, waar is dat geld eigenlijk ooit geraakt? Bij de programmeurs van Enigma2??


#226454 Openpli naar SH4 ontvangers porten?

Posted by Non Disclosed on 24 October 2011 - 22:40

Je snapt er nog steeds niks van blijkbaar. Dus zal ik het nog een keer uitleggen:

Heel Enigma2 is gebouwd rond de dvbapi, versie 5 op dit moment. Als die code moet gaan draaien op een platform waar deze api niet op beschikbaar is (en dat is het geval hier, maar ook bij de andere op dit platform gebaseerde hardware) dan moet een groot deel van de C code van Enigma2 worden aangepast, niet alleen de api calls zelf, maar in veel gevallen ook de logica er om heen.

In zijn huidige vorm valt OpenPLi dus niet te compileren, want er kunnen allerlei dependencies ten aanzien van die api niet worden geresolved.

Deze vraag is zoals de source van een Windows applicatie pakken, en deze omzetten naar Gnome. Allebei op een X86 processor, dat kan niet moeilijk zijn, toch?


Zever, die box draait een SH4, en die kan MIPS verwerken, dus is heel je verhaal onzinnig aangezien er MIPS versies van OpenPli zijn.


#226452 Openpli naar SH4 ontvangers porten?

Posted by Non Disclosed on 24 October 2011 - 22:38

Triest, men stemt me naar beneden...heel triest....
Want als je de ontvanger niet kent dan kan je er niet over oordelen, zou je het apparaat kennen dan zou je het met me eens zijn dat het een OpenPli verdient.
Kan me niet voorstellen dat er mensen stemmen die het aparaat kennen.

Want wat is het meest voorkomende probleem als je SAT aan mensen probeerd te "verkopen"?
De prijs, en tweede hoop je dat het stabiel is....

Een DM600PVR kost nog altijd 160 euro!
Een Vu+ Solo HD kost nog altijd 250 euro!!

Een Amiko 8900HD kost amper 150!!

Probeer dan iemand te overtuigen als ze de kabel-HD ontvanger "GRATIS" krijgen!
Tel buiten de ontvanger nog eens een 200 euro voor een tripple-head-schotel, da's 350! Euro met een Amiko!!!
Maar met een DM? >500 Euro!

Nog iemand die me gaat vertellen dan OpenPli een Amiko versie verdient?
Die Amiko 8900 is beter dan een DM600PVR, probeer het en je wil geen DM600PVR meer, met zekerheid.
Trouwens ook geen andere DM tenzij je een ingebouwde harddisk wenst.

Mijn ding is simpel, met deze ontvanger kan je mensen overtuigen zo goedkoop is die.....en met de anderen?


#226448 Openpli naar SH4 ontvangers porten?

Posted by Non Disclosed on 24 October 2011 - 22:11

En dat is nu precies zever.
Ik heb diverse Linux versies gedraaid over diverse platvormen.
Altijd weer kom je uit op drivers en libraries of die wel of niet bestaan.
Developers gaan er altijd vanuit dat die bestaan, pas als ze niet bestaan gaat het mis.
Developers roepen API's aan, en als die niet bestaan worden die lui zenuwachtig.
Of ga je me vertellen dat er diverse developers bestaan voor Mips (SH4 is OOK MIPS compatibel!) en PowerPC.
Kom op, PowerPC en Mips zijn twee volledig verschillende platformen, waar het aankomt op de compiler om de juiste code te genereren.
SH4 is niet veel anders, sterker nog het is MIPS compatibel, zowel Little als Big Indian...maar beter is te compileren voor SH4 CPU om optimale prestaties te krijgen.
Enigma is geen kernel level app, het zit een beetje hoger dan dat...dus hoe kan ik het compileren voor SH4 of kan iemand het doen?
Als Linux (OS) alles ondersteund, dan kan compilatie van APPS alla Enigma niet een enorm probleem zijn zolang de API's kloppen.
Ik begin een beetje het idee te krijgen dan niemand het maar wil proberen en het op voorhand afschiet.
Koop een Amiko, kost geen drol, maar heeft OpenPli nodig!!! En het kan, want OpenPli is CPU onafhankelijk....ze ondersteunen genoeg CPU's om het een poging te wagen.