Jump to content


pietjepuk

Member Since 5 Jan 2008
Offline Last Active 12 Nov 2021 11:07
-----

Posts I've Made

In Topic: small and little text on lcd after vuduo to vuduo4kse migration

6 November 2021 - 19:43

No actual xml in your case here.https://github.com/O...op/data/display This should be solved for these models i think. DUO4K and DUO4KSE .

Unfortunately not, installed the one from there already ;-(


In Topic: small and little text on lcd after vuduo to vuduo4kse migration

5 November 2021 - 16:23

Info from Enigma2 in debug mode:

ENIGMA_DEBUG_LVL=4                                                                                                                                              

[eInit] + (9) gLCD                                                                       

[eFbLCD] /dev/fb1: No such file or directory                                             

[eFbLCD] framebuffer /dev/fb1 not available                                              

[eDboxLCD] xres=480, yres=320, bpp=32 lcd_type=3                                         

[eLCD] (480x320x32) buffer 0xb5e2a008 614400 bytes, stride 1920                          

[gLCDDC] resolution: 480x320x32 stride=1920                                              

[eInit] + (9) GFBDC                                                                      

[fb] /dev/fb0: 21600k video mem 


In Topic: small and little text on lcd after vuduo to vuduo4kse migration

5 November 2021 - 15:34

Please check this thread:

 

https://forums.openp...u-uno-4kse-lcd/

 

May be the Duo4kse has the same LCD as the uno4kse

 

so may be interesting to display the LCD resolution like explained in the other thread.

The problem I seem to have is that no images generated via skins or lcd4linux are actually written to the display. What is shown seems to be a fallback from a situation where skin images cannot be written to the screen. Is there anywhere in a setting a link to the entry in /dev to be used for the lcd display by the enigma2 process?

I've tried a few different "display" skins, no change visible on the actual display when I try different skins

 

I've been looking at the /dev directory, should there be a lcd0 device entry? when looking at box directory I see

root@vuduo4kse:/dev# ls -l dbox

lrwxrwxrwx    1 root     root             6 Jan  1  1970 fp0 -> ../fp0

-rw-r--r--    1 root     root             5 Nov  5 14:42 lcd0

lrwxrwxrwx    1 root     root             8 Jan  1  1970 oled0 -> ../oled0

 
Should lcd0 also be a symbolic link to ../lcd0? and a /dev/lcd0?

In Topic: lcd bug in openpli-8.1-release-vuduo4kse-20211031_usb.zip

4 November 2021 - 19:13

You're looking in the wrong place, those files live in /usr/share/enigma2/skin_default.

Is that not the place for the screen skin defaults? The LCD display seem to have its own in the display subdir


In Topic: lcd bug in openpli-8.1-release-vuduo4kse-20211031_usb.zip

4 November 2021 - 18:53

That wouldn't be good,

 

The Duo4KSE uses the same skin_display as the Duo4K and the Solo4K. I don't miss anything on my Duo4K, can you give examples of what is missing?

 

edit:

 

I see only 3 png's being used, hdd.png, record.png and stream.png, and they are all present in the icons directory in skin_default.

I checked the duo4kse and uno4kse distribution, in both there is only one file in the display/skin_default directory.

There must be more stuff missing as the actual display does not show any correct data.

 

Just checked vuduo4k image too, same situation