Jump to content


Photo

Openpli4 transmission

transmission openpli4

  • Please log in to reply
61 replies to this topic

#1 rolamento

  • Member
  • 14 posts

0
Neutral

Posted 14 October 2013 - 09:55

Hi,

 

When trying to install transmission on openpli4:

 

depencies not satisfy

Librtmp0  (>= 2.4+git487+5ba573a)   cannot install package

 

Cheers



Re: Openpli4 transmission #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 46,349 posts

+749
Excellent

Posted 14 October 2013 - 11:51

Already reported (about 20 times...)


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Openpli4 transmission #3 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 14 October 2013 - 12:47

but for the first time with an actual error message.
Fixed in the next build.

Re: Openpli4 transmission #4 rolamento

  • Member
  • 14 posts

0
Neutral

Posted 14 October 2013 - 16:04

Glade to help!

 

Cheers



Re: Openpli4 transmission #5 Radionov123

  • Senior Member
  • 59 posts

+1
Neutral

Posted 14 October 2013 - 19:45

but for the first time with an actual error message.Fixed in the next build.


http://openpli.org/f...n-others/page-4
DVB-S(2):13E;9E;5E;1W;5W@0,9m+19,2E;23,5E;28,2E;36E@1,1mDVB-TOpenPLi 4,0 betaDM8000HD + 1GB usb-stick + 1TB HDD

Re: Openpli4 transmission #6 Radionov123

  • Senior Member
  • 59 posts

+1
Neutral

Posted 17 October 2013 - 16:53

but for the first time with an actual error message.Fixed in the next build.


With today's update the problem is sadly not fixed....the error message is still the same...
DVB-S(2):13E;9E;5E;1W;5W@0,9m+19,2E;23,5E;28,2E;36E@1,1mDVB-TOpenPLi 4,0 betaDM8000HD + 1GB usb-stick + 1TB HDD

Re: Openpli4 transmission #7 raus81

  • Member
  • 1 posts

0
Neutral

Posted 19 October 2013 - 09:24

Hi, I solved installing librtmp1 instead of librtmp0, symlinking librtmp.so.1 to librtmp.so.0 in /usr/lib then installing transmission with --force-depends. Hope it will help!



Re: Openpli4 transmission #8 rolamento

  • Member
  • 14 posts

0
Neutral

Posted 19 October 2013 - 16:10

With today update the error persists.

 

Cheers



Re: Openpli4 transmission #9 Dream1975

  • Senior Member
  • 1,596 posts

+14
Neutral

Posted 20 October 2013 - 11:58

Hi, I solved installing librtmp1 instead of librtmp0, symlinking librtmp.so.1 to librtmp.so.0 in /usr/lib then installing transmission with --force-depends. Hope it will help!

Is there a manual way to do this (or maybe a way OpenPLi will do this automatically)?


Mutant HD2400, OpenPLi RC, 2x DVB-C & 2x DVB-S

Mutant HD51, OpenPLi RC, 1x DVB-C & 1x DVB-S

Wavefrontier T55 (Astra 1,2,3 en HB)

Smartcards Ziggo (Irdeto) and CDS (Seca) on Oscam

 


Re: Openpli4 transmission #10 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 20 October 2013 - 12:58

This is the control file of the transmission package in the openpli 4 feed:
Package: transmission
Version: 2.73-r1.1
Description: transmission version 2.73-r1.1
 Transmission is a BitTorrent client w/ a built-in Ajax-Powered Webif GUI.
Section: network
Priority: optional
Maintainer: OE-Core Developers <openembedded-core@lists.openembedded.org>
License: GPLv2
Architecture: mips32el
OE: transmission
Homepage: www.transmissionbt.com/
Depends: libc6 (>= 2.18), libcrypto1.0.0 (>= 1.0.1e), libz1 (>= 1.2.8), librtmp1 (>= 2.4+git490+a9f353c), libcurl4 (>= 7.32.0), libevent (>= 2.0.21)
Recommends: update-rc.d
Source: http://mirrors.m0k.org/transmission/files/transmission-2.73.tar.bz2;name=archive file://init file://config file://configure-kill-intl-check.patch
so if your transmission package is still complaining about a missing librtmp0 package, you are not using the transmission package from the openpli 4 feed, because as you can see we fixed that (about a week ago)

Re: Openpli4 transmission #11 Dream1975

  • Senior Member
  • 1,596 posts

+14
Neutral

Posted 20 October 2013 - 13:31

I still use the install from last weekend. I'll do a new flash and test again.


Mutant HD2400, OpenPLi RC, 2x DVB-C & 2x DVB-S

Mutant HD51, OpenPLi RC, 1x DVB-C & 1x DVB-S

Wavefrontier T55 (Astra 1,2,3 en HB)

Smartcards Ziggo (Irdeto) and CDS (Seca) on Oscam

 


Re: Openpli4 transmission #12 Dream1975

  • Senior Member
  • 1,596 posts

+14
Neutral

Posted 20 October 2013 - 13:58

With Mediaportal/IPTV list updater and tsmedia I still get the error. Is there a way to let apps know to make use of the new libtrmp (like a symlink or something)?

Attached Files


Mutant HD2400, OpenPLi RC, 2x DVB-C & 2x DVB-S

Mutant HD51, OpenPLi RC, 1x DVB-C & 1x DVB-S

Wavefrontier T55 (Astra 1,2,3 en HB)

Smartcards Ziggo (Irdeto) and CDS (Seca) on Oscam

 


Re: Openpli4 transmission #13 Radionov123

  • Senior Member
  • 59 posts

+1
Neutral

Posted 20 October 2013 - 16:27

so if your transmission package is still complaining about a missing librtmp0 package, you are not using the transmission package from the openpli 4 feed, because as you can see we fixed that (about a week ago) 

 

Should I set up OpenPli 4.0 feed manually, or ...... ? As I see after todays update  - in the feed there is still transmission 2.60, not 2.73:Attached File  TMission.jpg   159.44KB   39 downloads

 

 


Edited by Radionov123, 20 October 2013 - 16:29.

DVB-S(2):13E;9E;5E;1W;5W@0,9m+19,2E;23,5E;28,2E;36E@1,1mDVB-TOpenPLi 4,0 betaDM8000HD + 1GB usb-stick + 1TB HDD

Re: Openpli4 transmission #14 WanWizard

  • Forum Moderator
    PLi® Core member
  • 46,349 posts

+749
Excellent

Posted 20 October 2013 - 16:37

What you see is the GUI, the transmission interface. I presume that hasn't changed, although it would be nice it it's version would be bumped to.

 

2.73 is in the feeds though:

root@vuduo2:~# opkg list | grep transmission
enigma2-plugin-extensions-transmission - 2.60 - Transmission is a BitTorrent client w/ a built-in Ajax-Powered Webif GUI.
transmission - 2.73-r1.1 - transmission version 2.73-r1.1  Transmission is a BitTorrent client w/ a
transmission-client - 2.73-r1.1 - transmission version 2.73-r1.1  Transmission is a BitTorrent client w/ a
transmission-dev - 2.73-r1.1 - transmission version 2.73-r1.1 - Development files  Transmission is a 

Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Openpli4 transmission #15 Radionov123

  • Senior Member
  • 59 posts

+1
Neutral

Posted 20 October 2013 - 17:19

Despite the version in the feeds, It does not work and gives the same error message:

 

 

Attached File  Tmission2.jpg   161.04KB   40 downloads

 

 

And yes, I am using the version from the feeds.

 


DVB-S(2):13E;9E;5E;1W;5W@0,9m+19,2E;23,5E;28,2E;36E@1,1mDVB-TOpenPLi 4,0 betaDM8000HD + 1GB usb-stick + 1TB HDD

Re: Openpli4 transmission #16 WanWizard

  • Forum Moderator
    PLi® Core member
  • 46,349 posts

+749
Excellent

Posted 20 October 2013 - 17:41

Probably as I said because transmission was fixed as pieterg said (that was your initial question, you asked about "the transmission package"), but not the GUI component that you try to install.

 

So that needs to be fixed too.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Openpli4 transmission #17 blzr

  • PLi® Core member
  • 2,008 posts

+99
Good

Posted 20 October 2013 - 18:03

this enigma2-plugin-extensions-transmission - 2.60 is a 3-rd party e2 plugin, which was based on some obsolete transmission version;

removing it from the feed wouldn't be such a bad idea (IIRC it didn't work on OpenPLi for some time, and now it doesn't even install)...

 

the version that works on OpenPLi is transmission 2.73, you can only install it manually from console:

opkg install transmission

True sarcasm doesn't need green font...

Re: Openpli4 transmission #18 Radionov123

  • Senior Member
  • 59 posts

+1
Neutral

Posted 21 October 2013 - 06:55

opkg install transmission gives another error message:

 

root@dm8000:~# opkg install transmission
Installing transmission (2.73-r1.1) to root...
Collected errors:
 * opkg_install_pkg: Package transmission md5sum mismatch. Either the opkg or the package index are corrupt. Try 'opkg update'.
 * opkg_install_cmd: Cannot install package transmission.
root@dm8000:~#
 
after opkg update:
 
Installing transmission (2.73-r1.1) to root...
libcurl4: unsatisfied recommendation for curl-certs
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for transmission:
 *      librtmp0 (>= 2.4+git487+5ba573a) *
 * opkg_install_cmd: Cannot install package transmission.

DVB-S(2):13E;9E;5E;1W;5W@0,9m+19,2E;23,5E;28,2E;36E@1,1mDVB-TOpenPLi 4,0 betaDM8000HD + 1GB usb-stick + 1TB HDD

Re: Openpli4 transmission #19 WanWizard

  • Forum Moderator
    PLi® Core member
  • 46,349 posts

+749
Excellent

Posted 21 October 2013 - 07:49

libcurl has a dependency to libtmp0 too, that has already been reported.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Openpli4 transmission #20 rolamento

  • Member
  • 14 posts

0
Neutral

Posted 21 October 2013 - 12:48

Whenever i update i will test it and report it here.

 

With today update still the same error.

 

Cheers






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users