Jump to content


Photo

MediaPortal dependencies problem.


  • Please log in to reply
28 replies to this topic

#1 Freon

  • Senior Member
  • 213 posts

+2
Neutral

Posted 10 September 2016 - 07:39

 I am running latest upgradeble image Pli4 on my Vu Zero.

Media portal after latest update is not shown in plugins, there are missing dependencies for it.

python-requests_2.11.1+git0+58d855e193-r0.0_mips32el.ipk

python-js2py_0.39+git0+144b1701fa-r0.0_mips32el.ipk

python-cfscrape_1.6.6+git0+5da4af148f-r0.1_mips32el.ipk

I have them as ipk files, bit unable to install it on Pli?!?!

 

log file for mediaportal:

satisfy_dependencies_for: Cannot satisfy the following dependencies for enigma2-plugin-extensions-mediaportal:
 * python-six * python-cfscrape * python-js2py * python-requests (>= 2.0.0) *
 
Any solution for this?

Edited by Freon, 10 September 2016 - 07:39.

MAY THE FORCE BE WITH YOU!


Re: MediaPortal dependencies problem. #2 ian1095

  • Senior Member
  • 460 posts

+6
Neutral

Posted 10 September 2016 - 07:51

Yes find them online and add them to your image.

 

Total pain in the arse and took me over half and hour to find them.

 

Ive not uploaded them because they were not ipk's and many users cannot install files manually,so I thought it best not to confuse them.

 

Ive now nade sure that these new dependencies have been added to my autobackup plugin too,because I dont want to have to be searching for them on my pc or online again if I no longer have them in the future.

 

If you spend the time though you can find the files online and even better if you find them already packed as ipk's for other users to load.

 

Ian.

 

EDIT: just saw you say that you have them already as ipk's and that they wont install.

 

Just unpack them and install manually and they will work.


Edited by ian1095, 10 September 2016 - 07:54.


Re: MediaPortal dependencies problem. #3 Freon

  • Senior Member
  • 213 posts

+2
Neutral

Posted 10 September 2016 - 07:55

I have them, unable to install.

MAY THE FORCE BE WITH YOU!


Re: MediaPortal dependencies problem. #4 Freon

  • Senior Member
  • 213 posts

+2
Neutral

Posted 10 September 2016 - 07:57

Here it is, all complete.

Attached Files


MAY THE FORCE BE WITH YOU!


Re: MediaPortal dependencies problem. #5 sefer

  • Member
  • 3 posts

0
Neutral

Posted 10 September 2016 - 19:17

not working



Re: MediaPortal dependencies problem. #6 sonic1

  • Senior Member
  • 62 posts

+3
Neutral

Posted 10 September 2016 - 20:36

That should be all you need to mips or arm

Attached Files



Re: MediaPortal dependencies problem. #7 kalehrl

  • Senior Member
  • 395 posts

+6
Neutral

Posted 11 September 2016 - 09:21

When I installed the latest MP and the dependencies, my remote control started acting funny.

Whatever button I pressed, volume would turn up to the max and other buttons wouldn't have any function.

I uninstalled it and things became normal.



Re: MediaPortal dependencies problem. #8 thanosga

  • Member
  • 1 posts

0
Neutral

Posted 11 February 2018 - 09:39

Hello friends, I want to ask if i can play subtitles to mediaportal and how will i do it. Please help!!!



Re: MediaPortal dependencies problem. #9 zigzag

  • Senior Member
  • 161 posts

0
Neutral

Posted 9 December 2018 - 20:25

We are using OpenPli 4 but we are unable to update the version of Mediaportal we have installed as it always results in
 
'mediaportal update failed' 'check the update log carefully'
 
but having tried over and over again we can never get it to update so we have not been able to update the last 2 updates
released. 
 
I have tried to manually add the following:
 
python-cfscrape_1.6.6-r0_all.ipk
python-js2py_0.39-r0_all.ipk
python-pyexecjs-node_1.4.0-r0_6.11.2_all.ipk
python-requests_2.9.1-r0_all.ipk
 
but nothing seems to work. It looks like some problem occurs with python-requests to prevent
the plugin from updating in my opinion.
 
I know this is an old issue with OpenPli4 that has been discussed time and time again but it has taken up so much
time trying to resolve it that before we give up and just uninstall it completely we hope that maybe someone may be
able to offer some advice that may result in some success...
 
Thank you very much.


Re: MediaPortal dependencies problem. #10 littlesat

  • PLi® Core member
  • 47,225 posts

+494
Excellent

Posted 9 December 2018 - 21:58

Latest mediaportal required a modern image and that is why it is obsoleted on a ‘ancient’ openpli4

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: MediaPortal dependencies problem. #11 zigzag

  • Senior Member
  • 161 posts

0
Neutral

Posted 10 December 2018 - 13:54

Latest mediaportal required a modern image and that is why it is obsoleted on a ‘ancient’ openpli4

littlesat, we appreciate your kind reply. 

 

Please can you suggest what alternative we have to be able to update the Mediaportal

version we have.

 

We have had the 'mediaportal update failed' 'check the update log carefully'

error message for the last 2 updates released - whenever we attempt an update to the
latest version.
 
We were initially successful in installing MP to our OpenPli 4 image after many attempts..
although i don't know what exactly was the successful process if we had to repeat it!
 
Is there something we  need to install that prevents us from updating?
 
We really are stuck using OpenPli 4 because as reported in another section of this forum,
we cannot use OpenPli 6, 6.1, 6.2 or 7.0 with our IPTV service we subscribe to due to different
issues occurring, either with the video freezing and audio cutting out, or video slowing down and audio cutting out,
or video moving fast and audio cutting out then returning the cutting out again, and in other cases the video breaks up
and audio cuts out.
 
These issues do not occur with the version of OpenPli 4 we are using from September 18th. 
OpenPli is the only stable version for our IPTV to work flawlessly but we have the MP issue where we either take many attempts
to successfully install or we are currently unable to update the version we have to the latest.
 
We assume we have all dependent files installed for the plugin to have initially installed.
 
Any help would be very much appreciated as we would prefer to keep OpenPli as our image if possible.
 
installed

Edited by zigzag, 10 December 2018 - 13:55.


Re: MediaPortal dependencies problem. #12 WanWizard

  • Forum Moderator
    PLi® Core member
  • 45,703 posts

+737
Excellent

Posted 10 December 2018 - 14:03

Mediaportal doesn't work because it requires very recent versions of a long list of Python modules, versions that are simply not available on the antique OS version that runs OpenPli 4.

 

OpenPLi 4 has been end of life for over a year now, and when OpenPLi 7 is released, we will stop building OpenPLi 4 images all together, and retire that version. You can't expect us to take illegal IPTV services into account.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.2TC ©, Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: MediaPortal dependencies problem. #13 zigzag

  • Senior Member
  • 161 posts

0
Neutral

Posted 10 December 2018 - 14:20

You are not expected to take into account illegal IPTV services, even though i would guess 50% of users would be using this service.

I understand this.

I just would like to know why one image works flawless but in subsequent releases something must have been changed as it is completely

unstable for our use. 

If it is easier for us to install the 'latest' versions of the dependencies required for MP we would be very grateful if someone could suggest where we could 

look for these to manually install and what files we need exactly.

Many thanks...


Edited by zigzag, 10 December 2018 - 14:21.


Re: MediaPortal dependencies problem. #14 WanWizard

  • Forum Moderator
    PLi® Core member
  • 45,703 posts

+737
Excellent

Posted 10 December 2018 - 14:31

I just explained why you can't.

 

For the same reason you can't go to Microsoft and say "I want to use the latest Windows 10 application, but I want to use it on Windows 2000, please make sure that remains compatible".

 

It is not going to happen.

 

And we absolutely loathe illegal viewing, streams or otherwise. It is the main reason providers move to CI's, embedded smartcards, card pairing, etc which means we who pay for a subscription have to pay a high price for less service.

So people like you make that people like me can no longer use the hardware I desire to watch the TV I want to watch.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.2TC ©, Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: MediaPortal dependencies problem. #15 zigzag

  • Senior Member
  • 161 posts

0
Neutral

Posted 10 December 2018 - 14:45

I just explained why you can't.

 

For the same reason you can't go to Microsoft and say "I want to use the latest Windows 10 application, but I want to use it on Windows 2000, please make sure that remains compatible".

 

It is not going to happen.

 

And we absolutely loathe illegal viewing, streams or otherwise. It is the main reason providers move to CI's, embedded smartcards, card pairing, etc which means we who pay for a subscription have to pay a high price for less service.

So people like you make that people like me can no longer use the hardware I desire to watch the TV I want to watch.

 

 

I find your reply to be extremely rude and a completely unnecessary direct attack which is both disrespectful and unnecessary.

Firstly, who on earth told you that my family's iptv service is of the illegal type?

Have i posted that it is across any of the threads on this forum?

Are there not 'legal' iptv services? Do you know these exist? Would you like me to confirm what they are?

Are streams from various plugins you havve in your feeds 'illegal' or 'legal'? I'm pretty sure you  know which i refer to...

Aside from that, the fact that you are unable to reply respectfully without accusations and negative comments leaves me completely

baffled...

 

Thanks for your total unprofessional reply to a simple query requested with respect and curtousy.



Re: MediaPortal dependencies problem. #16 WanWizard

  • Forum Moderator
    PLi® Core member
  • 45,703 posts

+737
Excellent

Posted 10 December 2018 - 14:50

You didn't state you did not use illegal services, on the contrary. So I'm pretty confident that my assumption is spot on. You are asking me to do something (even though you have already been told several times it is not going to happen) so you can keep doing exactly what prevents me doing from what I want to do, and I am entitled to tell you I am not happy with that, and why.

 

So for the third time, it is not going to happen. And I have already explained why.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.2TC ©, Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: MediaPortal dependencies problem. #17 littlesat

  • PLi® Core member
  • 47,225 posts

+494
Excellent

Posted 10 December 2018 - 15:10

Mediaportal should fully work in OpenPLi7.0-rc... so I suggest switch to OpenPLi7.0-rc.... Why are you stick on ancient OpenPLi 4.0?


Edited by littlesat, 10 December 2018 - 15:10.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: MediaPortal dependencies problem. #18 WanWizard

  • Forum Moderator
    PLi® Core member
  • 45,703 posts

+737
Excellent

Posted 10 December 2018 - 15:43

Because he says his IPTV provider doesn't work on newer images. Not something that is our problem to fix.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.2TC ©, Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: MediaPortal dependencies problem. #19 Erik Slagter

  • PLi® Core member
  • 44,822 posts

+489
Excellent

Posted 12 December 2018 - 17:48

"iptv provider"  :D


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: MediaPortal dependencies problem. #20 zigzag

  • Senior Member
  • 161 posts

0
Neutral

Posted 12 December 2018 - 18:56

"iptv provider"  :D

Ever heard of usatvnow?

it's been available via plugins you've carried in your feeds for a long time.

:D






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users