Jump to content


Photo

OpenWebif

openwebif openssl

  • Please log in to reply
14 replies to this topic

#1 Klaus

  • Senior Member
  • 27 posts

0
Neutral

Posted 26 October 2016 - 21:46

Hi,

 

I have a dreambox DM800 HD PVR and OpenWebif 0.1+git659.

 

To update OpenWebif, I deleted and reinstalled it. But I became the same version of OpenWebif and later on a message saying that OpenWebif is not available because there is no module OpenSSL.

 

So what can I do  ?

 

I found a new version of OpenWebif at https://github.com/E...lugin-OpenWebif, but I do not know how to install it. I prefer this solution if possible.

 

thanks for your help

 

sincerely

Klaus

 

 

 



Re: OpenWebif #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 51,323 posts

+949
Excellent

Posted 26 October 2016 - 21:48

OpenPLi 2.1 is the last available version for this end-of-life box, which is no longer maintained.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (C), Zgemma H6(fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: OpenWebif #3 Klaus

  • Senior Member
  • 27 posts

0
Neutral

Posted 26 October 2016 - 21:58

OpenPLi 2.1 is the last available version for this end-of-life box, which is no longer maintained.

 

I understood that. I search a newer version of OpenWebIF or if not possible, make work the version actually installed.

 

Klaus



Re: OpenWebif #4 WanWizard

  • Forum Moderator
    PLi® Core member
  • 51,323 posts

+949
Excellent

Posted 26 October 2016 - 22:20

I don't know if it is that easy, especially with regards to dependencies, there's a lot more OpenSSL related stuff in more recent versions.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (C), Zgemma H6(fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: OpenWebif #5 Klaus

  • Senior Member
  • 27 posts

0
Neutral

Posted 27 October 2016 - 09:32

I don't know if it is that easy, especially with regards to dependencies, there's a lot more OpenSSL related stuff in more recent versions.

In more recent versions of what ? Openpli ?

 

But if there is no newer version of Openpli for my box, this is not useful for me.

 

Klaus



Re: OpenWebif #6 WanWizard

  • Forum Moderator
    PLi® Core member
  • 51,323 posts

+949
Excellent

Posted 27 October 2016 - 11:13

No, more recent versions (as in: newer than you have on your box) of OpenWebIf.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (C), Zgemma H6(fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: OpenWebif #7 Klaus

  • Senior Member
  • 27 posts

0
Neutral

Posted 27 October 2016 - 12:46

so how to make work my OpenWebif which needs OpenSSL ?

 

Klaus



Re: OpenWebif #8 Klaus

  • Senior Member
  • 27 posts

0
Neutral

Posted 27 October 2016 - 21:43

I found out that openssl is installed :

 

root@dm800:~# opkg install openssl
Package openssl (0.9.8m-r14.1) installed in root is up to date.opkg install openssl
Package openssl (0.9.8m-r14.1) installed in root is up to date.

 

root@dm800:/# find -iname openssl
./usr/bin/openssl
./usr/lib/python2.6/site-packages/OpenSSL

 

So certainly Openwebif cannot find it. How to know where OpenWebif expects openssl ?

 

Klaus



Re: OpenWebif #9 WanWizard

  • Forum Moderator
    PLi® Core member
  • 51,323 posts

+949
Excellent

Posted 27 October 2016 - 22:24

It is probably a version issue and not a location issue, 0.9.8 is very old.

 

It is an indirect dependency, OpenWebIf requires python-pyopenssl, and that requires the OpenSSL package. So it could well be that OpenWebIf needs a specific minumum version of that python package, or it needs Python 2.7 instead of 2.6.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (C), Zgemma H6(fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: OpenWebif #10 Klaus

  • Senior Member
  • 27 posts

0
Neutral

Posted 28 October 2016 - 20:44

Python 2.7 is not available for my box.

 

I think the best way to resolve my problem ist flashing my box with a new image. 

 

Actually it works with "backup800.nfi", I don't know anymore from where I downloaded it. I don't know which version of openpli it contains.

 

Where can I get OpenPLi 2.1 for a cloned dreambox ?

 

cheers

Klaus



Re: OpenWebif #11 mimisiku

  • Senior Member
  • 2,414 posts

+31
Good

Posted 28 October 2016 - 20:58

Are you serious? Plainly asking for support for a clone box???? The nerve!
Met één been in het graf..... Helaas

Re: OpenWebif #12 WanWizard

  • Forum Moderator
    PLi® Core member
  • 51,323 posts

+949
Excellent

Posted 29 October 2016 - 23:39

As you may have guested, the answer is "nowhere". We don't make images for clone boxes.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (C), Zgemma H6(fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: OpenWebif #13 Erik Slagter

  • PLi® Core member
  • 45,514 posts

+505
Excellent

Posted 5 November 2016 - 12:51

OpenWebif is not a "module" that you can install into an existing image. It has very tight dependencies with enigma.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: OpenWebif #14 SpaceRat

  • Senior Member
  • 1,011 posts

+62
Good

Posted 6 November 2016 - 16:33

Not really ...
1st box: Vu+ Ultimo 4k 4xDVB-S2 FBC / 2xDVB-C / 1.8 TB HDD / OpenATV 6.2
2nd box: Gigablue Quad 4k 2xDVB-S2 FBC / 2xDVB-C / 1.8 TB HDD / OpenATV 6.2
testing boxes: Vu+ Duo² + AX Quadbox HD2400 + 2x Vu+ Solo² + Octagon SF4008
Sats & Pay-TV: Astra 19.2°E + Hotbird 13°E with Redlight / SCT HD / SES Astra HD- / Sky V14 / 4th empire propaganda TV
Card-Server: Raspberry Pi + IPv6-capable oscam
Router: Linksys WRT1900ACS w/ LEDE + Fritz!Box 7390

Re: OpenWebif #15 Klaus

  • Senior Member
  • 27 posts

0
Neutral

Posted 26 November 2016 - 22:41

Finally it flashed my box with the same OpenPli version, and everything works again, thanks for help.

 

Klaus







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users