Jump to content


Photo

How to build Enigma2 images.


  • Please log in to reply
76 replies to this topic

Re: How to build Enigma2 images. #21 Sjaaky

  • Senior Member
  • 7,442 posts

+41
Good

Posted 26 April 2017 - 22:13

I cannot build openpli4 (master branch) with Ubuntu 16.10. GCC 6 is just too new. After solving several problems, I got stuck, installed GCC 4.9, got stuck again, so tried using docker. Apparently using docker is quite common for openembedded / yocto developers.
I adjusted a dockerfile found on the internet based on Debian Jessie and adjusted some startup script. This allowed me to build openpli4 cleanly.
For me working with docker is a much nicer experience than a virtual machine.

Re: How to build Enigma2 images. #22 littlesat

  • PLi® Core member
  • 49,539 posts

+533
Excellent

Posted 27 April 2017 - 09:02

When you want to build openpli4 you have to switch the branch to master. By default it now "cloned" to develop (which is 5)... so before you make.... you type "git checkout master"

 

[edit sorry please forget... my mistake]


Edited by littlesat, 27 April 2017 - 09:03.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: How to build Enigma2 images. #23 blzr

  • PLi® Core member
  • 2,051 posts

+100
Excellent

Posted 27 April 2017 - 09:48

to build openpli4 on newer linux distros you need to use master-for-gcc5 branch;

you would need to merge latest master into it though, last merge was two months ago...

 

(however I'm not sure if it still doesn't need some more tweaks for gcc6 /?/)


True sarcasm doesn't need green font...

Re: How to build Enigma2 images. #24 Erik Slagter

  • PLi® Core member
  • 45,353 posts

+498
Excellent

Posted 27 April 2017 - 15:28

The branch is suitable for both gcc5 and gcc6. It only needs to have master merged to it.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: How to build Enigma2 images. #25 Abu Baniaz

  • PLi® Contributor
  • 1,181 posts

+26
Good

Posted 15 December 2017 - 18:29

What amendments are required for a homebuild version of the latest Developer image please?



Re: How to build Enigma2 images. #26 WanWizard

  • Forum Moderator
    PLi® Core member
  • 49,008 posts

+840
Excellent

Posted 15 December 2017 - 19:30

I think that depends on what your host platform is.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: How to build Enigma2 images. #27 citymen34

  • Member
  • 21 posts

0
Neutral

Posted 27 February 2019 - 14:09

ERROR: linux-etxx00-3.8.7-r6.13 do_fetch: Fetcher failure for URL: 'http://www.et-view.c...ux-3.8.7.tar.gz'. Checksum mismatch!
File: '/home/ozcan/openpli40/openpli-oe-core/sources/linux-3.8.7.tar.gz' has md5 checksum 5ff1696c859144a5a023df540bddf2dd when 5f6aaac90a4587df34e418bedd7d40eb was expected
File: '/home/ozcan/openpli40/openpli-oe-core/sources/linux-3.8.7.tar.gz' has sha256 checksum 830ccfda8e14bcfa22868e415da594d4d272ffa9d083792a1a038ea5e9ee8630 when afc3e654b779f4b994a0d455d6ad12f46ff0dbec2fe222a4f55925744b498218 was expected
If this change is expected (e.g. you have upgraded to a new version without updating the checksums) then you can use these lines within the recipe:
SRC_URI[md5sum] = "5ff1696c859144a5a023df540bddf2dd"
SRC_URI[sha256sum] = "830ccfda8e14bcfa22868e415da594d4d272ffa9d083792a1a038ea5e9ee8630"
Otherwise you should retry the download and/or check with upstream to determine if the file has become corrupted or otherwise unexpectedly modified.

ERROR: linux-etxx00-3.8.7-r6.13 do_fetch: Fetcher failure for URL: 'http://www.et-view.c...ux-3.8.7.tar.gz'. Unable to fetch URL from any source.
ERROR: linux-etxx00-3.8.7-r6.13 do_fetch: Function failed: base_do_fetch
ERROR: Logfile of failure stored in: /home/ozcan/openpli40/openpli-oe-core/build/tmp/work/et9x00-oe-linux/linux-etxx00/3.8.7-r6.13/temp/log.do_fetch.15736
ERROR: Task (/home/ozcan/openpli40/openpli-oe-core/meta-xtrend/recipes-bsp/linux/linux-etxx00_3.8.7.bb:do_fetch) failed with exit code '1'
NOTE: Tasks Summary: Attempted 1903 tasks of which 0 didn't need to be rerun and 1 failed.

Summary: 1 task failed:
  /home/ozcan/openpli40/openpli-oe-core/meta-xtrend/recipes-bsp/linux/linux-etxx00_3.8.7.bb:do_fetch
Summary: There were 28 WARNING messages shown.
Summary: There were 3 ERROR messages shown, returning a non-zero exit code.
make: *** [image] Error 1
 

please help me et-view link error


Edited by citymen34, 27 February 2019 - 14:10.


Re: How to build Enigma2 images. #28 WanWizard

  • Forum Moderator
    PLi® Core member
  • 49,008 posts

+840
Excellent

Posted 27 February 2019 - 14:18

Xtrend no longer exists, the site www.et-view.com has been down for a while. You get the checksum error because of the error message returned.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: How to build Enigma2 images. #29 twol

  • Senior Member
  • 283 posts

+8
Neutral

Posted 27 February 2019 - 14:50

ERROR: linux-etxx00-3.8.7-r6.13 do_fetch: Fetcher failure for URL: 'http://www.et-view.c...ux-3.8.7.tar.gz'. Checksum mismatch!
File: '/home/ozcan/openpli40/openpli-oe-core/sources/linux-3.8.7.tar.gz' has md5 checksum 5ff1696c859144a5a023df540bddf2dd when 5f6aaac90a4587df34e418bedd7d40eb was expected
File: '/home/ozcan/openpli40/openpli-oe-core/sources/linux-3.8.7.tar.gz' has sha256 checksum 830ccfda8e14bcfa22868e415da594d4d272ffa9d083792a1a038ea5e9ee8630 when afc3e654b779f4b994a0d455d6ad12f46ff0dbec2fe222a4f55925744b498218 was expected
If this change is expected (e.g. you have upgraded to a new version without updating the checksums) then you can use these lines within the recipe:
SRC_URI[md5sum] = "5ff1696c859144a5a023df540bddf2dd"
SRC_URI[sha256sum] = "830ccfda8e14bcfa22868e415da594d4d272ffa9d083792a1a038ea5e9ee8630"
Otherwise you should retry the download and/or check with upstream to determine if the file has become corrupted or otherwise unexpectedly modified.
ERROR: linux-etxx00-3.8.7-r6.13 do_fetch: Fetcher failure for URL: 'http://www.et-view.c...ux-3.8.7.tar.gz'. Unable to fetch URL from any source.
ERROR: linux-etxx00-3.8.7-r6.13 do_fetch: Function failed: base_do_fetch
ERROR: Logfile of failure stored in: /home/ozcan/openpli40/openpli-oe-core/build/tmp/work/et9x00-oe-linux/linux-etxx00/3.8.7-r6.13/temp/log.do_fetch.15736
ERROR: Task (/home/ozcan/openpli40/openpli-oe-core/meta-xtrend/recipes-bsp/linux/linux-etxx00_3.8.7.bb:do_fetch) failed with exit code '1'
NOTE: Tasks Summary: Attempted 1903 tasks of which 0 didn't need to be rerun and 1 failed.
Summary: 1 task failed:
  /home/ozcan/openpli40/openpli-oe-core/meta-xtrend/recipes-bsp/linux/linux-etxx00_3.8.7.bb:do_fetch
Summary: There were 28 WARNING messages shown.
Summary: There were 3 ERROR messages shown, returning a non-zero exit code.
make: *** [image] Error 1
 
please help me et-view link error

If you really need to build an image for the et9x00, you have 3 choices:
Either use the links from the OE-A (where they have recovered all the files that were deleted and now host them) and incorporate those links in your OpenPli build , build one of the OE-A images directly or download a built image.

Gigablue Quad 4K & UE 4K
.........FBC Tuners:
------------------> DUR-Line DCR 5-1-8-L4 Multiswitch to 1.5M dish(28.2E)
------------------> Spaun SUS 5581/33 NFA Multiswitch to 80 cm dish(19.2E)
.........DVB-S2X into 90cm dish (27.5W)

Octagon SF8008 DVB-S2X tuner using Legacy ports on multiswitches
Edision Osmio 4K+, Zgemma H9Combo and Multibox using Legacy ports on multiswitches
Zgemma H9twin & Zgemma H9 C/S mode into Giga4K
 


Re: How to build Enigma2 images. #30 citymen34

  • Member
  • 21 posts

0
Neutral

Posted 27 February 2019 - 14:51

How can fix this?
i want build et9000 image

Edited by citymen34, 27 February 2019 - 14:52.


Re: How to build Enigma2 images. #31 WanWizard

  • Forum Moderator
    PLi® Core member
  • 49,008 posts

+840
Excellent

Posted 27 February 2019 - 14:52

Build OpenPLi 7 instead of OpenPLi 4, which is end of life.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: How to build Enigma2 images. #32 twol

  • Senior Member
  • 283 posts

+8
Neutral

Posted 27 February 2019 - 14:53

How can fix this?
i want build et9000 image

See post #29!

Gigablue Quad 4K & UE 4K
.........FBC Tuners:
------------------> DUR-Line DCR 5-1-8-L4 Multiswitch to 1.5M dish(28.2E)
------------------> Spaun SUS 5581/33 NFA Multiswitch to 80 cm dish(19.2E)
.........DVB-S2X into 90cm dish (27.5W)

Octagon SF8008 DVB-S2X tuner using Legacy ports on multiswitches
Edision Osmio 4K+, Zgemma H9Combo and Multibox using Legacy ports on multiswitches
Zgemma H9twin & Zgemma H9 C/S mode into Giga4K
 


Re: How to build Enigma2 images. #33 citymen34

  • Member
  • 21 posts

0
Neutral

Posted 27 February 2019 - 15:18

Build OpenPLi 7 instead of OpenPLi 4, which is end of life.

 

i want build openpli4 image. sorry all my work was trash?



Re: How to build Enigma2 images. #34 WanWizard

  • Forum Moderator
    PLi® Core member
  • 49,008 posts

+840
Excellent

Posted 27 February 2019 - 15:34

I can't help it that you pick something that is years old, who's dependencies can no longer be resolved?

 

Follow @twol's advice, shop around for the old drivers, and change your recipes accordingly.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: How to build Enigma2 images. #35 anudanan

  • Senior Member
  • 1,002 posts

+14
Neutral

Posted 27 February 2019 - 15:46

Why don‘t you use the openpli 4.0 from the Download area. I know, the Feed is not complete for all plugins but some plugins you csn get from other places if you need this
Receiver:2 x Uno4k SE (PLI 7.0 rel), 1 x ET9200 (PLI 4.0), NAS: 2 x QNAP 410, TV: LG 65C8llla, LG 47LB570V, LG 42LM615S, Sound: Yamaha RX-v663, Teufel System 5 THX

Re: How to build Enigma2 images. #36 citymen34

  • Member
  • 21 posts

0
Neutral

Posted 27 February 2019 - 15:52

Why don‘t you use the openpli 4.0 from the Download area. I know, the Feed is not complete for all plugins but some plugins you csn get from other places if you need this

 

hi, where is the Download area?



Re: How to build Enigma2 images. #37 anudanan

  • Senior Member
  • 1,002 posts

+14
Neutral

Posted 27 February 2019 - 15:55

https://openpli.org/download/xtrend/
Receiver:2 x Uno4k SE (PLI 7.0 rel), 1 x ET9200 (PLI 4.0), NAS: 2 x QNAP 410, TV: LG 65C8llla, LG 47LB570V, LG 42LM615S, Sound: Yamaha RX-v663, Teufel System 5 THX

Re: How to build Enigma2 images. #38 citymen34

  • Member
  • 21 posts

0
Neutral

Posted 27 February 2019 - 19:56

 

Why don‘t you use the openpli 4.0 from the Download area. I know, the Feed is not complete for all plugins but some plugins you csn get from other places if you need this

 

hi, where is the Download area?

 

 

i'm using this image (Download area Openpli4) but i want change time zone. İstanbul time zone is incorrect. Correct time zone is GMT +3

And i want learn how to make image.



Re: How to build Enigma2 images. #39 citymen34

  • Member
  • 21 posts

0
Neutral

Posted 27 February 2019 - 20:01

it's possible unpack / repack image?



Re: How to build Enigma2 images. #40 betacentauri

  • PLi® Core member
  • 5,542 posts

+252
Excellent

Posted 27 February 2019 - 20:09

In /usr/share/enigma2 you should find a timezone.xml file. Change this file.


Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users