Jump to content


Photo

CrossEPG not finding Rytec sources


  • Please log in to reply
74 replies to this topic

#1 gogglebox

  • Senior Member
  • 95 posts

0
Neutral

Posted 30 August 2017 - 21:42

Hi,

 

I really like the idea of the new sources, splitting packages that exist currently into smaller ones.

 

CrossEPG isn't able to find rytec sources and I would like the new set of sources, are you able to help in any way?

 

I will also see how to modify the script that decompresses the file that arrives to see if it's possible to modify to understand .xz files.



Re: CrossEPG not finding Rytec sources #2 Abu Baniaz

  • PLi® Contributor
  • 2,097 posts

+56
Good

Posted 31 August 2017 - 00:21

Use EPG importer instead.

PLi build CrossEPG from E2OpenPlugins. Nobody maintains that project. There are pull requests well over five years old.

Re: CrossEPG not finding Rytec sources #3 doglover

  • Rytec EPG Team
  • 16,135 posts

+596
Excellent

Posted 31 August 2017 - 07:20

I checked the the Crossepg python Rytec update.

The URL's which are in there still work.

 

Maybe you can check:  https://github.com/o...rytec_update.py

and the crossepg_rytec_update.py file on your receiver.

 

Willy


~~Rytec Team~~
Maxytec Multibox SE OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: CrossEPG not finding Rytec sources #4 gogglebox

  • Senior Member
  • 95 posts

0
Neutral

Posted 31 August 2017 - 22:35

Thanks! I've tried this but it's still not working. I will look into it.



Re: CrossEPG not finding Rytec sources #5 Matrix10

  • Senior Member
  • 332 posts

+27
Good

Posted 1 September 2017 - 00:43

Willy, what he probably means is that grouping of channels is not the same in CrossEPG and EPGImport

 

example:

 

In EPGimport you have Italia-Basis,Italia-Sky and Italia-Sport/Film/Premium

 

In CrossEPG I think you have only Rytec Italy XMLTV.

 

Groeten en bedankt voor all EPG werk.

 

MX



Re: CrossEPG not finding Rytec sources #6 gogglebox

  • Senior Member
  • 95 posts

0
Neutral

Posted 1 September 2017 - 01:45

I checked the the Crossepg python Rytec update.

The URL's which are in there still work.

 

Maybe you can check:  https://github.com/o...rytec_update.py

and the crossepg_rytec_update.py file on your receiver.

 

Willy

 

I've checked and I've got the right crossepg_rytec_update.py file from GitHub. When I run Update rytec providers, after creating the .pyo file, it brings up a box saying 0 providers found with a green tick to the left of the image. At least it's not saying it can't find any, which it was saying before. I checked the links in the py file and they are valid. I don't know if this is image specific but I will certainly raise this on the BlackHole forum as well. Can you suggest anything to enable CrossEPG to download the sources?

 

In the meantime, I will draw up my own .conf files for the packages I need.

 

I'm on version 0.8.1 of CrossEPG and I can't update it to 0.8.3 using the .ipk. I haven't found a way yet to manually override the feed version.



Re: CrossEPG not finding Rytec sources #7 gogglebox

  • Senior Member
  • 95 posts

0
Neutral

Posted 1 September 2017 - 01:53

Willy, what he probably means is that grouping of channels is not the same in CrossEPG and EPGImport

 

example:

 

In EPGimport you have Italia-Basis,Italia-Sky and Italia-Sport/Film/Premium

 

In CrossEPG I think you have only Rytec Italy XMLTV.

 

Groeten en bedankt voor all EPG werk.

 

MX

 

I'm not able to get any providers at all, it says 0 found. With the .conf files from when it worked, I can get the bigger packages. I would like to get the ones in EPGImport and they exist in the link in crossepg_rytec_update.py file. I don't know why it's not working but it would e good if it could work.



Re: CrossEPG not finding Rytec sources #8 Abu Baniaz

  • PLi® Contributor
  • 2,097 posts

+56
Good

Posted 1 September 2017 - 02:15

Does BlackHole build from E2-Openplugins version?

Re: CrossEPG not finding Rytec sources #9 doglover

  • Rytec EPG Team
  • 16,135 posts

+596
Excellent

Posted 1 September 2017 - 08:08

Do not know what BlackHole does.

Why do you not use EPGimport?

 

Willy


Edited by doglover, 1 September 2017 - 08:10.

~~Rytec Team~~
Maxytec Multibox SE OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: CrossEPG not finding Rytec sources #10 gogglebox

  • Senior Member
  • 95 posts

0
Neutral

Posted 1 September 2017 - 11:40

I prefer CrossEPG because it's what I've always used.



Re: CrossEPG not finding Rytec sources #11 gogglebox

  • Senior Member
  • 95 posts

0
Neutral

Posted 1 September 2017 - 22:30

The config files I drew up myself work very well. It would be good though if CrossEPG can generate them itself.



Re: CrossEPG not finding Rytec sources #12 doglover

  • Rytec EPG Team
  • 16,135 posts

+596
Excellent

Posted 2 September 2017 - 07:25

Fix it on the Github, and generate a pull request.  See how much succes you have....

 

If this will not get fixed, then Crossepg will not work althogether after 1-1-2018 when al the file will be provided in xz format.  I made a request that Crossepg would be adapted for this format.  No succes yet.

If nobody cares to develop this, so be it.  Crossepg will not be compatible then.  And I will not shed a tear for this, because Crossepg is a real pain in the behind.

 

Willy


~~Rytec Team~~
Maxytec Multibox SE OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: CrossEPG not finding Rytec sources #13 gogglebox

  • Senior Member
  • 95 posts

0
Neutral

Posted 2 September 2017 - 17:58

Thanks.

 

I'm going to try to make it work with xz files. I'm aware of the fact it won't work anymore after 1-1-2018.

 

Yes it can be that but it works in principle for what I use it for.



Re: CrossEPG not finding Rytec sources #14 doglover

  • Rytec EPG Team
  • 16,135 posts

+596
Excellent

Posted 3 September 2017 - 07:06

Yes it can be that but it works in principle for what I use it for.

 

 

A lot of other people, run into problems, and then turn to me to resolve it.  Which I cannot.  I have spent hours and hours on finding an error, and then it turns out to be a quirk of Crossepg.  Users do not tell me thy are using Crossepg,  and in turn I am spendign hours to find the error which is quirk of Crossepg.

 

The biggest in Crossepg is that Crossepg does not use the Namespace parameter of the service ref.  So it attaches in many case the wrong EPG to the wrong channel.  f.i. in the Virgin and Telenet cable channels file there are several service refs which are the same as some channels on satellite, except for the Namespace.  Of course the channel is not the same.  Result wrong EPG.

 

Willy


~~Rytec Team~~
Maxytec Multibox SE OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: CrossEPG not finding Rytec sources #15 Abu Baniaz

  • PLi® Contributor
  • 2,097 posts

+56
Good

Posted 3 September 2017 - 17:08

Willy,
Do you know which bit of code does this?

Thanks.

Re: CrossEPG not finding Rytec sources #16 doglover

  • Rytec EPG Team
  • 16,135 posts

+596
Excellent

Posted 4 September 2017 - 08:00

No, I do not.  My python knowledge is non-existent.

 

Willy


~~Rytec Team~~
Maxytec Multibox SE OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: CrossEPG not finding Rytec sources #17 bogdanm

  • Senior Member
  • 59 posts

+1
Neutral

Posted 9 September 2017 - 21:37

In last version image BH

Crrosepg was update


Edited by bogdanm, 9 September 2017 - 21:38.


Re: CrossEPG not finding Rytec sources #18 Huevos

  • PLi® Contributor
  • 3,764 posts

+144
Excellent

Posted 10 September 2017 - 01:50

In last version image BH

Crrosepg was update

Updated for what?

 

Where is the commit?



Re: CrossEPG not finding Rytec sources #19 Ev0

  • Senior Member
  • 49 posts

+3
Neutral

Posted 10 September 2017 - 11:22

 

In last version image BH

Crrosepg was update

Updated for what?

 

Where is the commit?

 

https://github.com/E...02345d29f50ee9c



Re: CrossEPG not finding Rytec sources #20 doglover

  • Rytec EPG Team
  • 16,135 posts

+596
Excellent

Posted 13 September 2017 - 13:21

In order to check-up on crossepg I tried to install Crossepg on one ow my OpenPLi machines.

The version in the feed from OpenPLi is taken from here:  https://github.com/o...plugin-CrossEPG

This version is not adapted for use with the new rytec sources (new format and xz).  So that does not work.

 

I tried to compile the version from the E2OpenPlugins Github (https://github.com/E...plugin-CrossEPG) but failed.

Tried to compile it with the make bash files given on the Github, But no result.

Tried to compile it with the build environment of OpenPLi but miserable failed also.

The trick of copying the python files to mthe installed version, does not work, because the modifications are in a C++ file.  This need to be compiled for a mipsel environment.

 

Can someone post a version of Crosepg for mipsel compiled from the E2OpenPlugins, so I can test it out and give comments pls.

 

Willy


~~Rytec Team~~
Maxytec Multibox SE OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users