Jump to content


Photo

OpenPli 7 Multiboot


  • Please log in to reply
39 replies to this topic

#1 Reinh@rd

  • Member
  • 18 posts

0
Neutral

Posted 28 December 2018 - 15:18

Habe das openpli-7.0-rc-osmio4k-20181227_usb im flash und möchte die Multiboot-Möglichkeit nutzen.

Nach Aufruf des Flash Bild soll der USB-Stick (24 GB) formatiert werden. Diese Prozedur dauert jetzt wschon über eine Stunde.

Was läuft falsch?

Gibt es eine andere Möglichkeit den Stick zu formatieren?

 

Ein gutes 2019


Greetings from "Linken Niederrhein" Reinh@rd

Re: OpenPli 7 Multiboot #2 Frenske

  • Forum Moderator
    PLi® Core member
  • 21,727 posts

+188
Excellent

Posted 28 December 2018 - 17:11

Ich frage mich ob der Größe vom USB Stick vielleicht Probleme verursacht. Versuche dies mal mit einem USB Stick mit weniger Speicher?
Mijn schotel is een T90 met 10 LNB's. Daarnaast voor de fun nog een draaibaar systeem met een Triax TD 78.

Dreamboxen heb ik niet meer. Verder nog een een VU+ duo2 met 500Gb harddisk + een VU+ Uno, Zero, Solo 4K, Ultimo 4K, Zero 4K, Uno 4Kse. + ook nog een Xtrend ET4000. Daarnaast heb ik ook nog diverse andere modellen w.o. een Formuler F4, ET8500, ET7500, Mut@nt 2400HD, Xsarius Fusion HD se en verder nog wel het e.e.a. waarmee op verzoek vanalles wordt getest. Iemand moet het tenslotte doen. ;) :)

Voor centrale opslag van media gebruik ik een Qnap 219P met tweemaal 2 Tb harddisks.

-------------------------------------------------------------------------------------------
Many answers to your question can be found in our wiki: Just one click away from this "solutioncentre".

Als ik alles al wist hoefde ik ook niets te vragen. If I had all the knowledge I had no questions at all.

Re: OpenPli 7 Multiboot #3 JuergenK1

  • Senior Member
  • 95 posts

+1
Neutral

Posted 29 December 2018 - 08:31

Das USB-Stück am PC FAT32 formatieren,das Images passt locker auf ein USB-Stück der Speicher von den  USB-Stück muss nur groß genug sein.



Re: OpenPli 7 Multiboot #4 betacentauri

  • PLi® Core member
  • 5,247 posts

+244
Excellent

Posted 29 December 2018 - 08:51

Ne, er will OpenMultiboot verwenden und da muss der Stick ext4 formatiert sein.
Aber hat die Box nicht Hardware Multiboot? Dann brauch man keinen Stick, da der Flash mehrere Partitionen für die Images hat.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: OpenPli 7 Multiboot #5 Reinh@rd

  • Member
  • 18 posts

0
Neutral

Posted 1 January 2019 - 14:48

Ein gutes Neues Jahr,

 

es muß am Image liegen.

 

Mit dem Image: Satdreamgr-6-osmio4k-20181224 hat es problemlos in ein paar Sekunden geklappt.


Greetings from "Linken Niederrhein" Reinh@rd

Re: OpenPli 7 Multiboot #6 Pike_Bishop

  • Senior Member
  • 808 posts

+29
Good

Posted 3 January 2019 - 23:06

ext3 funktioniert auch für Openmultiboot.


Edited by Biki3, 3 January 2019 - 23:06.

Receiver: Mutant HD 2400, VU Ultimo 4k

Image: PLI 6.0


Re: OpenPli 7 Multiboot #7 mikel

  • Senior Member
  • 308 posts

0
Neutral

Posted 7 February 2019 - 19:23

Hallo,

 

habe mir eine Zgemma H7S bestellt, da die Box Multiboot kann und einen Flash von 4 Gb hat meine Frage zum ersten Image-Flash?

 

Das Pli-Image in Version 7 kann ja nun auch Multiboot und es gibt auch Images extra dafür, wird hier der Flashspeicher beim ersten mal in 4x1Gb formartiert und muss der Vorgang zweimal durchgeführt werden? Wie funktioniert das genau und gibt es hier Probleme? Wie ausgereift ist das im Pli-Image und kann man dabei den Flash beschädigen?

 

Über eine Anleitung und Erfahrungen würde ich mich sehr freuen.

 

Danke vorab.

 

Gruß Mickel



Re: OpenPli 7 Multiboot #8 betacentauri

  • PLi® Core member
  • 5,247 posts

+244
Excellent

Posted 7 February 2019 - 19:45

Die Namen der Images auf der Webseite sind missverständlich. Du solltest als erstes das Image ohne Multiboot im Namen herunterladen und per USB Stick flashen. Das heisst jetzt nicht, dass du das Multiboot komplett deaktiviert hast.
Danach kannst du vom Image aus Images in die anderen 3 Slots/Partitionen flashen.
Wenn du per USB flashst, löschst du immer alle 4 Images. Das lässt sich nicht ändern!

Den Flash kannst du durch ein bestimmtes Image nicht beschädigen. Kannst also gerne PLi ausprobieren. Wenn es nicht gefällt, flash ein anderes. PLi Images sind ggf. nicht immer super duper aktuell, aber dafür wird Wert auf die Stabilität gelegt und dass dem normalen User nur getestete Software zur Verfügung gestellt wird.

Edited by betacentauri, 7 February 2019 - 19:46.

Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: OpenPli 7 Multiboot #9 mikel

  • Senior Member
  • 308 posts

0
Neutral

Posted 7 February 2019 - 19:55

Hallo betacentauri,

 

danke für Deine schnelle Info.

 

Warum stellt man hier zwei Images zur Verfügung, ist wenn man das für eine neue Box erstmalig machen will sehr verwirrend?

Oder ist das Multibootimage für einen Stick?

Wird hier beim erstenmal formartiert und beim zweiten mal das Image geflasht? Also zweimal hintereinander normales Image per USB flashen?

 

Partition 2-4 dann online bzw. über die Box flashen.

Wird mit jedem Image jeweils in 1 GB partitioniert?

 

Pli-Image nutze ich 10 Jahre auf meiner ET9000.

 

Mikel


Edited by mikel, 7 February 2019 - 20:00.


Re: OpenPli 7 Multiboot #10 betacentauri

  • PLi® Core member
  • 5,247 posts

+244
Excellent

Posted 7 February 2019 - 20:32

Hi Mikel,

 

das wurde größtenteils so gemacht um die Größe der Image Zip Dateien und damit der Downloads zu verkleinern. Beide Zip Dateien (sowohl die usb als auch die Multiboot) beinhalten vom Prinzip her das gleiche Image.

Aber langsam. Das Image openpli-7.0-release-h7-20190204_usb.zip beispielsweise läßt sich nur per USB Stick flashen. Dabei werden wie gesagt alle 4 vorhandenen Images gelöscht. Die Box wird also quasi neu aufgesetzt. Danach ist in Slot 1 das geflashte Image und alle anderen 3 Slots sind leer.

Das solltest du einmalig machen, weil ggf. ab Werk nur ein abgespecktes Image auf der Box installiert ist.

Danach dann nur noch über das Image (Flash online) andere Images flashen (außer du willst die Box neu aufsetzen). Da werden automatisch die PLi Multiboot Images angezeigt. Vom Image aus kannst du alle 4 Slots/Partitionen flashen. Die nicht geflashten Images bleiben dabei unberührt. Wenn du das laufende Image flashst, wird die Box aber automatisch neugestartet.

Du kannst auch andere (nicht PLi) Images auf deinem PC downloaden und dann auf die Box schieben und über das Image flashen. Hab das längere Zeit mit der Box nicht mehr gemacht. Deswegen weiß ich nicht genau, ob das alles kompatibel ist. Wenn du aber PLi Images in andere Slots flashst (beispielsweise einen neuen Release candidate), dann funktioniert das auf jeden Fall.


Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: OpenPli 7 Multiboot #11 mikel

  • Senior Member
  • 308 posts

0
Neutral

Posted 8 February 2019 - 15:15

Hallo betacentauri,

 

danke für die ausführliche Einführung, warte nun auf meine neue Box und werde das alles testen.

 

Gruß Mikel



Re: OpenPli 7 Multiboot #12 mikel

  • Senior Member
  • 308 posts

0
Neutral

Posted 15 March 2019 - 16:05

Hallo,

 

nach dem ersten flashen soll der 4 Gb Flashpeicher in 4 x 1 Gb formatiert/aufgeteilt werden.
Bei mir wird jeweils nur ca. 730 Mb angezeigt, ist das normal?
 

Wie sieht das mit Backups von den einzelnen Partitionen und wieder zurückflashen aus, habe bemerkt das dieses nicht richtig funzt. Was muss man da beachten?

 

Danke vorab.

 

Gruß Mikel


Edited by mikel, 15 March 2019 - 16:06.


Re: OpenPli 7 Multiboot #13 mikel

  • Senior Member
  • 308 posts

0
Neutral

Posted 15 March 2019 - 17:50

Nach Test folgendes herausgefunden:

 

Onlineflash geht mit Pli nur mit dem eigenen Images, in Part1 sollte somit HDF oder ATV ec. sein, hiermit kann man online/lokal verschiedene Images in die Part. 2-4 flashen und auch von Part1 Backups machen und wieder flashen.

 

Mikel


Edited by mikel, 15 March 2019 - 17:52.


Re: OpenPli 7 Multiboot #14 littlesat

  • PLi® Core member
  • 48,656 posts

+515
Excellent

Posted 15 March 2019 - 18:13

Openatv kan man auch flashen dutch es als zip auf den root van usb stick zunschreiben un den file renamen (nicht immer) dass openpli den boxtype erkennen kann.

Edited by littlesat, 15 March 2019 - 18:24.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: OpenPli 7 Multiboot #15 mikel

  • Senior Member
  • 308 posts

0
Neutral

Posted 15 March 2019 - 18:23

Hallo Littlesat,

kann nicht richtig verstehen was Du da schreibst, vielleich doch in englisch, das kann ich dann übersetzen.

 

Hello Littlesat,

can not really understand what you write there, maybe in English, I can translate then.

 

Thank you, Greetings Mikel



Re: OpenPli 7 Multiboot #16 littlesat

  • PLi® Core member
  • 48,656 posts

+515
Excellent

Posted 15 March 2019 - 18:25

You can flash openatv with our flashimage by playing the doenloaded zip as is on a root of an usb stick. It might be you need to rename the file so flashimage recognizes the correct box id as they might differ with openatv.
The is also json support and you can add an alternative json feed via the ui... but nobody suported this (yet)

Edited by littlesat, 15 March 2019 - 18:26.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: OpenPli 7 Multiboot #17 mikel

  • Senior Member
  • 308 posts

0
Neutral

Posted 15 March 2019 - 18:30

Hi, littlesat,

 

Thanks, will test if that works, would that synonymous with other images go?

 

Please an answer.
After the first flash the 4 Gb flash memory should be formatted / divided into 4 x 1 Gb.
For me, only about 730 Mb is displayed, is this normal?

 

Mikel



Re: OpenPli 7 Multiboot #18 littlesat

  • PLi® Core member
  • 48,656 posts

+515
Excellent

Posted 15 March 2019 - 18:35

Yep with all... you should use the same box id in the name (like hd51 for mutant hd51) so the parser can recognize it.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: OpenPli 7 Multiboot #19 betacentauri

  • PLi® Core member
  • 5,247 posts

+244
Excellent

Posted 15 March 2019 - 23:19

Hi Mikel,

soweit ich weiß kommt es darauf welches Image du flashst. Ich meine das PLi erzeugt 4 mal 1GB. Die anderen Images erzeugen 4 kleinere Partitionen und eine Swap Partition.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: OpenPli 7 Multiboot #20 mikel

  • Senior Member
  • 308 posts

0
Neutral

Posted 16 March 2019 - 09:49

Hi Betacentauri,

 

danke für die schnelle Antwort.

 

Die Box bei Auslieferung hatte ein ATV-Image im Flash, hatte dann Pli7 per USB geflasht und somit die Partitionen formatiert, möchte sagen das somit auch kein GB pro Partition angezeigt wurden.

Habe zu erst immer per DCC auf die Anzeige geschaut und dann per Telnet "df" den Speicher ausgelesen und der zeigt mir nachfolgendes an. Habe jetzt aber ein ATV Image in Part1 neu aufgesetzt, da von hier alle Images geflasht und auch gespeichert und wieder zurückbespielt werden können, wie oben im  Abschnitt #13 bereits geschrieben das Pli kein Online/Lokal flashen anderer Images zur Verfügung stellt. Wird hier bei Neuflash per USB immer auch neu formatiert?

Oder war das nur beim ersten mal nach Auslieferung?

Würde fast sagen wird immer neu formatiert, somit auch das löschen der anderen Partitionen.

Kann man evtl. nur mit anderen Images testen was beim Flashen für Größen herauskommen?

 

Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root               789904    326860    405700  45% /
devtmpfs                190312         4    190308   0% /dev
tmpfs                       64         0        64   0% /media
tmpfs                   514068       124    513944   0% /var/volatile
/dev/sda1            1953309952 164478464 1787782912   8% /media/hdd

 

Es werden 789904 kB gleich 789,904 MB angezeigt sollte so korrekt sein und evtl. nicht mehr herauszuholen sein?

 

Noch ein wichtiger Punkt für mich.

Kann man die Box nach Crash bzw. defektem Image in Part. 2-4 wieder von Part.1 starten lassen?

Ich wollte bereits ein Image auf einer dieser Part. flashen, was scheinbar defekt war und somit startete die Box nicht mehr und ich musste neu aufsetzen?

 

Danke vorab.

 

Gruß Mikel


Edited by mikel, 16 March 2019 - 09:51.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users