Jump to content


Photo

OpenPli 7 Multiboot


  • Please log in to reply
39 replies to this topic

Re: OpenPli 7 Multiboot #21 mikel

  • Senior Member
  • 284 posts

0
Neutral

Posted 16 March 2019 - 10:07

Die "df" Anzeige aus #20 ist von Part.2 mit Pli-Image, nun habe ich mir Part.1 mit ATV anzeigen lassen und nachstehendes Ergebnis bekommen:

 

Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root               536496    339504    155708  69% /
devtmpfs                190260         4    190256   0% /dev
tmpfs                       64         0        64   0% /media
/dev/mmcblk0p1            3050        10      3040   0% /boot
tmpfs                   514012       180    513832   0% /var/volatile

 

Nur noch 536496 kB gesamt, was ist hier los, denke die Partitionen sind wenn dann gleich?

Oder ist das dann vom geflashten Image auf der jeweiligen Part. abhängig?

Verstehe ich nicht mehr, was da im Hintergrund abläuft?

Vielleicht kannst Du mir das erklären und was man ggf. machen kann um hier die 4 größtmöglichen gleichen Part. zu erhalten?

 

Bitte auch Beitrag #20 lesen.

 

Danke Mikel


Edited by mikel, 16 March 2019 - 10:09.


Re: OpenPli 7 Multiboot #22 mikel

  • Senior Member
  • 284 posts

0
Neutral

Posted 16 March 2019 - 10:24

Habe jetzt noch Part.3 mit HDF-Image ausgelesen und gleiches Ergebnis wie im Pli-Image erhalten, nämlich

die 789904 kB gesamt.

 

Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root               789904    389064    343496  53% /
devtmpfs                190268         4    190264   0% /dev
tmpfs                       64         0        64   0% /media
/dev/mmcblk0p1            3050        10      3040   0% /boot
tmpfs                   514024       192    513832   0% /var/volatile

 

Wird evtl. nur das Image in Part.1 anders formartiert und das vielleicht von der Größe her vom Image abhängig was man per USB flasht? Ich weiß nicht ob ich das alles noch teste?

 

Mikel


Edited by mikel, 16 March 2019 - 10:26.


Re: OpenPli 7 Multiboot #23 littlesat

  • PLi® Core member
  • 47,227 posts

+494
Excellent

Posted 16 March 2019 - 10:49

It looks like ATV changed the way the partitions are devided and they created a swap... I have no real idea why you should need the swap? We just follow what the BSP of the manufacturer indicates...


Edited by littlesat, 16 March 2019 - 10:50.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: OpenPli 7 Multiboot #24 betacentauri

  • PLi® Core member
  • 4,979 posts

+233
Excellent

Posted 16 March 2019 - 11:50

Du kannst das Image 1 starten indem du die Box ausmachst. Dann alle USB Stick abziehen. Dann den Power Knopf an der Box drücken und mehrere Sekunden gedrückt lassen.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: OpenPli 7 Multiboot #25 betacentauri

  • PLi® Core member
  • 4,979 posts

+233
Excellent

Posted 16 March 2019 - 12:11

Die Partitionen werden nur geändert, wenn man mit einem USB Stick die Box beim Booten flasht. Beim Online flashen ändert sich nicht die Partitionierung.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: OpenPli 7 Multiboot #26 mikel

  • Senior Member
  • 284 posts

0
Neutral

Posted 16 March 2019 - 14:46

Hi,

 

ein herzliches Dankeschön für die Hilfe geht an Littlesat und Betacentauri.

 

Gruß Mikel



Re: OpenPli 7 Multiboot #27 betacentauri

  • PLi® Core member
  • 4,979 posts

+233
Excellent

Posted 17 March 2019 - 19:43

@Littlesat: They have created swap for KODI.

 

@Mikel: Wenn du parted -l ausführst und dann ein paar Mal Strg+c drückst, sollte so etwas angezeigt werden:

Model: MMC 004GE0 (sd/mmc)
Disk /dev/mmcblk0: 3959MB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name     Flags
 1      1049kB  4194kB  3146kB                  boot     msftdata
 2      4194kB  12.6MB  8389kB                  kernel1
 3      12.6MB  851MB   839MB   ext4            rootfs1
 4      851MB   860MB   8389kB                  kernel2
 5      860MB   1699MB  839MB   ext4            rootfs2
 6      1699MB  1707MB  8389kB                  kernel3
 7      1707MB  2546MB  839MB   ext4            rootfs3
 8      2546MB  2554MB  8389kB                  kernel4
 9      2554MB  3393MB  839MB   ext4            rootfs4
10      3393MB  3908MB  515MB   linux-swap(v1)  swap

D.h. ich habe wohl mal in der Vergangenheit ein OE-A Image per USB Stick geflasht, weil ich eine swap Partition habe, die OpenPLi nicht anlegt (wußte ich gar nicht mehr und interessiert mich eigentlich auch nicht ;))

In der Ausgabe sieht man auch die echten Partitionsgrößen. Das ext4 Dateisystem verbraucht für interne Verwaltungsdaten Platz, der dem User nicht zur Verfügung steht. Den echten verwendbaren Platz siehst du dann mit df bzw. df -h.

root@hd51:~# df -h .
Filesystem                Size      Used Available Use% Mounted on
/dev/root               766.8M    169.6M    553.1M  23% /

Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: OpenPli 7 Multiboot #28 littlesat

  • PLi® Core member
  • 47,227 posts

+494
Excellent

Posted 17 March 2019 - 20:07

Why not offering one complete slot for swap? When you wanna do it! When it is really needed for kodi...

Edited by littlesat, 17 March 2019 - 20:35.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: OpenPli 7 Multiboot #29 mikel

  • Senior Member
  • 284 posts

0
Neutral

Posted 17 March 2019 - 20:51

Hi Littlesat und Betacentauri,

 

danke für die Ausführungen an euch beide, sehr interessant!

 

Habe mich nochmals ein wenig im Thema Multiboot belesen, habe auch mal bei ATV angefragt da hier eine Lösung für eine neue Formatierung des Flashspeichers kommen soll. Man kann erst in ca. 2 Wochen etwas sagen und ob das auch für die Zgemma H7 kommen wird? Habe auch mal probiert ob ein anderes Image lokal über Pli angezeigt wird, ja wird es, wenn auf USB/HDD ein Image im Zipformat liegt. Sollte dann auch zu installieren sein? Was natürlich fehlt ist ein Backup der einzelnen Partitionen zu erstellen, geht mit Pli nicht. Wird das wie im ATV oder HDF noch eingebaut bzw. kommen?

 

So fehlerlos klappt das alles auch mit den beiden genannten Images nicht immer. Man sollte doch in Part. 1-4 ein Online Update machen können, das geht mal und dann wieder stürzt die Box bei der Auswahl Online flash bereits ab und ich muss in eine andere Partition gehen. Wenn man das halt alles von Part. 1 macht geht das aber halt für die verschiedenen Images nicht immer direkt online, sondern nur lokal über das Image in Part.1, sollte doch nicht im sinne des Erfinders sein? Was dahinter steckt habe ich nicht herausgefunden.

 

Vielleicht ist das ganze noch nicht zu 100% ausgereift. Habe z. Z. ATV per USB geflasht in Part.1 und von dort alles erledigt, auch Backups von den anderen Part. erstellt und wieder eingespielt, funzt alles bestens.

Vielleicht wird ja noch an der Formatierung gebastelt, Vorstellungen wie eine groß und 3 kleine Part. oder wirklich 4 mit je 1 GB ect. stehen dort zur Frage, mal sehen was da noch kommt oder auch nicht.

 

Gruß Mikel


Edited by mikel, 17 March 2019 - 20:53.


Re: OpenPli 7 Multiboot #30 mikel

  • Senior Member
  • 284 posts

0
Neutral

Posted 18 March 2019 - 10:41

Hi,

 

habe nochmals ein wenig mit den einzelnen Images im Multiboot getestet.

 

Habe in Startpart.1 ein ATV6.2 per USB gefasht, von dort aus Part.2-4 wie folgt geflasht:

in Part.2 das PLI7.0, in Part.3 das HDF6.4, in Part.4 ATV6.2.

Ich hatte in den Images von ATV und HDF Probleme das onlie/lokal flashen auszuwählen, es kam abwechselnd ein Absturz der Box, egal ob mal aus der Startpart.1 oder aus den wie oben bestückten Part.3-4.

Wenn ich dann die Images gewechselt habe wechselte auch wieder der crash bzw. ich konnte wieder flashen, sehr rätselhaft?

Heute habe ich nach updates im ATV z. Z. keine Probleme mehr, ich kann von Part.1 bzw. Part.4 online/lokal flash aktivieren und ich bekomme z. Z. keinen crash mehr. Habe Part.4 auf ATV6.3 aktualisiert ohne Probleme.

Beim HDF crasht weiter der Aufruf zum online/lokal flash, die Box stürzt ab und kann nur durch den Netzschalter wieder zum leben erweckt werden.

 

An was kann das liegen, an den einzelnen Images, die evtl. einen Bug haben?

Stelle mal Logfiles vom crash der Images aus Multiboot zur Einsicht mit hier zur Verfügung, vielleicht könnt ihr als Profis etwas erkennen.

 

Das PLI crasht nicht, kann vom Part2 mit onlineflash aktualisiert werden.

 

Danke vorab.

 

Gruß Mikel

Attached Files


Edited by mikel, 18 March 2019 - 10:44.


Re: OpenPli 7 Multiboot #31 Frenske

  • Forum Moderator
    PLi® Core member
  • 20,992 posts

+166
Excellent

Posted 18 March 2019 - 12:35

@Mikel,

Es kann sein das irgendwan in der Zukunft die Multiboot Funktionalität verbessern wird. Mehr kann ich dazu noch nicht sagen aber es gibt eine neue Initiative also müssen wir abwarten.
Mijn schotel is een T90 met 10 LNB's. Daarnaast voor de fun nog een draaibaar systeem met een Triax TD 78.

Een Dreambox DM 800-SE Verder nog een een VU+ duo met 500Gb harddisk + een VU+ Uno. + ook nog een Xtrend ET4000 en een Vu+ Zero erbij. Inmiddels heb ik ook nog een VU+ Duo2 erbij, een Vu+ Solo 4K, een Formuler F4, Xtrend ET10000, ET8500, ET7500, Mut@nt 2400HD, Xsarius Fusion HD se en nog het e.e.a.

Voor centrale opslag van media gebruik ik een Qnap 219P met tweemaal 2 Tb harddisks.

-------------------------------------------------------------------------------------------
Many answers to your question can be found in our wiki: Just one click away from this "solutioncentre".

Als ik alles al wist hoefde ik ook niets te vragen. If I had all the knowledge I had no questions at all.

Re: OpenPli 7 Multiboot #32 betacentauri

  • PLi® Core member
  • 4,979 posts

+233
Excellent

Posted 18 March 2019 - 18:22

Ja, lasst uns mal abwarten ob die neue Multiboot Umsetzung kommt oder nicht.

 

Die Crashes sind ja scheinbar in anderen Images aufgetreten. Da kann OpenPLi erstmal nichts machen. Bzw. nur wenn das PLi das verursacht, wovon ich im Moment nicht ausgehe. Im Prinzip wäre es gut, wenn alle Teams den gleichen Code verwenden würden. Das wird aber nicht ganz einfach sein das hinzubekommen.


Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: OpenPli 7 Multiboot #33 mikel

  • Senior Member
  • 284 posts

0
Neutral

Posted 18 March 2019 - 18:52

Hi Betacentauri,

 

kann man nicht im Pli-Image wenigstens das online/lokal flash + Backup integrieren, wie das in den zwei genannten Images der Fall ist? Somit kann man das Pli per USB flashen und von startpart.1 alle anderen Part. bedienen und auch davon Backups erstellen und wieder zurück flashen.

Warum ist das eigentlich nicht so gestaltet wie bei den genannten Images?

 

Bei Pli kann man über Flash Bild online eigene Images flashen und per USB/HDD im Zipformat auch Fremdimages. Aber Backups sind nicht möglich, habe auch das Pli per USB schon geflasht, hat sich aber nicht mit den anderen Images in den Part.2-4 vertragen und irgendwann kam es zum crash und dann habe ich ATV per USB als startimage in Part.1 geflasht, gibt auch mal die oben geschilderten Probleme aber soweit kann ich nun vorerst damit leben, bis eine evtl. perfekte Lösung kommt?

 

Hast Du mal in #29 und 30 gelesen und mal die crashlogs angeschaut?

Vielleicht sieht man da ja wo die Probleme liegen.

 

Gruß Mikel


Edited by mikel, 18 March 2019 - 18:54.


Re: OpenPli 7 Multiboot #34 betacentauri

  • PLi® Core member
  • 4,979 posts

+233
Excellent

Posted 18 March 2019 - 20:21

Ich bin mir recht sicher, dass man mit dem Plugin Backupsuite ein Backup des aktuell laufenden Image machen kann.
Es kann gut sein, dass man kein Backup der anderen 3 Images machen kann. Ist das dein Problem?

Na ja, es gibt eben unterschiedliche Entwickler. Die einen mögen lieber das eine und die anderen lieber das andere. Somit entsteht eben unterschiedlicher Code. Die PLi Variante hat ein paar Vorteile (man sieht automatisch welche Images installiert sind) während die anderen Images andere Vorteile haben.

Crashlogs habe ich nur sehr kurz überflogen. Müsste ich mir im Detail anschauen. Dazu habe ich im Moment aber keine Zeit.

Lass uns mal abwarten ob wirklich eine neue Lösung kommt. Wenn ja, lohnt sich der Aufwand nicht die jetzige Lösung nochmal zu überarbeiten.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: OpenPli 7 Multiboot #35 mikel

  • Senior Member
  • 284 posts

0
Neutral

Posted 19 March 2019 - 09:35

Hi Betacentauri,

 

ales klar, warten ob und was kommt, wenn nicht sollte man auch für sich die beste Lösung testen und nutzen.

 

Das mit der Backupsuite klappt sehr gut ohne Multiboot, innerhalb von Multiboot für Backups der Images in Part nicht geeignet. Habe ich schon probiert, kann man dann nicht zurückspielen, evtl. wenn PLI in startpart.1 liegt, aber das habe auch bereits getestet und war für die Nutzung im Multiboot nicht geeigent.

 

Es scheint wirklich so, dass die Images sich untereinander nicht vertragen, wie auch immer.

 

Vielleicht bis demnächst.

 

Gruß Mikel


Edited by mikel, 19 March 2019 - 09:35.


Re: OpenPli 7 Multiboot #36 mikel

  • Senior Member
  • 284 posts

0
Neutral

Posted 19 March 2019 - 11:03

Betacentauri, muss leider nochmals stören,

 

wenn ich nun parted -l ausführe bekomme ich nachfolgende Meldung, siehe auch in der Anlage bereitgestelltes Telnetprotokoll.

 

Unbekannte Partitionstabelle, die gesicherte GPT-Tabelle ist defekt, aber die primäre scheint in
Ordnung zu sein, daher wird diese verwendet.

 

Gestern war das noch ok, die Testerei bringt vielleicht doch nicht so viel!

Natürlich sammelt man reichlich Erkenntnisse, die dann auch Vorteile bringen.

Muss ich neu per USB flashen?

Sicher ist sicher, dann läuft das System wenigsten halbwegs gut.

 

Danke.

 

Gruß Mikel

Attached Files



Re: OpenPli 7 Multiboot #37 mikel

  • Senior Member
  • 284 posts

0
Neutral

Posted 19 March 2019 - 16:02

Habe nun neu per USB geflasht, diesesmal habe ich HDF genommen, funktioniert z. Z. in allen Partitionen mit den jeweiligen Images ohne Absturz.

 

Leider kommt bei Telneteingabe "parted -l" die in #36 beschriebene Fehlermeldung.

Die primäre Tabelle scheint in Ordnung zu sein, daher wird diese dann verwendet und auch korrekt angezeigt.

Der Flashspeicher scheint ok, oder ist da was defekt?

 

Mikel



Re: OpenPli 7 Multiboot #38 betacentauri

  • PLi® Core member
  • 4,979 posts

+233
Excellent

Posted 19 March 2019 - 17:25

Die Fehlermeldungen sind vollkommen normal und können ignoriert werden. Ich meine ich hatte oben schon geschrieben, dass du einfach Strg+c mehrfach drücken sollst bis alle Fehlermeldungen durch sind.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: OpenPli 7 Multiboot #39 mikel

  • Senior Member
  • 284 posts

0
Neutral

Posted 19 March 2019 - 18:01

Bis gestern hatte ich halt diese Fehlermeldungen nicht, nach der Ausführung mehrmals auf Strg+C gedrückt und die Anzeige war ohne Fehlermeldung da, nun eben nicht mehr.

 

Wenn Du sagst das kann man ignorieren, bin ich ja beruhigt.

 

Entschuldige dass ich nochmals nachgefragt habe!

 

Danke.

 

Tschüß Mikel



Re: OpenPli 7 Multiboot #40 betacentauri

  • PLi® Core member
  • 4,979 posts

+233
Excellent

Posted 19 March 2019 - 18:39

Kein Problem.

 

Es kann sein, dass nach einem Flashen von PLi per USB Stick weniger Fehler angezeigt werden. KANN sein. Im PLi wurde da mal etwas angepasst. Aus meiner Sicht kann man sie aber ignorieren.


Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users