Jump to content


Photo

Auto Language Selection - options not saved corectly


  • Please log in to reply
29 replies to this topic

Re: Auto Language Selection - options not saved corectly #21 littlesat

  • PLi® Core member
  • 56,477 posts

+693
Excellent

Posted 13 May 2024 - 11:37

This is a solution for this behavior..

 

https://github.com/O...6b8b535263e9fcf

 

Maybe we should also consider to 'backport' this one to 9.0 release and 8.3 as actually it is a bugfix.


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Auto Language Selection - options not saved corectly #22 Stan

  • Senior Member
  • 346 posts

0
Neutral

Posted 13 May 2024 - 12:25

Is there no other way to fix this? There's a good reason why configuration changes are saved to file only when Enigma is stopped.



Re: Auto Language Selection - options not saved corectly #23 WanWizard

  • PLi® Core member
  • 68,877 posts

+1,748
Excellent

Posted 13 May 2024 - 12:28

Originally because NAND flash was very slow to write to, so I/O was limited in Enigma, by design. This restriction is no longer present, especially on newer hardware, which all have eMMC.


Currently in use: VU+ Duo 4K (2xFBC S2), VU+ Solo 4K (1xFBC S2), uClan Usytm 4K Pro (S2+T2), Octagon SF8008 (S2+T2), Zgemma H9.2H (S2+T2)

Due to my bad health, I will not be very active at times and may be slow to respond. I will not read the forum or PM on a regular basis.

Many answers to your question can be found in our new and improved wiki.


Re: Auto Language Selection - options not saved corectly #24 Stan

  • Senior Member
  • 346 posts

0
Neutral

Posted 13 May 2024 - 12:41

Not because of the speed... Because of the limited write cycles.



Re: Auto Language Selection - options not saved corectly #25 littlesat

  • PLi® Core member
  • 56,477 posts

+693
Excellent

Posted 13 May 2024 - 12:45

Only the changed parameters are saved here.... the non changed are not saved.


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Auto Language Selection - options not saved corectly #26 WanWizard

  • PLi® Core member
  • 68,877 posts

+1,748
Excellent

Posted 13 May 2024 - 13:14

Not because of the speed... Because of the limited write cycles.

 

That is largely a myth.

 

We've calculated that even if you flash the box daily, it will still outlive you.


Currently in use: VU+ Duo 4K (2xFBC S2), VU+ Solo 4K (1xFBC S2), uClan Usytm 4K Pro (S2+T2), Octagon SF8008 (S2+T2), Zgemma H9.2H (S2+T2)

Due to my bad health, I will not be very active at times and may be slow to respond. I will not read the forum or PM on a regular basis.

Many answers to your question can be found in our new and improved wiki.


Re: Auto Language Selection - options not saved corectly #27 Stan

  • Senior Member
  • 346 posts

0
Neutral

Posted 13 May 2024 - 13:42

Flashing the box is one write cycle.

 

Writing to file every time a parameter is changed is more than that.

 

You'd be surprised how fast a flash memory can wear out with sloppy programming.



Re: Auto Language Selection - options not saved corectly #28 WanWizard

  • PLi® Core member
  • 68,877 posts

+1,748
Excellent

Posted 13 May 2024 - 13:47

UBI is pretty good at wear-leveling, something that wasn't there in DMM 7025 days... Anyway, these days no longer a real issue.
 

 You'd be surprised how fast a flash memory can wear out with sloppy programming.

 

Sloppy programming even wears me out... :)


Currently in use: VU+ Duo 4K (2xFBC S2), VU+ Solo 4K (1xFBC S2), uClan Usytm 4K Pro (S2+T2), Octagon SF8008 (S2+T2), Zgemma H9.2H (S2+T2)

Due to my bad health, I will not be very active at times and may be slow to respond. I will not read the forum or PM on a regular basis.

Many answers to your question can be found in our new and improved wiki.


Re: Auto Language Selection - options not saved corectly #29 Stan

  • Senior Member
  • 346 posts

0
Neutral

Posted 13 May 2024 - 13:59

Then why this quick and dirty workaround instead of finding the cause? There was no urgency.

And there is more to fix in that area. Post #2 has not been adressed yet, it may be related.

 

Before backporting to older versions, please consider that maybe a better fix is found.


Edited by Stan, 13 May 2024 - 14:09.


Re: Auto Language Selection - options not saved corectly #30 WanWizard

  • PLi® Core member
  • 68,877 posts

+1,748
Excellent

Posted 13 May 2024 - 15:22

I don't know, I'm not involved in this and haven't followed it. But I am in general against any form of hacking and workarounds...


Currently in use: VU+ Duo 4K (2xFBC S2), VU+ Solo 4K (1xFBC S2), uClan Usytm 4K Pro (S2+T2), Octagon SF8008 (S2+T2), Zgemma H9.2H (S2+T2)

Due to my bad health, I will not be very active at times and may be slow to respond. I will not read the forum or PM on a regular basis.

Many answers to your question can be found in our new and improved wiki.



1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users