Jump to content


1455

Member Since 13 Dec 2011
Offline Last Active Today, 12:15
*****

Topics I've Started

New skin.py and SkinSelector.py killed the old skins

21 July 2020 - 21:27

I have a question about skins supported by development branch.
Starting with commit eeabec7bfb126fe88a9452fc9596f6ee9db22aed all skins from 2015 at least have become unusable.
I understand that this is progress, but the respected developers didn't leave any information about what needs to be fixed in the skins. In addition, when developing on PC (Ubuntu 20.04), I get errors even for all original skins from the data folder:

[Skin] Error: Unable to parse skin data in '/usr/local/e2/share/enigma2/skin_default/skin.xml' - ''ElementTree' object has no attribute 'tag''!

But at the same time, PLi skins are successfully launched.

Is the reason in the Python version mismatches, own skin's scripts or its xml structure?