Jump to content


Photo

Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit


  • Please log in to reply
1791 replies to this topic

Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1781 ptergrand

  • Senior Member
  • 44 posts

0
Neutral

Posted 17 July 2020 - 22:34

1455 ;

hello teacher how are you

 

I couldn't do a Satellite Blindscan scan.

 

 

Attached Files



Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1782 1455

  • Senior Member
  • 328 posts

+4
Neutral

Posted 18 July 2020 - 09:38

I couldn't do a Satellite Blindscan scan.

https://rickcaylor.w...esting-10003441

It has two elements (need patches for PC).

1. A program to blindscan digital satellites signals.
https://github.com/a...ey/blindscan-s2
https://github.com/n0p/blindscan-s2
https://bitbucket.or...-s2/src/master/

2. Plugin for enigma2.
https://github.com/O...aster/blindscan

The main problem is support for only 3 types of tuners at the driver level.
I tried to write "Techisat SkyStar USB HD (DVB-S/S2)" which I have, but so far nothing has worked.
 



Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1783 ptergrand

  • Senior Member
  • 44 posts

0
Neutral

Posted 19 July 2020 - 02:19

Thank you very much for your information.
Best regards


Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1784 1455

  • Senior Member
  • 328 posts

+4
Neutral

Posted 21 July 2020 - 20:02

sudo add-apt-repository ppa:graphics-drivers/ppa

The nvidia 450.57 driver from this repository doesn't work with h265 with any player at all. Be careful with ppa!



Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1785 1455

  • Senior Member
  • 328 posts

+4
Neutral

Posted 21 July 2020 - 20:55

To Ubuntu 20.04 users and me as a keepsake. If you get update notifications over the video window, then do the following in Ubuntu (can't vouch for the accuracy of the translation for different countries):
'settings' -> 'notifications' -> 'application update' and turn off  'pop-up notifications'



Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1786 yuriy72

  • New Member
  • 2 posts

0
Neutral

Posted 5 August 2020 - 08:54

Hello 1455! it is greate that you use GIT now!  :)



Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1787 ptergrand

  • Senior Member
  • 44 posts

0
Neutral

Posted 14 August 2020 - 00:13

Ubuntu 20.04

 

4. If you have Intel or AMD integrated GPU, use "opengl" video driver in the xine.conf.

 

sudo star@star-Vostro-3670:~$ sudo /usr/src/OpenPLi-PC/xine-lib-1.2-1.2.10+hg-e2pc/debian/tmp/usr/bi

n/xine-config
[sudo] star için parola:  
Usage: xine-config [OPTIONS] [LIBRARIES]
      DEPRECATED. Use pkg-config instead.
Options:
       [--prefix[=DIR]]
       [--exec-prefix[=DIR]]
       [--version]
       [--libs]
       [--acflags]
       [--cflags]
       [--bindir]
       [--plugindir]
       [--datadir]
       [--scriptdir]
       [--localedir]
       [--xine-list]
       [--objcflags]

 

sudo /usr/local/e2/bin/enigma2

 

[Screen] Showing screen 'NetworkWizard'.
[Skin] Processing screen 'Volume', position=(80, 150), size=(42 x 540) for module 'Volume'.
[Screen] Warning: Skin is missing element 'VolumeText' in <class 'Screens.Volume.Volume'>.
[Skin] Processing screen 'Mute', position=(180, 225), size=(68 x 90) for module 'Mute'.
[Volume] Volume set to 50.
[cXineLib] I have XINE event ---  14
[cXineLib] xine_event_handler(): event->type: 14
[Skin] Processing screen 'Scart', position=(0, 0), size=(1920 x 1080) for module 'Scart'.
[Console] command: /usr/sbin/ntpdate -s -u pool.ntp.org
[cXineLib] FRAMERATE: 1000
video_out_vaapi Error : vaapi_create_subpicture(): unknown libva error
video_out_vaapi Error : vaPutSurface(): unknown libva error
video_out_vaapi Error : vaapi_create_subpicture(): unknown libva error
video_out_vaapi Error : vaPutSurface(): unknown libva error
video_out_vaapi Error : vaapi_create_subpicture(): unknown libva error
Backtrace:
/usr/local/e2/bin/enigma2(_Z17handleFatalSignaliP9siginfo_tPv) [0x5612E235A64D]
/lib/x86_64-linux-gnu/libpthread.so.0(n/a) [0x7F2A1B36F3C0]
/usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so(n/a) [0x7F2A17E271C5]
/usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so(n/a) [0x7F2A17E196D4]
/usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so(n/a) [0x7F2A17DFBCEA]
/usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so(n/a) [0x7F2A18020D83]
/usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so(n/a) [0x7F2A18024727]
/usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so(n/a) [0x7F2A180249AA]
/usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so(n/a) [0x7F2A17FECD5B]
/usr/lib/xine/plugins/2.8/xineplug_vo_out_vaapi.so(n/a) [0x7F2A1C7F15AB]
/usr/lib/libxine.so.2(n/a) [0x7F2A1BC46584]
/usr/lib/libxine.so.2(n/a) [0x7F2A1BC4BB53]
/lib/x86_64-linux-gnu/libpthread.so.0(n/a) [0x7F2A1B363609]
/lib/x86_64-linux-gnu/libc.so.6(clone) [0x7F2A1B28A103]
-------FATAL SIGNAL
Parçalama arızası

 

 



Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1788 ptergrand

  • Senior Member
  • 44 posts

0
Neutral

Posted 14 August 2020 - 00:33

video_out_vaapi Error : vaapi_create_subpicture(): unknown libva error
video_out_vaapi Error : vaPutSurface(): unknown libva error
video_out_vaapi Error : vaapi_create_subpicture(): unknown libva error
video_out_vaapi Error : vaPutSurface(): unknown libva error
video_out_vaapi Error : vaapi_create_subpicture(): unknown libva error
video_out_vaapi Error : vaPutSurface(): unknown libva error
[Console] finished: /usr/sbin/ntpdate -s -u pool.ntp.org
[RTC] set RTC offset to -75600 sec.
XNextEvent 2
connectionLost? [Failure instance: Traceback (failure with no frames): <class 'twisted.internet.error.ConnectionLost'>: Connection to the other side was lost in a non-
clean fashion: Connection lost.
]
[RTC] set RTC offset to -75600 sec.
stopping xModem autorun pppd
stop execute pppd
[EPGImport] autostart (1) occured at 1597361572.3
[EPGImport] Stop
XNextEvent 3
video_out_vaapi Error : vaapi_create_subpicture(): unknown libva error
video_out_vaapi Error : vaPutSurface(): unknown libva error
[cXineLib] Unloading post plugins
[cXineLib] Close stream
[cXineLib] Dispose queue
[cXineLib] I have XINE event ---  7
[cXineLib] xine_event_handler(): event->type: 7
[cXineLib] Demux flush
[cXineLib] Dispose stream
[cXineLib] Dispose ao_port
video_out_vaapi Error : vaPutSurface(): unknown libva error
[cXineLib] Dispose vo port
video_out: max frames used: 2 of 25
video_out: early wakeups: 0 of 325
[cXineLib] Done.

 

Attached Files



Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1789 1455

  • Senior Member
  • 328 posts

+4
Neutral

Posted 14 August 2020 - 10:32

You have a UHD-630 graphics core. I still don't understand why e2pc doesn't work with the iHD driver. But you can use the i965 driver. To do this, add to /etc/environment

#LIBVA_DRIVER_NAME=i915
LIBVA_DRIVER_NAME=i965
#LIBVA_DRIVER_NAME=iHD

Write later what happens. My result is bad. Intel deinterlacing is terrible. When scaling the 1080 channel to 4k, the screen is very laggy. However, 4k content uses hardware acceleration on the Cofee Lake core with the i965 driver.

 

There is no need to generate a new config. It is placed automatically.


Edited by 1455, 14 August 2020 - 10:37.


Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1790 ptergrand

  • Senior Member
  • 44 posts

0
Neutral

Posted 14 August 2020 - 20:53

I'm back in Ubuntu 18.04

 

When i install ubuntu 20.04 i will test it again

 

Thank you very much for your information



Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1791 RevPir

  • Member
  • 23 posts

+1
Neutral

Posted 3 September 2020 - 14:22

Hi 1455,

Is it possible to use the fallback tuner in enigma2pc?

When I select it, it works with the first channel but it stops working if i change the channel, even with the host receiver on standby.

Any suggestion?

Thank you again.


MSI B350 PC MATE - AMD Ryzen™ 3 2200G with Radeon™ Vega 8 Graphics* - 8 GB ram DDR4 - Nvidia GeForce® GT 730 2 GB

TechniSat DVB-PC SkyStar HD2 PCI-Express - Ubuntu 18.04 LTS And Ubuntu 20.04 LTS - * Radeon™ Vega 8 Graphics not in use.


Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1792 1455

  • Senior Member
  • 328 posts

+4
Neutral

Posted 4 September 2020 - 08:58

Sorry, I have not tested this mode, as it implies no dvb card on the remote PC. For example, this is a PC in another room connected to the main PC through a router. In this case, the channel list on the remote PC will be gray, as written here. That is, the channels are initially unavailable.
In addition, you need to find out which port is not busy and specify it. For example, these should not be ports for the oscam web interface or the OpenWebIF plugin.
I don't know your receivers configuration. If both PC have a dvb card, then the remote receiver mode doesn't make sense at all. Even if they are connected to the same dish through a priority switch, receive on the slave PC will be possible in the polarization and range that is set in the master tuner. Of course this doesn't require remote tuner mode.
If you really need remote mode, it is not enough to simply disconnect the cable from second PC. Try to remove the dvb card or compress the her firmware on the remote PC, if it is installed there, and specify a free port.
 

 

 

 

 

 
 

 

 

 


Edited by 1455, 4 September 2020 - 09:00.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users