Jump to content


Photo

crond & firewall.sh switch on freeze and block dm500

firewall iptables crond dm500

  • Please log in to reply
2 replies to this topic

#1 fagenland

  • Member
  • 10 posts

0
Neutral

Posted 19 March 2012 - 19:47

Problem when activating services firewall and crond in dm500 OpenPLi 20120319

Hello, first my excuses by my English quite little and bad. Also I have to confess that in Linux I am limited, but have interest and I read.

I have to congratulate and to thank for to pli team by its work, because at least for dm500 Chinese this image works and allows to work correctly, as far as functions and yield for my is the best one.


I have problems when activating firewall.

From the blue button of the control, setup/services him frame start to firewall and crond and later to knows and ..... the result is that deco is blocked and communication HTTP and FTP no longer returns. Unique remedy before this, to return to the Dreamup and reflash. He is not nothing, but a little time is lost to return to form the things.

I have formed mounted /media/var and /media/hdd, as well as a file swap in /hdd. I have the CCcam that comes with the image working like client. Streaming works totally. With this I say that I have several adjustments that to realize when I must return to dreamup, reason why I have decided to go to that they know but that I before returning to have the same result.

Investigating, I have solved that could correct it when publishing the /var/bin/firewall.sh file and change parameter ALLOW_LAN_ACCESS= " 0 " to ALLOW_LAN_ACCESS= " 1 " before activating the service of firewall. This would be correct? I mean, would avoid the block.

On the other hand, another adjustment related to firewall is the one of the /var/etc/firewall file users, this file, comes with directions written thus:

192.168.0.1 # Main PC
10.0.0.1 # .....
176.126.65.98 # friend
Google.com # mr Google.

I have erased it to this and simply I have put directions IP of my PC´s and the Router, just in case, thus:

XXX.XXX.XXX.XXX
XXX.XXX.XXX.XXX


This is correct? That is to say, I understand that having the parameter I do not have to include to own dreambox nor commentary some?

At the moment I have the DM500 without the services mentioned marked from the menu but already I have modified the archives.


When I write by telnet from dcc:

firewall.sh status

iptables v1.3.5: can't initialize iptables table `filter': Table does not exist
(do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.


Another data that makes me think is that in the /var/iptables folder some file does not exist. Here it is necessary to put some file?

Thanks for your time and greetings.

Re: crond & firewall.sh switch on freeze and block dm500 #2 fagenland

  • Member
  • 10 posts

0
Neutral

Posted 20 March 2012 - 21:30

Hi, te problem is /var on lan & swap file on /media/hdd.

Re: crond & firewall.sh switch on freeze and block dm500 #3 dAF2000

  • Forum Moderator
    PLi® Core member
  • 14,136 posts

+52
Good

Posted 21 March 2012 - 17:38

Welcome on this forum.

I have erased it to this and simply I have put directions IP of my PC´s and the Router, just in case, thus:

XXX.XXX.XXX.XXX
XXX.XXX.XXX.XXX


This is correct? That is to say, I understand that having the parameter I do not have to include to own dreambox nor commentary some?


Yes, this is correct. You only need to mention the IP addresses of allowed hosts. So, add the IP address of your pc/laptop. No other changes are needed.
Many answers to your question can be found in our wiki: http://openpli.org/wiki





Also tagged with one or more of these keywords: firewall, iptables, crond, dm500

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users