Jump to content


Photo

dvb-usb-af9015 - not working on OpenPLi 3

dvbt af9015 kernel

  • Please log in to reply
41 replies to this topic

#1 robertut

  • Senior Member
  • 344 posts

+2
Neutral

Posted 18 July 2013 - 17:56

Hello people,

 

Trying to use an af9015-based USB DVB-T tuner (Leadtek WinFast DTV Dongle Gold), which used to work perfectly on OpenPLi 2.1, and OpenPLi 3.0 until recently.

 

After an online update, the box doesn't boot anymore. Dmesg says:

usb 2-1.2: new full-speed USB device number 3 using ehci-brcm
UBIFS: mounted UBI device 0, volume 0, name "rootfs"(null)
UBIFS: LEB size: 126976 bytes (124 KiB), min./max. I/O unit sizes: 2048 bytes/2048 bytes
UBIFS: FS size: 118468608 bytes (112 MiB, 933 LEBs), journal size 9023488 bytes (8 MiB, 72 LEBs)
UBIFS: reserved for root: 0 bytes (0 KiB)
UBIFS: media format: w4/r0 (latest is w4/r0), UUID 879ABCBC-F51F-4A09-B9F8-825BA8200234, small LPT model
VFS: Mounted root (ubifs filesystem) on device 0:10.
devtmpfs: mounted
Freeing unused kernel memory: 300k freed
usbcore: registered new interface driver tpm
dvb: module_layout: kernel tainted.
Disabling lock debugging due to kernel taint
input: dreambox remote control (native) as /devices/virtual/input/input1
input: dreambox advanced remote control (native) as /devices/virtual/input/input2
DVB: registering new adapter (dvb0)
platform dvb0.0: DVB: registering adapter 0 frontend 0 (DVB-S2)...
input: front panel as /devices/virtual/input/input3
NET: Registered protocol family 10
usb 1-2: dvb_usb_v2: found a 'Leadtek WinFast DTV Dongle Gold' in cold state
usbcore: registered new interface driver dvb_usb_af9015
usb 1-2: dvb_usb_v2: downloading firmware from file 'dvb-usb-af9015.fw'
usb 1-2: dvb_usb_v2: found a 'Leadtek WinFast DTV Dongle Gold' in warm state
usb 1-2: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
DVB: registering new adapter (Leadtek WinFast DTV Dongle Gold)
i2c i2c-4: af9013: firmware version 4.95.0.0
usb 1-2: DVB: registering adapter 1 frontend 0 (Afatech AF9013)...
tda18271 4-00c0: creating new instance
TDA18271HD/C2 detected @ 4-00c0
Registered IR keymap rc-leadtek-y04g0051
input: Leadtek WinFast DTV Dongle Gold as /devices/platform/ehci-brcm.0/usb1/1-2/rc/rc0/input4
rc0: Leadtek WinFast DTV Dongle Gold as /devices/platform/ehci-brcm.0/usb1/1-2/rc/rc0
usb 1-2: dvb_usb_v2: schedule remote query interval to 500 msecs
usb 1-2: dvb_usb_v2: 'Leadtek WinFast DTV Dongle Gold' successfully initialized and connected
svc: failed to register lockdv1 RPC service (errno 124).
tda18271: performing RF tracking filter calibration
CPU 0 Unable to handle kernel paging request at virtual address 0005696b, epc == cc805cfc, ra == cc805cf4
Oops[#1]:
Cpu 0
$ 0   : 00000000 10008700 00000000 000562eb
$ 4   : cc805d30 cc805c06 00000000 00000000
$ 8   : 00000061 09140039 84848484 84848484
$12   : 000562eb 3b9aca00 00000000 00000000
$16   : cc805d0c cddd7400 00000000 e15d9714
$20   : cffc7080 00000001 80720000 cffc706c
$24   : 00000003 8005ae58
$28   : cc804000 cc805c70 00000029 cc805cf4
Hi    : 00000004
Lo    : b74ac5c0
epc   : cc805cfc 0xcc805cfc
    Tainted: GF          O
ra    : cc805cf4 0xcc805cf4
Status: 10008703    KERNEL EXL IE
Cause : 00800008
BadVA : 0005696b
PrId  : 0002a044 (Brcm4380)
Modules linked in: dvb_usb_af9015 dvb_usb_v2 af9013 mxl5007t dvb_pll mt2060 tda18218 mxl5005s qt1010 ipv6 dvb(OF) modloader2(O) modloader(O) tpm(O)
Process kdvb-ad-1-fe-0 (pid: 409, threadinfo=cc804000, task=cdc7c488, tls=00000000)
Stack : 00000002 fffffff5 fffbbb3f 02bde780 807d0000 80437af0 00000001 cddd7400
        00000000 cddd7400 cffc7080 cc805d0c cde58c00 cddd7404 cde58c00 cde58ca0
        00000000 80438fd8 00000000 00000004 00000001 00000001 cc805cf4 00000002
        cde58c00 8044af74 807c7f40 cde58ca0 00000000 02bde780 cc805d04 805f6224
        00000000 000000c0 cc800001 cc805cf0 000100c0 00000027 cc805d0c 4e034884
        ...
Call Trace:
[<80437af0>] __i2c_transfer+0x90/0xc8
[<80438fd8>] i2c_transfer+0x78/0xd8
[<8044af74>] tda18271_read_extended+0x70/0x178
[<805f6224>] schedule_timeout+0x154/0x1e0
[<8044bdec>] tda18271c2_rf_cal_init+0x320/0xcb8
[<8046e4b0>] dvb_frontend_thread+0x0/0x518
[<8044c938>] tda18271_init+0x1b4/0x1bc
[<80050000>] commit_creds+0xe4/0x374
[<e15fa2dc>] af9015_af9013_init+0x8c/0xa8 [dvb_usb_af9015]
[<8046e4b0>] dvb_frontend_thread+0x0/0x518
[<80050000>] commit_creds+0xe4/0x374
[<e15fa178>] af9015_tuner_init+0x78/0xa8 [dvb_usb_af9015]
[<80054220>] dequeue_task+0x1c/0x40
[<8046cebc>] dvb_frontend_init+0x4c/0x7c
[<805f814c>] __schedule+0x3d8/0x8e8
[<80052fb4>] __wake_up_common+0x68/0xc0
[<8046e508>] dvb_frontend_thread+0x58/0x518
[<8046e4b0>] dvb_frontend_thread+0x0/0x518
[<8005329c>] complete+0x48/0x68
[<8046e4b0>] dvb_frontend_thread+0x0/0x518
[<80047670>] kthread+0xbc/0xc4
[<800475b4>] kthread+0x0/0xc4
[<800057c0>] ret_from_kernel_thread+0x10/0x18

Please point me in the right direction, to make it work with actual image version.



Re: dvb-usb-af9015 - not working on OpenPLi 3 #2 mattiL

  • Senior Member
  • 268 posts

+5
Neutral

Posted 18 July 2013 - 20:23

I don't know much about this, but have you tried to boot without the DTV dongle?



Re: dvb-usb-af9015 - not working on OpenPLi 3 #3 rhinoceros

  • Senior Member
  • 491 posts

+21
Neutral

Posted 18 July 2013 - 22:11

Interesting. I posted a similar issue in the dutch part of the forum. I have a USB DVB-T Nova-T stick. Since recently, probably since the upgrade to 3.8.7 kernel my box (ET9X00) hangs with 'Booting...; in the display. The stick is detected and registered but seems to fail initialization. Yet exactly the same configuration has been working without any such issue now for two years.

 

Are there others that have issues with boxes that do not boot with the recent kernel update? If so, which USB devices do you use - if any?



Re: dvb-usb-af9015 - not working on OpenPLi 3 #4 robertut

  • Senior Member
  • 344 posts

+2
Neutral

Posted 20 July 2013 - 21:24

I don't know much about this, but have you tried to boot without the DTV dongle?

 

Yes. Without the DTV dongle plugged in, the box boots up successfully.

 

It worked perfectly until a recent update. The DTV dongle is not faulty, it works perfectly on a PC.



Re: dvb-usb-af9015 - not working on OpenPLi 3 #5 robertut

  • Senior Member
  • 344 posts

+2
Neutral

Posted 20 July 2013 - 21:25

Since recently, probably since the upgrade to 3.8.7 kernel my box (ET9X00) hangs with 'Booting...; in the display.

 

Is there any way to actually downgrade back the kernel to an older version which still works?



Re: dvb-usb-af9015 - not working on OpenPLi 3 #6 Erik Slagter

  • PLi® Core member
  • 45,365 posts

+498
Excellent

Posted 21 July 2013 - 09:05

By the way, this is a KERNEL OOPS. Most of the time this means a bug in a driver (in this case indeed the USB stick).
* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: dvb-usb-af9015 - not working on OpenPLi 3 #7 robertut

  • Senior Member
  • 344 posts

+2
Neutral

Posted 21 July 2013 - 17:15

Hmmm... how can it be a bug in the af9015 driver, while in earlier kernel versions worked perfectly with the same driver, moreover, on OpenPLi 2.1 it still works just fine! With the same driver.



Re: dvb-usb-af9015 - not working on OpenPLi 3 #8 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 21 July 2013 - 17:20

Hmmm... how can it be a bug in the af9015 driver, while in earlier kernel versions worked perfectly with the same driver, moreover, on OpenPLi 2.1 it still works just fine! With the same driver.

you are contradicting yourself ;)
The driver is included in the kernel, so a different kernel version means a different driver version.

Re: dvb-usb-af9015 - not working on OpenPLi 3 #9 robertut

  • Senior Member
  • 344 posts

+2
Neutral

Posted 21 July 2013 - 17:56

I thought that the driver is being installed from the plugins manager download menu, from the "driver" category. If that's not the driver, what is it then? I'm asking because the box works fine even with the DTT stick plugged in, until I install the (so-called?) driver from the plugins menu. Does the kernel change during this process?

 

Installing is required because otherwise it couldn't be seen in the tuners list. After install completes, a reboot is required, and the box hangs during bootup.


Edited by robertut, 21 July 2013 - 17:57.


Re: dvb-usb-af9015 - not working on OpenPLi 3 #10 rhinoceros

  • Senior Member
  • 491 posts

+21
Neutral

Posted 21 July 2013 - 18:50

Strange because the dib0700 driver seems to have the same issue. Box hangs only sometimes in booting. That is then 2 drivers broken. Perhaps a change in the driver interface in kernel 3.8.7?



Re: dvb-usb-af9015 - not working on OpenPLi 3 #11 Erik Slagter

  • PLi® Core member
  • 45,365 posts

+498
Excellent

Posted 21 July 2013 - 19:09

I thought that the driver is being installed from the plugins manager download menu, from the "driver" category. If that's not the driver, what is it then? I'm asking because the box works fine even with the DTT stick plugged in, until I install the (so-called?) driver from the plugins menu. Does the kernel change during this process?

 

Installing is required because otherwise it couldn't be seen in the tuners list. After install completes, a reboot is required, and the box hangs during bootup.

You assume, by the fact that driver is loaded as a module, that the driver is a seperate entity from the kernel. Your assumption is wrong. Modules are pieces of the kernel that aren't loaded by default. Every module is different from kernel to kernel version.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: dvb-usb-af9015 - not working on OpenPLi 3 #12 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 21 July 2013 - 19:23

Strange because the dib0700 driver seems to have the same issue. Box hangs only sometimes in booting. That is then 2 drivers broken. Perhaps a change in the driver interface in kernel 3.8.7?


No, the issues have no relation.
This one causes an oops, while yours is a timing issue during init.

Re: dvb-usb-af9015 - not working on OpenPLi 3 #13 robertut

  • Senior Member
  • 344 posts

+2
Neutral

Posted 21 July 2013 - 20:10

OK. I understand.

 

Another question then.

 

I have a couple of older OpenPLi images saved on my PC, like for example "OpenPLi-3.0-beta-et6x00-20130316_usb.zip". I used to have this version running perfectly with my af9015 DTT stick until I made an update.

Now I took this 20130316 image, flashed it back - installed driver from online feed, and the box crashed. I don't understand why... Could somebody explain me?

 

Was the af9015 package on the server feed changed since 20130316, when it was still functional with the images with kernels available at THAT time?

 

I'd be happy to restore the functional state with my fresh 20130316 image I saved back then, and the af9015 package + its dependencies which were available back then...


Edited by robertut, 21 July 2013 - 20:11.


Re: dvb-usb-af9015 - not working on OpenPLi 3 #14 betacentauri

  • PLi® Core member
  • 5,575 posts

+253
Excellent

Posted 21 July 2013 - 21:20

The image uses most likely an older kernel. Drivers or better modules are build against a kernel version. So you try to use kernel x with driver for kernel y. That don't work.
It seems that the feed contains only the latest versions.
Don't you have an old fullbackup which you can use? (Always make one, then you don't have these troubles)
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: dvb-usb-af9015 - not working on OpenPLi 3 #15 robertut

  • Senior Member
  • 344 posts

+2
Neutral

Posted 21 July 2013 - 22:26

Unfortunately I don't. I only have a backup of OpenPLi 2.1, which I had to revert to now...

That's why I'm seeking for help.

 

Could anyone please give me at least some version numbers or file names of older af9015 modules in .ipk format? Hopefully I can find anything on some forums...


Edited by robertut, 21 July 2013 - 22:27.


Re: dvb-usb-af9015 - not working on OpenPLi 3 #16 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 22 July 2013 - 08:20

OK. I understand.
 
Another question then.
 
I have a couple of older OpenPLi images saved on my PC, like for example "OpenPLi-3.0-beta-et6x00-20130316_usb.zip". I used to have this version running perfectly with my af9015 DTT stick until I made an update.
Now I took this 20130316 image, flashed it back - installed driver from online feed, and the box crashed. I don't understand why... Could somebody explain me?

when you install the drivers from the feed, the kernel is updated (as a dependency).
You need a 3.8.7 kernel in order to install a 3.8.7 driver

Was the af9015 package on the server feed changed since 20130316, when it was still functional with the images with kernels available at THAT time?

Yes, the af9015 package version is 3.8.7 now, because it is part of the kernel.

Re: dvb-usb-af9015 - not working on OpenPLi 3 #17 robertut

  • Senior Member
  • 344 posts

+2
Neutral

Posted 22 July 2013 - 15:31

Is there a place where I could find older package versions I could manually install with opkg on older image version?



Re: dvb-usb-af9015 - not working on OpenPLi 3 #18 Erik Slagter

  • PLi® Core member
  • 45,365 posts

+498
Excellent

Posted 22 July 2013 - 15:58

Yes, actually you would need both the older kernel and the corresponding modules, which might be difficult, as the kernel is in the image and the modules are in the feed (which are not archived).


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: dvb-usb-af9015 - not working on OpenPLi 3 #19 betacentauri

  • PLi® Core member
  • 5,575 posts

+253
Excellent

Posted 22 July 2013 - 18:53

Try this one. Do you need other modules, too?

Attached Files


Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: dvb-usb-af9015 - not working on OpenPLi 3 #20 robertut

  • Senior Member
  • 344 posts

+2
Neutral

Posted 22 July 2013 - 21:56

Wow, thanks a million! I'd love to have the dependencies of this, too.







Also tagged with one or more of these keywords: dvbt, af9015, kernel

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users