Jump to content


Photo

Openpli and Python

Python

  • Please log in to reply
15 replies to this topic

#1 zeros

  • PLi® Contributor
  • 1,138 posts

+42
Good

Posted 15 April 2015 - 06:00

Whether all the boxes use today version 2.7? or use any of the box 2.6 yet?
I can see, my dreambox use Python version 2.7.3

(2.6 & 2.7)
DM920UHD DVB-S2X TRIPLE tuner + Triple M.S tuner DVB-S2X, DVB-T2/T, QboxHD, QboxHD Mini, Icecrypt T2300HD,
Qviart Lunix3 4K

Vertex 4K60 4:4:4 600MHz

Re: Openpli and Python #2 janejak

  • Senior Member
  • 281 posts

+10
Neutral

Posted 15 April 2015 - 23:48

newest Python version 2.7.9 for vu+ duo2 but openpli stil use 2.7.3



Re: Openpli and Python #3 zeros

  • PLi® Contributor
  • 1,138 posts

+42
Good

Posted 16 April 2015 - 04:04

Python 3.5.0a3 is the latest. I just want to know if all the boxes are useing one and the same Python version (that useing openpli4)? Therefore older versions (2.6.x) do not use today none of the boxes, is it so?
DM920UHD DVB-S2X TRIPLE tuner + Triple M.S tuner DVB-S2X, DVB-T2/T, QboxHD, QboxHD Mini, Icecrypt T2300HD,
Qviart Lunix3 4K

Vertex 4K60 4:4:4 600MHz

Re: Openpli and Python #4 MiLo

  • PLi® Core member
  • 13,873 posts

+290
Excellent

Posted 16 April 2015 - 17:15

I'm sure there's a real question in here somewhere. What is it that you want to know or do?
Real musicians never die - they just decompose

Re: Openpli and Python #5 athoik

  • PLi® Core member
  • 7,867 posts

+291
Excellent

Posted 16 April 2015 - 17:21

When OE updated by OpenPLi, most probably 2.7.9 will land..

The SNI support that 2.7.9 has is a good reason.
Wavefield T90: 0.8W - 1.9E - 4.8E - 13E - 16E - 19.2E - 23.5E - 26E - 33E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916

Re: Openpli and Python #6 zeros

  • PLi® Contributor
  • 1,138 posts

+42
Good

Posted 16 April 2015 - 20:12

It is known that a higher version has more features. On the other hand a higher version may not be supported by the box which uses a lower level Python. I know which version I have, but whether all the boxes using the same level of Python, I do not know. The question is prompted by adapting plugins, which author is someone else, not me.
I can see folders
/usr/lib/python2.6
/usr/lib/python2.7
So if all the boxes that use Openpli4, can handle the higher (2.7) version, this is my question.

Edited by zeros, 16 April 2015 - 20:13.

DM920UHD DVB-S2X TRIPLE tuner + Triple M.S tuner DVB-S2X, DVB-T2/T, QboxHD, QboxHD Mini, Icecrypt T2300HD,
Qviart Lunix3 4K

Vertex 4K60 4:4:4 600MHz

Re: Openpli and Python #7 MiLo

  • PLi® Core member
  • 13,873 posts

+290
Excellent

Posted 16 April 2015 - 21:58

All openpli boxes run 2.7 currently. If there's a python2.6 dir, that is probably a bug in some plugin.

Python is upgraded with the rest of oe. Which we don't do too often as it causes hundreds of package upgrades.

Edited by MiLo, 16 April 2015 - 22:02.

Real musicians never die - they just decompose

Re: Openpli and Python #8 zeros

  • PLi® Contributor
  • 1,138 posts

+42
Good

Posted 17 April 2015 - 04:14

Got it! Thank you very much for your answer. I'm counting then that all boxes using PLi today, use the same version of Python.
DM920UHD DVB-S2X TRIPLE tuner + Triple M.S tuner DVB-S2X, DVB-T2/T, QboxHD, QboxHD Mini, Icecrypt T2300HD,
Qviart Lunix3 4K

Vertex 4K60 4:4:4 600MHz

Re: Openpli and Python #9 MiLo

  • PLi® Core member
  • 13,873 posts

+290
Excellent

Posted 17 April 2015 - 14:47

Just wondering, why do you care? There isn't much difference between versions, and what works on 2.6 will still work on 2.7 and beyond.
Real musicians never die - they just decompose

Re: Openpli and Python #10 athoik

  • PLi® Core member
  • 7,867 posts

+291
Excellent

Posted 17 April 2015 - 15:18

Personally I would like to switch on 2.7.9 cause of SNI support.

SNI is really a must if you want to access secure services.

http://en.wikipedia....Name_Indication
Wavefield T90: 0.8W - 1.9E - 4.8E - 13E - 16E - 19.2E - 23.5E - 26E - 33E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916

Re: Openpli and Python #11 zeros

  • PLi® Contributor
  • 1,138 posts

+42
Good

Posted 17 April 2015 - 16:03

In response to MiLo, if Google 'python 2.6 and 2.7 differences' can find a number of differences, but I'm not an expert to bring them out. It is a fact that all the things do not go in the same way- probably should adjust then in the program.
DM920UHD DVB-S2X TRIPLE tuner + Triple M.S tuner DVB-S2X, DVB-T2/T, QboxHD, QboxHD Mini, Icecrypt T2300HD,
Qviart Lunix3 4K

Vertex 4K60 4:4:4 600MHz

Re: Openpli and Python #12 MiLo

  • PLi® Core member
  • 13,873 posts

+290
Excellent

Posted 18 April 2015 - 10:55

Python 2.6 programs (and earlier versions too) will run fine in 2.7 without any changes. Only Python 3 breaks backwards compatibility with the 2.x series and requires changes to source code to work.
Real musicians never die - they just decompose

Re: Openpli and Python #13 MiLo

  • PLi® Core member
  • 13,873 posts

+290
Excellent

Posted 18 April 2015 - 10:59

I pushed a master-next branch that might work (and has python 2.7.9).
Real musicians never die - they just decompose

Re: Openpli and Python #14 truebeleive

  • Member
  • 2 posts

0
Neutral

Posted 9 August 2017 - 22:49

hay fox i need a solution for the iptvplayer 1700

i keep getting that error to download a patch SNI for python with most servers especial GOMOVIES

any solution please let me know i love GO MOVIES it replaces 123 movies and now its not working  i am running OpenPli enigma2 any help would be great thanks in advance.

forgot to mention i have python2.7


Edited by truebeleive, 9 August 2017 - 22:50.


Re: Openpli and Python #15 MrForce

  • Member
  • 1 posts

0
Neutral

Posted 12 August 2017 - 20:21

hay fox i need a solution for the iptvplayer 1700

i keep getting that error to download a patch SNI for python with most servers especial GOMOVIES

any solution please let me know i love GO MOVIES it replaces 123 movies and now its not working  i am running OpenPli enigma2 any help would be great thanks in advance.

forgot to mention i have python2.7

 

Hi,

 

I have the same problem :wacko:

 

Many regards

MrForce :D



Re: Openpli and Python #16 WanWizard

  • Forum Moderator
    PLi® Core member
  • 47,482 posts

+793
Excellent

Posted 12 August 2017 - 20:25

Should be no problem on 6.0-rc?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users