Jump to content


Photo

Cool TV Guide wants to upgrade to non-existing new version


  • Please log in to reply
111 replies to this topic

Re: Cool TV Guide wants to upgrade to non-existing new version #41 Thijs_Rallye

  • Senior Member
  • 76 posts

+1
Neutral

Posted 1 February 2017 - 19:24

Ok, I just ran into the problem that CoolTVGuide immediately shut itself down upon opening. Since the upgrade isn't available via the regular application catalog I decided to google around a bit and it appears the plugin "kills" itself from Februari the 1st 2017, which I've found out the hard way. (today after ignoring the update popup for months :P)

 

Anyways, since 7.3 was working fine for me I found that editing the plugin.py file at line 74 did the trick. (credits: BigBlack66 @ https://www.boxpirat...dbceb4e0de57815 ).

 

eolvs = '81201727584562'

 

change it to

 

eolvs = '81209927584562'

 

Or change it to whatever year you like. Otherwise you can just use the plugin.py attached.

 

So for anyone concerning the same issue copy the attached plugin.py to /Root/usr/lib/enigma2/python/Plugins/Extensions/CoolTVGuide, delete plugin.pyo (or rename to plugin.pyo.bak just in case), reboot enigma and it is working again till Februari 2099 without the update alert.

 

 

Thijs

Attached Files



Re: Cool TV Guide wants to upgrade to non-existing new version #42 WanWizard

  • Forum Moderator
    PLi® Core member
  • 51,479 posts

+953
Excellent

Posted 1 February 2017 - 19:41

Isn't it brillant, software with timebombs in it...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (C), Zgemma H6(fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Cool TV Guide wants to upgrade to non-existing new version #43 mynameistoolong

  • Member
  • 1 posts

0
Neutral

Posted 1 February 2017 - 19:58

hi all 

going to egg tv guide  pop up cool man guide won't let me go to tv guide

was working yesterday  except for it coming up when clicked out of egg guide forcing me to click again to get rid of pop up

 

 



Re: Cool TV Guide wants to upgrade to non-existing new version #44 littlesat

  • PLi® Core member
  • 50,810 posts

+564
Excellent

Posted 1 February 2017 - 20:57

I would recommend to increase that number much higher.... or simply use our standard gmepg... ;)

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Cool TV Guide wants to upgrade to non-existing new version #45 mrvica

  • Senior Member
  • 817 posts

+49
Good

Posted 1 February 2017 - 21:43

>>> eolvs = '81209927584562'
by the end of centuary we are all dead, no need to increase it higher, @littlesat you have a sense of humor

Re: Cool TV Guide wants to upgrade to non-existing new version #46 littlesat

  • PLi® Core member
  • 50,810 posts

+564
Excellent

Posted 1 February 2017 - 21:52

;)

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Cool TV Guide wants to upgrade to non-existing new version #47 spss1970

  • Member
  • 2 posts

0
Neutral

Posted 1 February 2017 - 22:58

Thijs_Rallye ....I did exactly as you suggested and used your plugin.py file. The reboot seemed to create a new plugin.pyo file. However when I invoke the coolguide it just flicks up empty and disappears again (before I put in your plugin.py file it flicked up momentarily with epg-items and then gave me the please upgrade coolguide messagemessage). Today is February the 1st....so everything you say is consistent with my problem. Any ideas as I am a novice! I FTP'd in ASCII

Re: Cool TV Guide wants to upgrade to non-existing new version #48 littlesat

  • PLi® Core member
  • 50,810 posts

+564
Excellent

Posted 1 February 2017 - 22:59

Yep see post #44

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Cool TV Guide wants to upgrade to non-existing new version #49 spss1970

  • Member
  • 2 posts

0
Neutral

Posted 1 February 2017 - 23:08

Thijs_Rallye ....I did exactly as you suggested and used your plugin.py file. The reboot seemed to create a new plugin.pyo file. However when I invoke the coolguide it just flicks up empty and disappears again (before I put in your plugin.py file it flicked up momentarily with epg-items and then gave me the please upgrade coolguide messagemessage). Today is February the 1st....so everything you say is consistent with my problem. Any ideas as I am a novice! I FTP'd in ASCII .........

 

 

 

  :) Sorry...resolved...thanks a million. I ommitted to change the 2017--->2099 value in the eolvs line   :)



Re: Cool TV Guide wants to upgrade to non-existing new version #50 littlesat

  • PLi® Core member
  • 50,810 posts

+564
Excellent

Posted 2 February 2017 - 07:51

So you hacker cool tv and use illegal software... while you could use gmepg legally?

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Cool TV Guide wants to upgrade to non-existing new version #51 Deezel

  • Member
  • 6 posts

0
Neutral

Posted 2 February 2017 - 10:31

Cool guide is open source. It's not hacking to change a line of script to repair it. How is it illegal?

Re: Cool TV Guide wants to upgrade to non-existing new version #52 littlesat

  • PLi® Core member
  • 50,810 posts

+564
Excellent

Posted 2 February 2017 - 11:40

As far I know the source is closed.... The sources that occur are likely de-compiled pyo or pyc files... 


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Cool TV Guide wants to upgrade to non-existing new version #53 pierreVU

  • Member
  • 1 posts

0
Neutral

Posted 2 February 2017 - 12:33

Thanks for the pyi file.  Can you tell me however how I put this into my VU solo2.  I do not have that experience.  Do I need both files ( pyi and IPK).  Just put them on USB stick and into the VU?

 

Pierre Belgium



Re: Cool TV Guide wants to upgrade to non-existing new version #54 littlesat

  • PLi® Core member
  • 50,810 posts

+564
Excellent

Posted 2 February 2017 - 13:45

Just remove the complete plugin and use the GMEPG.... it is 99% the same....


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Cool TV Guide wants to upgrade to non-existing new version #55 Deezel

  • Member
  • 6 posts

0
Neutral

Posted 2 February 2017 - 14:28

Full plugin 7.6 on git hub, though compiled .pyo only. I assumed plugin.py posted here was decompiled.

Re: Cool TV Guide wants to upgrade to non-existing new version #56 BvE

  • Member
  • 4 posts

0
Neutral

Posted 2 February 2017 - 14:43

He means...

 

"use the GMEPG (Graphical Multi EPG) that is standard included in our image... instead of using the closed source Cool TV Guide...."

 

Cool TV Guide is not mandatory

Hello, not it is 2 February and my EPG information is gone using Cool TV Guide. I have deleted Cool TV plugin, but I do not get the standard EPG info (GMEPG).

What needs to be done to get GMEPG


Arion PVR9400

VU+ Duo2 with Dual Tuner / Canal Digitaal Netherlands


Re: Cool TV Guide wants to upgrade to non-existing new version #57 dirocca

  • Senior Member
  • 1,667 posts

+59
Good

Posted 2 February 2017 - 14:47

long press epg button?

 

grtz Philip


vuduo2 openpli6.1 1TB HDD 2xdualS2tuner

av receiver denon - samsung 4k hdr+ 65inch UE65MU7000 - bose accoustimas 7.1 :rolleyes:

tvv kaart & schotel(64cm), duo lnb, OSCAM

logitech harmony ultimate

 

 

 


Re: Cool TV Guide wants to upgrade to non-existing new version #58 Deezel

  • Member
  • 6 posts

0
Neutral

Posted 2 February 2017 - 16:10

I see Ihave the gmepg plugin in my files. Never even knew. How do I configure to use it instead of cool epg. Is this in addition to the system epg accessed by pressing the OK button. I use PKT image.

Re: Cool TV Guide wants to upgrade to non-existing new version #59 hgroth

  • Senior Member
  • 40 posts

0
Neutral

Posted 2 February 2017 - 16:40

thank you for the fix it worked but now my guide is only half the TV screen, how can I fix that?



Re: Cool TV Guide wants to upgrade to non-existing new version #60 littlesat

  • PLi® Core member
  • 50,810 posts

+564
Excellent

Posted 2 February 2017 - 17:53

Use GMEPG instead and press yellow button... for the 3rd time...


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users