Jump to content


Photo

Mediaportal Installation fehlgeschlagen

mediaportal xtrend et4000

  • Please log in to reply
21 replies to this topic

#1 grillgott

  • Member
  • 1 posts

0
Neutral

Posted 5 May 2017 - 18:45

Hallo Zusammen,

 

ich habe hier schon einige Threads durch aber bisher bin ich leider auf noch keine passende Lösung gestoßen, hoffentlich könnt Ihr mir helfen. Ich möchte gerne die aktuelle Version von Mediaportal auf meinen XTrend ET4000 installieren (gestern Abend geupdated). Per Telnet habe ich folgende Befehle ausgeführt nachdem ich die aktuelle ipk nach /tmp geschoben habe:

 

opkg update
opkg install python-mechanize
opkg install python-argparse
cd /tmp
opkg install *.ipk --force-depends

 

Ausgabe in Putty sieht wie folgt aus:

 

root@et4x00:~# opkg update
Updated list of available packages in /var/lib/opkg/openpli-3rd-party-et4x00.
Updated list of available packages in /var/lib/opkg/openpli-3rd-party.
Updated list of available packages in /var/lib/opkg/openpli-all.
Updated list of available packages in /var/lib/opkg/openpli-et4x00.
Updated list of available packages in /var/lib/opkg/openpli-mips32el-nf.
root@et4x00:~# opkg install python-mechanize
Package python-mechanize (0.2.5-r2.3) installed in root is up to date.
root@et4x00:~# opkg install python-argparse
Package python-argparse (2.7.3-r5.3.3) installed in root is up to date.
root@et4x00:~# cd /tmp
root@et4x00:/var/volatile/tmp# opkg install *.ipk --force-depends
Installing enigma2-plugin-extensions-mediaportal (8.0.8) on root.
Checking for an older version of MediaPortal in the system...
An older version of MediaPortal was found
Checking free space...
Proceeding to installation...
Configuring enigma2-plugin-extensions-mediaportal.
********************************************************
*  MediaPortal installed                               *
*                                                      *
*  Restart the Engima2 GUI to activate the plugin      *
********************************************************
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for enigma2-plugin-extensions-mediaportal:
 *      python-six *    python-requests (>= 2.0.0) *    python-js2py (>= 0.37) *
 
Mir ist klar dass die letzte Zeile anzeigt weshalb die Installation fehlschlägt, allerdings kann ich diese Packages nicht nachinstallieren.
 
Habt ihr eine Lösung für das Problem?
 
EDIT: Das hat auch nicht funktioniert
 
root@et4x00:~# opkg update
Updated list of available packages in /var/lib/opkg/openpli-3rd-party-et4x00.
Updated list of available packages in /var/lib/opkg/openpli-3rd-party.
Updated list of available packages in /var/lib/opkg/openpli-all.
Updated list of available packages in /var/lib/opkg/openpli-et4x00.
Updated list of available packages in /var/lib/opkg/openpli-mips32el-nf.
root@et4x00:~# opkg install python-six
Unknown package 'python-six'.
Collected errors:
 * opkg_install_cmd: Cannot install package python-six.
root@et4x00:~# opkg install python-requests
Not selecting python-requests 1.2.3 as installing it would break existing dependencies.
Unknown package 'python-requests'.
Collected errors:
 * opkg_install_cmd: Cannot install package python-requests.
root@et4x00:~# opkg install python-js2py
Unknown package 'python-js2py'.
Collected errors:
 * opkg_install_cmd: Cannot install package python-js2py.
 
 
Vielen Dank schon mal im Voraus!

Edited by grillgott, 5 May 2017 - 18:49.


Re: Mediaportal Installation fehlgeschlagen #2 sirtobie

  • Senior Member
  • 136 posts

+9
Neutral

Posted 5 May 2017 - 19:41

Musst du manuell nachinstallieren.

Gucks du: https://forums.openp...attach_id=78950


VG 
sirtobie


Re: Mediaportal Installation fehlgeschlagen #3 heckenhugo

  • Member
  • 12 posts

0
Neutral

Posted 6 May 2017 - 19:14

Hi,
obwohl die Installation der benoetigten Packages aus dem Download scheinbar funktioniert, will sich MediaPortal nicht installieren lassen: 
root@osmini:/var/volatile/tmp# opkg install enigma2-plugin-extensions-mediaportal_8.0.8_all.ipk
Installing enigma2-plugin-extensions-mediaportal (8.0.8) on root.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for enigma2-plugin-extensions-mediaportal:
 *      python-six *    python-requests (>= 2.0.0) *    python-js2py (>= 0.37) * 
 * opkg_install_cmd: Cannot install package enigma2-plugin-extensions-mediaportal
root@osmini:/var/volatile/tmp# opkg install python-six_1.7.3-r1_mips32el.ipk 
Installing python-six (1.7.3-r1) on root.
Configuring python-six. 
root@osmini:/var/volatile/tmp# opkg install python-requests_2.11.1\+git0\+58d855e193-r0.0_mips32el.ipk 
Installing rch: mips32el (2.11.1+git0+58d855e193-r0.0) on root. 
Configuring rch: mips32el. 
root@osmini:/var/volatile/tmp# opkg install python-js2py_0.39+git0\+144b1701fa-r0.0_mips32el.ipk 
Installing rch: mips32el (0.39+git0+144b1701fa-r0.0) on root. 
Configuring rch: mips32el. 
root@osmini:/var/volatile/tmp# opkg install enigma2-plugin-extensions-mediaportal_8.0.8_all.ipk 
Installing enigma2-plugin-extensions-mediaportal (8.0.8) on root. 
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for enigma2-plugin-extensions-mediaportal:
 * python-requests (>= 2.0.0) * python-js2py (>= 0.37) *
 * opkg_install_cmd: Cannot install package enigma2-plugin-extensions-mediaportal.
...nur python-six scheint er anzuerkennen...
Hat jmd noch einen Tip?

Edited by heckenhugo, 6 May 2017 - 19:18.


Re: Mediaportal Installation fehlgeschlagen #4 Pumuckel

  • Senior Member
  • 305 posts

+16
Neutral

Posted 6 May 2017 - 19:50

Versuch es mal mit diesen Abhängigkeiten

 

 

Attached Files



Re: Mediaportal Installation fehlgeschlagen #5 sirtobie

  • Senior Member
  • 136 posts

+9
Neutral

Posted 6 May 2017 - 22:06

Versuche es mal so: opkg install --force-depends *.ipk

 

Außerdem hättest du die Abhängigkeiten nicht vorinstallieren müssen. Ich habe zuerst das Mediaportal (aber mit --force-depends) installiert und danach die fehlenden Abhängigkeiten manuell nachinstalliert. Läuft prima außer dem Streamanbieter "vivo". Habe sogar online auf die Version 8.1.0 geupt.


VG 
sirtobie


Re: Mediaportal Installation fehlgeschlagen #6 heckenhugo

  • Member
  • 12 posts

0
Neutral

Posted 6 May 2017 - 23:17

Versuch es mal mit diesen Abhängigkeiten

sauber, damit hats geklappt. Besten Dank

Re: Mediaportal Installation fehlgeschlagen #7 ricki

  • Senior Member
  • 295 posts

+2
Neutral

Posted 11 May 2017 - 07:14

Lässt sich Mediaportal auf Solo 4K Installieren?



Re: Mediaportal Installation fehlgeschlagen #8 Pumuckel

  • Senior Member
  • 305 posts

+16
Neutral

Posted 11 May 2017 - 17:24

Ja --> klick hier



Re: Mediaportal Installation fehlgeschlagen #9 ricki

  • Senior Member
  • 295 posts

+2
Neutral

Posted 11 May 2017 - 18:27

Ja --> klick hier

Vielen Dank



Re: Mediaportal Installation fehlgeschlagen #10 drouski

  • Senior Member
  • 25 posts

0
Neutral

Posted 8 September 2017 - 12:37

Hallo allerseits,

seit gestern habe ich das Problem an einer Vu+soloseV2, dass das update von Mediaportal von 8.1.9 auf 8.9.9 nicht geht mit der folgenden Fehlermeldung:

 

mediaportal/enigma2-plugin-extensions-mediaportal_8.9.9_all.ipk.

Upgrading enigma2-plugin-extensions-mediaportal from 8.1.8 to 8.9.9 on root.

Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for enigma2-plugin-extensions-mediaportal:
 *     python-pyexecjs *     nodejs *
 * opkg_install_cmd: Cannot install package enigma2-plugin-extensions-mediaportal.

kann mir jemand einen Tipp geben, wie ich diese Abhängigkeiten: mediaportal/enigma2-plugin-extensions-mediaportal_8.9.9_all.ipk.
                                                                                                       Upgrading enigma2-plugin-extensions-mediaportal from 8.1.8 to 8.9.9 on root.
                                                                                                       Collected errors:
                                                                                                      * satisfy_dependencies_for: Cannot satisfy the following dependencies for enigma2-plugin-extensions-mediaportal:

                                                                                                      *     python-pyexecjs *     nodejs *

                                                                                                      * opkg_install_cmd: Cannot install package enigma2-plugin-extensions-mediaportal.

installieren kann?



 



Re: Mediaportal Installation fehlgeschlagen #11 mikel

  • Senior Member
  • 308 posts

0
Neutral

Posted 8 September 2017 - 19:18

Hallo,

 

habe das gleiche Problem wie im #10 genannt, Mediaportal update von 8.1.9 auf 8.9.9 auf meiner ET9000 funktioniert nicht. Liegt das an der ET9000 und dem Pli 4.0, der Boxspeicher ist für 6.0 einfach zu klein und auslagern auf USB möchte ich nicht.

 

Kann jemand die fehlenden Dateien bereitstellen und helfen?

 

Danke.

 

Gruß Mikel


Edited by mikel, 8 September 2017 - 19:21.


Re: Mediaportal Installation fehlgeschlagen #12 mikel

  • Senior Member
  • 308 posts

0
Neutral

Posted 9 September 2017 - 09:02

Hallo drouski,

 

nun steht die Version 9.0.1 zur Verfügung und damit funktioniert wieder das normale Update, war scheinbar ein Fehler im Plugin.

 

Gruß Mikel



Re: Mediaportal Installation fehlgeschlagen #13 treehe

  • Senior Member
  • 53 posts

0
Neutral

Posted 9 September 2017 - 14:59

Habe ein xMediaPortalUpdater gebastelt:
http://tinyurl.com/xmpupdate-tar-gz

 

Mit Dream-Explorer installieren und Benutzeroberfläche (Enigma) neu starten

Jetzt kann man ihn unter Plugins ausführen.

 

Alternative nur http://tinyurl.com/plugin-sh unter herunterladen und plugin.sh
und von Hand ausführen.

 

Gruss Treehe

 

P.S. Nur für Enigma 2.0 Boxen


Edited by treehe, 9 September 2017 - 15:01.


Re: Mediaportal Installation fehlgeschlagen #14 drouski

  • Senior Member
  • 25 posts

0
Neutral

Posted 9 September 2017 - 17:56

Danke, das Update geht wieder, allerdings ohne die graue Zone.

Ich habe das MP 8.9.9 mit force depends installiert und das  enigma2-plugin-extensions-mpgz_1.0.0_all.ipk.

So habe ich das meiste von der gr. Zone. Ich habe allerdings das automatische Update bei MP deaktiviert.



Re: Mediaportal Installation fehlgeschlagen #15 flattervogel

  • Senior Member
  • 30 posts

+3
Neutral

Posted 14 September 2017 - 11:34

Hier 2 wichtige IPKs fürs Mediaportal.

Attached Files



Re: Mediaportal Installation fehlgeschlagen #16 treehe

  • Senior Member
  • 53 posts

0
Neutral

Posted 17 September 2017 - 15:45

Etwas beim Installieren von python-pyexecjs-node_1.4.0-r0-6.11.2_all.ipk klappt nicht.

Beim nächsten installieren von Mediaportal wird das Fehlen von:

phthon-pyexecjs und nodejs

immer noch bemängelt.

Media Portal läst sich nur mit --force-depends installieren.

Hat jemand eine funktionierende ipk für Openpli 4 Enigma 2 Images?



Re: Mediaportal Installation fehlgeschlagen #17 flattervogel

  • Senior Member
  • 30 posts

+3
Neutral

Posted 17 September 2017 - 17:36

Warum nicht updaten auf Openpli 6 RC???



Re: Mediaportal Installation fehlgeschlagen #18 treehe

  • Senior Member
  • 53 posts

0
Neutral

Posted 17 September 2017 - 17:48

dm 8000 und openpli 6 ? Enigma 2 nicht 2.x


Edited by treehe, 17 September 2017 - 17:49.


Re: Mediaportal Installation fehlgeschlagen #19 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,785 posts

+834
Excellent

Posted 17 September 2017 - 17:51

Ja, waarum nicht? https://openpli.org/...dreambox/DM8000


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Mediaportal Installation fehlgeschlagen #20 treehe

  • Senior Member
  • 53 posts

0
Neutral

Posted 17 September 2017 - 20:01

Habe schnell ein Fullbackup meiner DM8000 gemacht.

Dann die http://downloads.ope...00-20170916.zip aufgespiel.

Leider konnte ich dann die Media Portal weder mit

opkg install -force-overwrite /tmp/enigma2-plugin-extensions-mediaportal_9.0.3_all.ipk
opkg install --force-depends /tmp/enigma2-plugin-extensions-mediaportal_9.0.3_all.ipk
installieren.

Habe nun mein Backup zurück gespielt.

Und hoffe einfach mal das jemand noch eine

phthon-pyexecjs und nodejs

für Openpli 4 schreibt.







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users