Jump to content


Photo

Zgemma H7S Multiboot not working...

Multiboot Zgemma H7S

  • Please log in to reply
17 replies to this topic

#1 gorski

  • Senior Member
  • 1,700 posts

+46
Good

Posted 5 August 2017 - 09:33

Hello, guys!

Got Zgemma H7S and I wanted to install 4 images in 4 ROM partitions, of course...

 

After OpenATV 6.1, which has the Multiboot options, I installed openpli-6.0-rc-h7-20170803_multiboot

It's just that either I don't know how to get into OpenPLi Multiboot/Multi OS installation menu (and I spent some time searching for it) - or it doesn't work...

 

I know how to do it in OpenATV:

Settings > Software Manager > flash online/local > yellow button (Startup_2 or whichever partition one wants) > find kernel.bin (where one put it, in the receiver) > green button (Flash) > when it's done, EXIT a number of times times > POWER button > MultiBoot > right arrow to choose the next image/partition > OK > reboot into that image...

OpenPLi flashing multiboot image is small, so I simply transferred it using FileZilla Client to a USB stick...

 

So, what's the procedure in OpenPLi, please? (If it works...)


<span style='font-family: comic sans ms,cursive'>"Enlightenment is man's emergence from his self-incurred immaturity. Immaturity is the inability to use one's own understanding without the guidance of another. This immaturity is self-incurred if its cause is not lack of understanding, but lack of resolution and courage to use it without the guidance of another. The motto of enlightenment is therefore: Sapere aude! Have courage to use your own understanding!</span><br /> <br /><span style='font-family: comic sans ms,cursive'>Laziness and cowardice are the reasons why such a large proportion of men, even when nature has long emancipated them from alien guidance..." I. Kant, "Political writings" (1784)</span><br /> <br /><span style='font-family: comic sans ms,cursive'><a class='bbc_url' href='<a class='bbc_url' href='http://eserver.org/p...lightenment.txt'>http://eserver.org/p...ent.txt</a>'><a class='bbc_url' href='http://www.english.upenn.edu/~mgamer/Etexts/kant.html</a>'>http://www.english.upenn.edu/~mgamer/Etexts/kant.html</a></a> - the jolly text on Enlightenment, at the basis of Modernity...</span>

Re: Zgemma H7S Multiboot not working... #2 littlesat

  • PLi® Core member
  • 49,479 posts

+533
Excellent

Posted 5 August 2017 - 09:48

It is not there yet... Maybe in 6.1. And we cannot copy it from Openatv sonwe have to rewite it. E.g. Openatv's implementation is full of os.system calls.
And indeed openpli images are smaller...

Edited by littlesat, 5 August 2017 - 09:49.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Zgemma H7S Multiboot not working... #3 betacentauri

  • PLi® Core member
  • 5,520 posts

+251
Excellent

Posted 5 August 2017 - 10:17

There are 2 options at the moment.
1. Install atv image first. Then flash OpenPLi multiboot image into partition 2, 3 or 4
2. This is quite difficult. Use ofgwrite and flash multiboot image from telnet command prompt. Problem is that latest ofgwrite is not included in rc6.0. So you have to format the destination partition manually before you start ofgwrite. So better use option 1.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: Zgemma H7S Multiboot not working... #4 littlesat

  • PLi® Core member
  • 49,479 posts

+533
Excellent

Posted 5 August 2017 - 10:20

Mmm Sounds we need a pm to get the latest ofgwrite with format included...
But you still have another small issue.. you can't easily switch back to open atv...

First I need to extend our FlashImage functionality which is in progress in our develop images...

Edited by littlesat, 5 August 2017 - 10:25.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Zgemma H7S Multiboot not working... #5 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,849 posts

+835
Excellent

Posted 5 August 2017 - 10:23

pr you mean?

 

I can cherry pick it if you pass me the develop comment.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Zgemma H7S Multiboot not working... #6 littlesat

  • PLi® Core member
  • 49,479 posts

+533
Excellent

Posted 5 August 2017 - 10:26

Do not cherry pick it... Leave it in rc6.1. I try to resolve flashimage in a stot and restart to image slot for rc6.1.

Edited by littlesat, 5 August 2017 - 10:26.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Zgemma H7S Multiboot not working... #7 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,849 posts

+835
Excellent

Posted 5 August 2017 - 13:04

ok.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Zgemma H7S Multiboot not working... #8 gorski

  • Senior Member
  • 1,700 posts

+46
Good

Posted 5 August 2017 - 18:45

Thanx!

I see, os calls leading to forking and needing loads of RAM...

 

My problem, however: you really shouldn't name the image "Multiboot", guys...

 

Otherwise I would have installed an image which has the multiboot manager etc. Now I have to see what, if anything I can do... I.e. I shall try installing another image and hope it will be over the second partition, where OpenPLi is... I'll report back when I do it.

 

P.S. Indeed, I did install OpenATV first and then OpenPLi - but I can not get out of OpenPLi now, naturally...


<span style='font-family: comic sans ms,cursive'>"Enlightenment is man's emergence from his self-incurred immaturity. Immaturity is the inability to use one's own understanding without the guidance of another. This immaturity is self-incurred if its cause is not lack of understanding, but lack of resolution and courage to use it without the guidance of another. The motto of enlightenment is therefore: Sapere aude! Have courage to use your own understanding!</span><br /> <br /><span style='font-family: comic sans ms,cursive'>Laziness and cowardice are the reasons why such a large proportion of men, even when nature has long emancipated them from alien guidance..." I. Kant, "Political writings" (1784)</span><br /> <br /><span style='font-family: comic sans ms,cursive'><a class='bbc_url' href='<a class='bbc_url' href='http://eserver.org/p...lightenment.txt'>http://eserver.org/p...ent.txt</a>'><a class='bbc_url' href='http://www.english.upenn.edu/~mgamer/Etexts/kant.html</a>'>http://www.english.upenn.edu/~mgamer/Etexts/kant.html</a></a> - the jolly text on Enlightenment, at the basis of Modernity...</span>

Re: Zgemma H7S Multiboot not working... #9 littlesat

  • PLi® Core member
  • 49,479 posts

+533
Excellent

Posted 5 August 2017 - 20:23

They are needed to prepare the online flashing and online multiboot flashing... So please hold on...

Edited by littlesat, 5 August 2017 - 20:27.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Zgemma H7S Multiboot not working... #10 jakey

  • Senior Member
  • 129 posts

+3
Neutral

Posted 6 August 2017 - 00:26

Thanx!

I see, os calls leading to forking and needing loads of RAM...

 

My problem, however: you really shouldn't name the image "Multiboot", guys...

 

Otherwise I would have installed an image which has the multiboot manager etc. Now I have to see what, if anything I can do... I.e. I shall try installing another image and hope it will be over the second partition, where OpenPLi is... I'll report back when I do it.

 

P.S. Indeed, I did install OpenATV first and then OpenPLi - but I can not get out of OpenPLi now, naturally...

 

You should install and try 'Automatic Full Backup 5.6 by Dima73 ,  it has full support for totally managing multiboot on my HD51,  the Zgemma H7S was added recently with 5.6 https://github.com/D...14cc37053b2a141 .  On my HD51 it's all I need for full management of images including adding the 'Multiboot switcher' to the start menu.


Edited by jakey, 6 August 2017 - 00:28.


Re: Zgemma H7S Multiboot not working... #11 littlesat

  • PLi® Core member
  • 49,479 posts

+533
Excellent

Posted 6 August 2017 - 07:49

Indeed this is currenly an alternative...
But I'm happy that fullbackup is not really required anymore (soon)

Edited by littlesat, 6 August 2017 - 07:51.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Zgemma H7S Multiboot not working... #12 gorski

  • Senior Member
  • 1,700 posts

+46
Good

Posted 6 August 2017 - 08:44

Cool, thanx!


<span style='font-family: comic sans ms,cursive'>"Enlightenment is man's emergence from his self-incurred immaturity. Immaturity is the inability to use one's own understanding without the guidance of another. This immaturity is self-incurred if its cause is not lack of understanding, but lack of resolution and courage to use it without the guidance of another. The motto of enlightenment is therefore: Sapere aude! Have courage to use your own understanding!</span><br /> <br /><span style='font-family: comic sans ms,cursive'>Laziness and cowardice are the reasons why such a large proportion of men, even when nature has long emancipated them from alien guidance..." I. Kant, "Political writings" (1784)</span><br /> <br /><span style='font-family: comic sans ms,cursive'><a class='bbc_url' href='<a class='bbc_url' href='http://eserver.org/p...lightenment.txt'>http://eserver.org/p...ent.txt</a>'><a class='bbc_url' href='http://www.english.upenn.edu/~mgamer/Etexts/kant.html</a>'>http://www.english.upenn.edu/~mgamer/Etexts/kant.html</a></a> - the jolly text on Enlightenment, at the basis of Modernity...</span>

Re: Zgemma H7S Multiboot not working... #13 gorski

  • Senior Member
  • 1,700 posts

+46
Good

Posted 16 October 2017 - 03:54

Guys, a quick Q: does openpli-6.0-release-h7-20171015_multiboot.zip contain full multiboot function, please? Or is it still called 'Multiboot' but it isn't?

 

I don't want to install it and mess up the other installations... I wanted to check Dmitrij's Device Manager but...

 

Thanx!


<span style='font-family: comic sans ms,cursive'>"Enlightenment is man's emergence from his self-incurred immaturity. Immaturity is the inability to use one's own understanding without the guidance of another. This immaturity is self-incurred if its cause is not lack of understanding, but lack of resolution and courage to use it without the guidance of another. The motto of enlightenment is therefore: Sapere aude! Have courage to use your own understanding!</span><br /> <br /><span style='font-family: comic sans ms,cursive'>Laziness and cowardice are the reasons why such a large proportion of men, even when nature has long emancipated them from alien guidance..." I. Kant, "Political writings" (1784)</span><br /> <br /><span style='font-family: comic sans ms,cursive'><a class='bbc_url' href='<a class='bbc_url' href='http://eserver.org/p...lightenment.txt'>http://eserver.org/p...ent.txt</a>'><a class='bbc_url' href='http://www.english.upenn.edu/~mgamer/Etexts/kant.html</a>'>http://www.english.upenn.edu/~mgamer/Etexts/kant.html</a></a> - the jolly text on Enlightenment, at the basis of Modernity...</span>

Re: Zgemma H7S Multiboot not working... #14 betacentauri

  • PLi® Core member
  • 5,520 posts

+251
Excellent

Posted 16 October 2017 - 06:03

No, it doesn't contain all multiboot functionalities. In 6.1 everything is included.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: Zgemma H7S Multiboot not working... #15 gorski

  • Senior Member
  • 1,700 posts

+46
Good

Posted 16 October 2017 - 09:50

Thank you!

 

I couldn't find one to download - does that mean one must compile it from GIT? I.e. it is not readily available?


<span style='font-family: comic sans ms,cursive'>"Enlightenment is man's emergence from his self-incurred immaturity. Immaturity is the inability to use one's own understanding without the guidance of another. This immaturity is self-incurred if its cause is not lack of understanding, but lack of resolution and courage to use it without the guidance of another. The motto of enlightenment is therefore: Sapere aude! Have courage to use your own understanding!</span><br /> <br /><span style='font-family: comic sans ms,cursive'>Laziness and cowardice are the reasons why such a large proportion of men, even when nature has long emancipated them from alien guidance..." I. Kant, "Political writings" (1784)</span><br /> <br /><span style='font-family: comic sans ms,cursive'><a class='bbc_url' href='<a class='bbc_url' href='http://eserver.org/p...lightenment.txt'>http://eserver.org/p...ent.txt</a>'><a class='bbc_url' href='http://www.english.upenn.edu/~mgamer/Etexts/kant.html</a>'>http://www.english.upenn.edu/~mgamer/Etexts/kant.html</a></a> - the jolly text on Enlightenment, at the basis of Modernity...</span>

Re: Zgemma H7S Multiboot not working... #16 Dimitrij

  • PLi® Core member
  • 6,579 posts

+210
Excellent

Posted 16 October 2017 - 11:08

See PM


Lunix3-4K/VU+solo4k(thanks guys to gisclub.tv)


Re: Zgemma H7S Multiboot not working... #17 gorski

  • Senior Member
  • 1,700 posts

+46
Good

Posted 18 October 2017 - 02:18

Multiboot - from what I can see, as an IT lay person - is not really Multiboot, it seems, in the newest OpenPLi...??? Namely,

 

1) it can't be flashed from a proper Multiboot image - a loop... Even though I chose which partition to install it into... And I have both zipped and decompressed image on the USB stick...

 

Attached File  no go.jpg   68.62KB   2 downloads

 

2) Once installed other images already in the box are not possible to see... Only OpenPLi:

 

Attached File  no go_b.jpg   54.41KB   1 downloads

 

Not sure what is going on ATM...

 

Sorry to have to report this...

 

 


<span style='font-family: comic sans ms,cursive'>"Enlightenment is man's emergence from his self-incurred immaturity. Immaturity is the inability to use one's own understanding without the guidance of another. This immaturity is self-incurred if its cause is not lack of understanding, but lack of resolution and courage to use it without the guidance of another. The motto of enlightenment is therefore: Sapere aude! Have courage to use your own understanding!</span><br /> <br /><span style='font-family: comic sans ms,cursive'>Laziness and cowardice are the reasons why such a large proportion of men, even when nature has long emancipated them from alien guidance..." I. Kant, "Political writings" (1784)</span><br /> <br /><span style='font-family: comic sans ms,cursive'><a class='bbc_url' href='<a class='bbc_url' href='http://eserver.org/p...lightenment.txt'>http://eserver.org/p...ent.txt</a>'><a class='bbc_url' href='http://www.english.upenn.edu/~mgamer/Etexts/kant.html</a>'>http://www.english.upenn.edu/~mgamer/Etexts/kant.html</a></a> - the jolly text on Enlightenment, at the basis of Modernity...</span>

Re: Zgemma H7S Multiboot not working... #18 Pr2

  • PLi® Contributor
  • 3,706 posts

+157
Excellent

Posted 23 June 2018 - 18:38

Hi,

 

For people finding this thread after a search on the forum, I just test Multiboot online flash on a Zgemma H7.

It is working, the only pre-requisite is to:

- have an internal HDD (ext4 formated)

or

- have external USB stick ext4 formated inserted into the Zgemma H7 during the flashing process

 

The external USB stick can be later on removed from the STB, it is used as a temporary storage to:

- download the image from the OpenPLi server

- create the backup on the current configuration to restore it on the flashed image.

 

So the flash and configuration are written in the internal Zgemma memory so the USB stick can be removed for normal use (except if you decide to store your picons on it for exemple).


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 






Also tagged with one or more of these keywords: Multiboot, Zgemma, H7S

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users