Jump to content


Photo

Checksum errors bouwen openpli

openpli

  • Please log in to reply
9 replies to this topic

#1 r00tc0d3

  • Senior Member
  • 31 posts

0
Neutral

Posted 6 January 2018 - 11:33

Hallo,

Ik ben zelf OpenPli aan het bouwen maar krijg de volgende melding:

WARNING: libpcre-native-8.39-r0 do_fetch: Checksum mismatch for local file /home/openpli/openpli-oe-core/sources/pcre-8.39.tar.bz2
Cleaning and trying again.
WARNING: libpcre-native-8.39-r0 do_fetch: Renaming /home/openpli/openpli-oe-core/sources/pcre-8.39.tar.bz2 to /home/openpli/openpli-oe-core/sources/pcre-8.39.tar.bz2_bad-checksum_ca478d2c2d563917ec8c1d52deff7e70
WARNING: libpcre-native-8.39-r0 do_fetch: Checksum failure encountered with download of http://downloads.sourceforge.net/projects/pcre/files/prce/8.39/pcre-8.39.tar.bz2 - will attempt other sources if available
WARNING: byacc-native-20160606-r0 do_fetch: Failed to fetch URL ftp://invisible-island.net/byacc/byacc-20160606.tgz, attempting MIRRORS if available
WARNING: libgles-vuuno4kse-16.1-20171222.r0 do_fetch: Checksum mismatch for local file /home/openpli/openpli-oe-core/sources/libgles-vuuno4kse-16.1-20171222.r0.tar.gz
Cleaning and trying again.
WARNING: libgles-vuuno4kse-16.1-20171222.r0 do_fetch: Renaming /home/openpli/openpli-oe-core/sources/libgles-vuuno4kse-16.1-20171222.r0.tar.gz to /home/openpli/openpli-oe-core/sources/libgles-vuuno4kse-16.1-20171222.r0.tar.gz_bad-checksum_a67d4ffac7cc7fcab2925d5562943056
WARNING: libgles-vuuno4kse-16.1-20171222.r0 do_fetch: Checksum failure encountered with download of http://archive.vuplus.com/download/build_support/vuplus/libgles-vuuno4kse-16.1-20171222.r0.tar.gz - will attempt other sources if available
ERROR: libgles-vuuno4kse-16.1-20171222.r0 do_fetch: Fetcher failure for URL: 'http://archive.vuplus.com/download/build_support/vuplus/libgles-vuuno4kse-16.1-20171222.r0.tar.gz'. Checksum mismatch!
File: '/home/openpli/openpli-oe-core/sources/libgles-vuuno4kse-16.1-20171222.r0.tar.gz' has md5 checksum a67d4ffac7cc7fcab2925d5562943056 when db1af1f03f4cc493b2f7e77ea361d72b was expected
File: '/home/openpli/openpli-oe-core/sources/libgles-vuuno4kse-16.1-20171222.r0.tar.gz' has sha256 checksum 2e064cb687ce1c38d16d98e721151006ba1bf57ac056a4ff32c0a6c4e5dc4aa1 when d40d3efec60285f9e5751c48b6e66bea6f1e090818f305fa2c1d314edb762143 was expected
If this change is expected (e.g. you have upgraded to a new version without updating the checksums) then you can use these lines within the recipe:
SRC_URI[md5sum] = "a67d4ffac7cc7fcab2925d5562943056"
SRC_URI[sha256sum] = "2e064cb687ce1c38d16d98e721151006ba1bf57ac056a4ff32c0a6c4e5dc4aa1"
Otherwise you should retry the download and/or check with upstream to determine if the file has become corrupted or otherwise unexpectedly modified.

ERROR: libgles-vuuno4kse-16.1-20171222.r0 do_fetch: Fetcher failure for URL: 'http://archive.vuplus.com/download/build_support/vuplus/libgles-vuuno4kse-16.1-20171222.r0.tar.gz'. Unable to fetch URL from any source.
ERROR: libgles-vuuno4kse-16.1-20171222.r0 do_fetch: Function failed: base_do_fetch
ERROR: Logfile of failure stored in: /home/openpli/openpli-oe-core/build/tmp/work/vuuno4kse-oe-linux-gnueabi/libgles-vuuno4kse/16.1-20171222.r0/temp/log.do_fetch.485
ERROR: Task (/home/openpli/openpli-oe-core/meta-vuplus/recipes-bsp/drivers/libgles-vuuno4kse.bb:do_fetch) failed with exit code '1'

Ik zit op origin/release-6.1 maar op develop had ik dit ook.
Als ik handmatig de bestand ophaal en de hash bereken klopt alles wel. Hebben jullie enig idee wat dit kan zijn?
Ik debug nog wel verder maar wou het even delen.



Re: Checksum errors bouwen openpli #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,469 posts

+824
Excellent

Posted 6 January 2018 - 11:37

Ik heb geen idee. Ik heb het zelf niet, en onze buildservers ook niet.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Checksum errors bouwen openpli #3 Erik Slagter

  • PLi® Core member
  • 45,353 posts

+498
Excellent

Posted 6 January 2018 - 11:37

Dit komt me bekend voor. Eens even nadenken. Heb je wel een git submodule update gedaan? Is die ook gelukt (i.e. heb je in git submodule geen plusjes meer staan)?

 

Ergens halverwege een cache/proxy die verkeerde versies ophaalt of de files die opgehaald worden zijn in feite foutmeldingen van iets?


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Checksum errors bouwen openpli #4 r00tc0d3

  • Senior Member
  • 31 posts

0
Neutral

Posted 6 January 2018 - 11:45

On branch 6.1
Your branch is up to date with 'origin/release-6.1'.

nothing to commit, working tree clean


Re: Checksum errors bouwen openpli #5 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,469 posts

+824
Excellent

Posted 6 January 2018 - 11:46

git submodule sync && git submodule update

?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Checksum errors bouwen openpli #6 r00tc0d3

  • Senior Member
  • 31 posts

0
Neutral

Posted 6 January 2018 - 11:49

De submodules zijn goed. Ik heb het ook met git --recursive gecloned. Maak allemaal niets uit.



Re: Checksum errors bouwen openpli #7 r00tc0d3

  • Senior Member
  • 31 posts

0
Neutral

Posted 6 January 2018 - 12:10

Lijkt toch iets lokaals te zijn. Ik bouw in een docker container and de checksum binnen en buiten de container zijn verschillend. Maf. Ik zoek het verder wel uit waardoor dit kan kommen.
Bedankt voor het meedenken!



Re: Checksum errors bouwen openpli #8 r00tc0d3

  • Senior Member
  • 31 posts

0
Neutral

Posted 6 January 2018 - 13:38

Kleine update. Met wget gaat het fout met curl gaat het goed. The bug zit hem dus in wget. Ik ben een andere versie distro gaan gebruiken. Handmatig gaat dit nu goed. Nu kijken of pli bouwen goed gaat.



Re: Checksum errors bouwen openpli #9 Erik Slagter

  • PLi® Core member
  • 45,353 posts

+498
Excellent

Posted 6 January 2018 - 19:47

Goed dat je wget noemt. Ik weet nu weer wat het probleem is. Het is inderdaad een probleem (maar niet per se een bug) in wget. In sommige distributies (in ieder geval Fedora) wordt in wget de config optie standaard aangezet dat alles wat als gzip compressed binnenkomt automatisch gunzipped wordt. Dat is prima als het gzippen transparant door de web server gebeurt, dat is wat je wilt. Maar het probleem is dat wget het ook doet als je een .gz file download. Wat je dan krijgt is een file die endigt op .gz maar niet meer gzipped is. Probeer het maar, bij de VU+ downloads krijg je files die je direct met tar kunt uitpakken. De checksum klopt dan uiteraard ook niet meer.

 

Workaround is om je in home directory de file .wgetrc aan te maken en daarin op te nemen:

compression=none

* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Checksum errors bouwen openpli #10 r00tc0d3

  • Senior Member
  • 31 posts

0
Neutral

Posted 7 January 2018 - 17:49

Heb het getest en klopt als een bus.

Bedankt voor de info. Weer wat wijzer.







Also tagged with one or more of these keywords: openpli

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users