Jump to content


Photo

OpenVPN error


  • Please log in to reply
57 replies to this topic

Re: OpenVPN error #41 successo4

  • Member
  • 9 posts

0
Neutral

Posted 6 September 2018 - 16:54

Zgemma H2 Start

 

openvpn does not work on openpli 6.2 zgemma start h2 start.
Although the installation works regularly when I start the vpn the network card does not acquire the ip of the vpn.
On other decoders like zgemma h2h and h5 ect it works regularly.
I did all the tests but nothing.
The thing I noticed is that in the / dev / net directory the tun file has a size of 0 kb while in the working h2h firmware it has a size of 1 kb.
Please someone knows how to solve thanks.
I remember having had problems with the previous software and then with 6.1 it was solved.
Thank you


Re: OpenVPN error #42 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,437 posts

+823
Excellent

Posted 6 September 2018 - 17:20

What is a H2 start? I know a H2.H and a H2.S.

 

Can you telnet into the box, and check the output of "lsmod". Is the "tun" module present?

If not, can you check if it is installed with "opkg install kernel-module-tun"?

Can you do "modprobe tun" and then check the "lsmod" output again?

 

Loading the tun module should create the tun device node. The size is not relevant, it is not a file.

 

If your openvpn connection isn't activated, add debugging to your config, and check the log in /var/log for the reason why.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: OpenVPN error #43 successo4

  • Member
  • 9 posts

0
Neutral

Posted 6 September 2018 - 17:30

decoder Zgemma Star H2

---------------------------------------------------------------

root@sh1:~# opkg install kernel-module-tun
Package kernel-module-tun (4.10.12-.1.1) installed in root is up to date.
root@sh1:~# lsmod
Module                  Size  Used by
tun                    21918  0
ipv6                  395672  36
sh1                  7662574  0
sh1_3                  33137  1 sh1
sh1_2                  22335  0
sh1_1                   6439  3 sh1_3,sh1,sh1_2
----------------------------
The vpn server is working because all the other decoders work.
On this decoder when I start the vpn it does not take the tun and therefore it does not see the vpn.
----------------------------------------------------
root@sh1:~# /etc/init.d/openvpn restart
Stopping openvpn: 25.
Starting openvpn: 25.
root@sh1:~# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:15:C0:3A:5D:F1
          inet addr:192.168.1.107  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::215:c0ff:fe3a:5df1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:118574 errors:0 dropped:19 overruns:0 frame:0
          TX packets:105007 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:33317681 (31.7 MiB)  TX bytes:11191079 (10.6 MiB)
 
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:140 (140.0 B)  TX bytes:140 (140.0 B)
-----------------------------------------------------------------------------------------------------
Tancks


Re: OpenVPN error #44 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,437 posts

+823
Excellent

Posted 6 September 2018 - 17:40

Have you enabled debugging in your config? Wat does the log file in /var/log say? And the log file on your server?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: OpenVPN error #45 successo4

  • Member
  • 9 posts

0
Neutral

Posted 6 September 2018 - 17:51

My server works let's loose because the other decoders all work regularly,
The zgemma start h2 decoder has had this problem for some time, which was then fixed with 6.1.
I assume it's a firmware problem because the other decoders work.
Do you have this decoder?
The strange thing that the tun file in the / dev / net / tun directory has 0 kb is therefore empty while the other decoders have the file but it is not empty.
 
log active
log /etc/openvpn/log.txt
0 kb


Re: OpenVPN error #46 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,437 posts

+823
Excellent

Posted 6 September 2018 - 17:55

See my previous post(s). And try reading them now.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: OpenVPN error #47 successo4

  • Member
  • 9 posts

0
Neutral

Posted 6 September 2018 - 18:07

Thu Jan  1 10:37:57 1970 us=716885 Current Parameter Settings:
Thu Jan  1 10:37:57 1970 us=718778   config = '/etc/openvpn/25.conf'
Thu Jan  1 10:37:57 1970 us=719128   mode = 0
Thu Jan  1 10:37:57 1970 us=719407   persist_config = DISABLED
Thu Jan  1 10:37:57 1970 us=719899   persist_mode = 1
Thu Jan  1 10:37:57 1970 us=720214   show_ciphers = DISABLED
Thu Jan  1 10:37:57 1970 us=720484   show_digests = DISABLED
Thu Jan  1 10:37:57 1970 us=720964   show_engines = DISABLED
Thu Jan  1 10:37:57 1970 us=721246   genkey = DISABLED
Thu Jan  1 10:37:57 1970 us=721510   key_pass_file = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=721926   show_tls_ciphers = DISABLED
Thu Jan  1 10:37:57 1970 us=722205 Connection profiles [default]:
Thu Jan  1 10:37:57 1970 us=722474   proto = tcp-client
Thu Jan  1 10:37:57 1970 us=724050   local = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=724825   local_port = 0
Thu Jan  1 10:37:57 1970 us=725234   remote = 'openvpn-server.ovh'
Thu Jan  1 10:37:57 1970 us=725552   remote_port = 33100
Thu Jan  1 10:37:57 1970 us=726171   remote_float = DISABLED
Thu Jan  1 10:37:57 1970 us=726493   bind_defined = DISABLED
Thu Jan  1 10:37:57 1970 us=726983   bind_local = DISABLED
Thu Jan  1 10:37:57 1970 us=727318   connect_retry_seconds = 5
Thu Jan  1 10:37:57 1970 us=727775   connect_timeout = 10
Thu Jan  1 10:37:57 1970 us=728142   connect_retry_max = 0
Thu Jan  1 10:37:57 1970 us=728449   socks_proxy_server = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=729030   socks_proxy_port = 0
Thu Jan  1 10:37:57 1970 us=729378   socks_proxy_retry = DISABLED
Thu Jan  1 10:37:57 1970 us=729853   tun_mtu = 1500
Thu Jan  1 10:37:57 1970 us=730203   tun_mtu_defined = ENABLED
Thu Jan  1 10:37:57 1970 us=730518   link_mtu = 1500
Thu Jan  1 10:37:57 1970 us=731023   link_mtu_defined = DISABLED
Thu Jan  1 10:37:57 1970 us=731344   tun_mtu_extra = 0
Thu Jan  1 10:37:57 1970 us=731882   tun_mtu_extra_defined = DISABLED
Thu Jan  1 10:37:57 1970 us=732262   mtu_discover_type = -1
Thu Jan  1 10:37:57 1970 us=732711   fragment = 0
Thu Jan  1 10:37:57 1970 us=733084   mssfix = 1450
Thu Jan  1 10:37:57 1970 us=733402   explicit_exit_notification = 0
Thu Jan  1 10:37:57 1970 us=733864 Connection profiles END
Thu Jan  1 10:37:57 1970 us=734205   remote_random = DISABLED
Thu Jan  1 10:37:57 1970 us=734509   ipchange = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=735103   dev = 'tun25'
Thu Jan  1 10:37:57 1970 us=735426   dev_type = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=735902   dev_node = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=736242   lladdr = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=736556   topology = 1
Thu Jan  1 10:37:57 1970 us=737039   tun_ipv6 = DISABLED
Thu Jan  1 10:37:57 1970 us=737353   ifconfig_local = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=738180   ifconfig_remote_netmask = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=738569   ifconfig_noexec = DISABLED
Thu Jan  1 10:37:57 1970 us=739019   ifconfig_nowarn = DISABLED
Thu Jan  1 10:37:57 1970 us=739294   ifconfig_ipv6_local = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=739558   ifconfig_ipv6_netbits = 0
Thu Jan  1 10:37:57 1970 us=739984   ifconfig_ipv6_remote = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=740258   shaper = 0
Thu Jan  1 10:37:57 1970 us=740525   mtu_test = 0
Thu Jan  1 10:37:57 1970 us=742053   mlock = DISABLED
Thu Jan  1 10:37:57 1970 us=745020   keepalive_ping = 8
Thu Jan  1 10:37:57 1970 us=746130   keepalive_timeout = 40
Thu Jan  1 10:37:57 1970 us=746933   inactivity_timeout = 0
Thu Jan  1 10:37:57 1970 us=748115   ping_send_timeout = 8
Thu Jan  1 10:37:57 1970 us=749050   ping_rec_timeout = 40
Thu Jan  1 10:37:57 1970 us=749881   ping_rec_timeout_action = 2
Thu Jan  1 10:37:57 1970 us=750502   ping_timer_remote = DISABLED
Thu Jan  1 10:37:57 1970 us=751787   remap_sigusr1 = 0
Thu Jan  1 10:37:57 1970 us=752202   persist_tun = DISABLED
Thu Jan  1 10:37:57 1970 us=752521   persist_local_ip = DISABLED
Thu Jan  1 10:37:57 1970 us=753022   persist_remote_ip = DISABLED
Thu Jan  1 10:37:57 1970 us=753334   persist_key = ENABLED
Thu Jan  1 10:37:57 1970 us=753874   passtos = DISABLED
Thu Jan  1 10:37:57 1970 us=754254   resolve_retry_seconds = 1000000000
Thu Jan  1 10:37:57 1970 us=754872   username = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=755244   groupname = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=755557   chroot_dir = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=756061   cd_dir = '/etc/openvpn'
Thu Jan  1 10:37:57 1970 us=756381   writepid = '/var/run/openvpn.25.pid'
Thu Jan  1 10:37:57 1970 us=756947   up_script = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=757310   down_script = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=758038   down_pre = DISABLED
Thu Jan  1 10:37:57 1970 us=758439   up_restart = DISABLED
Thu Jan  1 10:37:57 1970 us=758894   up_delay = DISABLED
Thu Jan  1 10:37:57 1970 us=759184   daemon = ENABLED
Thu Jan  1 10:37:57 1970 us=759457   inetd = 0
Thu Jan  1 10:37:57 1970 us=759964   log = ENABLED
Thu Jan  1 10:37:57 1970 us=760268   suppress_timestamps = DISABLED
Thu Jan  1 10:37:57 1970 us=760546   nice = 0
Thu Jan  1 10:37:57 1970 us=761036   verbosity = 5
Thu Jan  1 10:37:57 1970 us=761316   mute = 0
Thu Jan  1 10:37:57 1970 us=761697   gremlin = 0
Thu Jan  1 10:37:57 1970 us=762016   status_file = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=762290   status_file_version = 1
Thu Jan  1 10:37:57 1970 us=762553   status_file_update_freq = 60
Thu Jan  1 10:37:57 1970 us=764139   occ = ENABLED
Thu Jan  1 10:37:57 1970 us=764492   rcvbuf = 0
Thu Jan  1 10:37:57 1970 us=765024   sndbuf = 0
Thu Jan  1 10:37:57 1970 us=765356   mark = 0
Thu Jan  1 10:37:57 1970 us=765920   sockflags = 0
Thu Jan  1 10:37:57 1970 us=766286   fast_io = DISABLED
Thu Jan  1 10:37:57 1970 us=766737   lzo = 0
Thu Jan  1 10:37:57 1970 us=767105   route_script = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=767422   route_default_gateway = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=767900   route_default_metric = 0
Thu Jan  1 10:37:57 1970 us=768243   route_noexec = DISABLED
Thu Jan  1 10:37:57 1970 us=768554   route_delay = 0
Thu Jan  1 10:37:57 1970 us=769155   route_delay_window = 30
Thu Jan  1 10:37:57 1970 us=769489   route_delay_defined = DISABLED
Thu Jan  1 10:37:57 1970 us=769988   route_nopull = DISABLED
Thu Jan  1 10:37:57 1970 us=770323   route_gateway_via_dhcp = DISABLED
Thu Jan  1 10:37:57 1970 us=770790   max_routes = 100
Thu Jan  1 10:37:57 1970 us=771157   allow_pull_fqdn = DISABLED
Thu Jan  1 10:37:57 1970 us=771482   management_addr = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=772079   management_port = 0
Thu Jan  1 10:37:57 1970 us=772426   management_user_pass = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=772918   management_log_history_cache = 250
Thu Jan  1 10:37:57 1970 us=773270   management_echo_buffer_size = 100
Thu Jan  1 10:37:57 1970 us=773733   management_write_peer_info_file = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=774108   management_client_user = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=774431   management_client_group = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=775018   management_flags = 0
Thu Jan  1 10:37:57 1970 us=775364   shared_secret_file = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=775841   key_direction = 0
Thu Jan  1 10:37:57 1970 us=776200   ciphername_defined = ENABLED
Thu Jan  1 10:37:57 1970 us=776525   ciphername = 'BF-CBC'
Thu Jan  1 10:37:57 1970 us=777025   authname_defined = ENABLED
Thu Jan  1 10:37:57 1970 us=777358   authname = 'SHA1'
Thu Jan  1 10:37:57 1970 us=778188   prng_hash = 'SHA1'
Thu Jan  1 10:37:57 1970 us=778712   prng_nonce_secret_len = 16
Thu Jan  1 10:37:57 1970 us=779040   keysize = 0
Thu Jan  1 10:37:57 1970 us=779317   engine = DISABLED
Thu Jan  1 10:37:57 1970 us=779703   replay = ENABLED
Thu Jan  1 10:37:57 1970 us=780033   mute_replay_warnings = DISABLED
Thu Jan  1 10:37:57 1970 us=780316   replay_window = 64
Thu Jan  1 10:37:57 1970 us=780846   replay_time = 15
Thu Jan  1 10:37:57 1970 us=781201   packet_id_file = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=781483   use_iv = ENABLED
Thu Jan  1 10:37:57 1970 us=781911   test_crypto = DISABLED
Thu Jan  1 10:37:57 1970 us=782210   tls_server = DISABLED
Thu Jan  1 10:37:57 1970 us=782485   tls_client = ENABLED
Thu Jan  1 10:37:57 1970 us=784009   key_method = 2
Thu Jan  1 10:37:57 1970 us=784410   ca_file = '/etc/openvpn/chiavib/ca.crt'
Thu Jan  1 10:37:57 1970 us=785012   ca_path = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=785382   dh_file = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=785866   cert_file = '/etc/openvpn/chiavib/client085.crt'
Thu Jan  1 10:37:57 1970 us=786218   extra_certs_file = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=786540   priv_key_file = '/etc/openvpn/chiavib/client085.key'
Thu Jan  1 10:37:57 1970 us=787156   pkcs12_file = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=787490   cipher_list = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=787987   tls_verify = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=788324   tls_export_cert = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=788790   verify_x509_type = 0
Thu Jan  1 10:37:57 1970 us=789154   verify_x509_name = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=789475   crl_file = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=790053   ns_cert_type = 1
Thu Jan  1 10:37:57 1970 us=790402   remote_cert_ku[i] = 0
Thu Jan  1 10:37:57 1970 us=790891   remote_cert_ku[i] = 0
Thu Jan  1 10:37:57 1970 us=791245   remote_cert_ku[i] = 0
Thu Jan  1 10:37:57 1970 us=791565   remote_cert_ku[i] = 0
Thu Jan  1 10:37:57 1970 us=792064   remote_cert_ku[i] = 0
Thu Jan  1 10:37:57 1970 us=792384   remote_cert_ku[i] = 0
Thu Jan  1 10:37:57 1970 us=792931   remote_cert_ku[i] = 0
Thu Jan  1 10:37:57 1970 us=793298   remote_cert_ku[i] = 0
Thu Jan  1 10:37:57 1970 us=793760   remote_cert_ku[i] = 0
Thu Jan  1 10:37:57 1970 us=794124   remote_cert_ku[i] = 0
Thu Jan  1 10:37:57 1970 us=794447   remote_cert_ku[i] = 0
Thu Jan  1 10:37:57 1970 us=794939   remote_cert_ku[i] = 0
Thu Jan  1 10:37:57 1970 us=795283   remote_cert_ku[i] = 0
Thu Jan  1 10:37:57 1970 us=795816   remote_cert_ku[i] = 0
Thu Jan  1 10:37:57 1970 us=796215   remote_cert_ku[i] = 0
Thu Jan  1 10:37:57 1970 us=796547   remote_cert_ku[i] = 0
Thu Jan  1 10:37:57 1970 us=797046   remote_cert_eku = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=797375   ssl_flags = 0
Thu Jan  1 10:37:57 1970 us=798126   tls_timeout = 2
Thu Jan  1 10:37:57 1970 us=798519   renegotiate_bytes = 0
Thu Jan  1 10:37:57 1970 us=799070   renegotiate_packets = 0
Thu Jan  1 10:37:57 1970 us=799367   renegotiate_seconds = 3600
Thu Jan  1 10:37:57 1970 us=799769   handshake_window = 60
Thu Jan  1 10:37:57 1970 us=800092   transition_window = 3600
Thu Jan  1 10:37:57 1970 us=800371   single_session = DISABLED
Thu Jan  1 10:37:57 1970 us=800806   push_peer_info = DISABLED
Thu Jan  1 10:37:57 1970 us=801124   tls_exit = DISABLED
Thu Jan  1 10:37:57 1970 us=801401   tls_auth_file = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=802058   server_network = 0.0.0.0
Thu Jan  1 10:37:57 1970 us=802414   server_netmask = 0.0.0.0
Thu Jan  1 10:37:57 1970 us=803989   server_network_ipv6 = ::
Thu Jan  1 10:37:57 1970 us=804419   server_netbits_ipv6 = 0
Thu Jan  1 10:37:57 1970 us=805055   server_bridge_ip = 0.0.0.0
Thu Jan  1 10:37:57 1970 us=805449   server_bridge_netmask = 0.0.0.0
Thu Jan  1 10:37:57 1970 us=805967   server_bridge_pool_start = 0.0.0.0
Thu Jan  1 10:37:57 1970 us=806335   server_bridge_pool_end = 0.0.0.0
Thu Jan  1 10:37:57 1970 us=806796   ifconfig_pool_defined = DISABLED
Thu Jan  1 10:37:57 1970 us=807191   ifconfig_pool_start = 0.0.0.0
Thu Jan  1 10:37:57 1970 us=807543   ifconfig_pool_end = 0.0.0.0
Thu Jan  1 10:37:57 1970 us=808171   ifconfig_pool_netmask = 0.0.0.0
Thu Jan  1 10:37:57 1970 us=808510   ifconfig_pool_persist_filename = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=809012   ifconfig_pool_persist_refresh_freq = 600
Thu Jan  1 10:37:57 1970 us=809348   ifconfig_ipv6_pool_defined = DISABLED
Thu Jan  1 10:37:57 1970 us=809848   ifconfig_ipv6_pool_base = ::
Thu Jan  1 10:37:57 1970 us=810211   ifconfig_ipv6_pool_netbits = 0
Thu Jan  1 10:37:57 1970 us=810530   n_bcast_buf = 256
Thu Jan  1 10:37:57 1970 us=811135   tcp_queue_limit = 64
Thu Jan  1 10:37:57 1970 us=811471   real_hash_size = 256
Thu Jan  1 10:37:57 1970 us=811971   virtual_hash_size = 256
Thu Jan  1 10:37:57 1970 us=812302   client_connect_script = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=812758   learn_address_script = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=813122   client_disconnect_script = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=813820   client_config_dir = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=814231   ccd_exclusive = DISABLED
Thu Jan  1 10:37:57 1970 us=814552   tmp_dir = '/tmp'
Thu Jan  1 10:37:57 1970 us=815063   push_ifconfig_defined = DISABLED
Thu Jan  1 10:37:57 1970 us=815415   push_ifconfig_local = 0.0.0.0
Thu Jan  1 10:37:57 1970 us=815916   push_ifconfig_remote_netmask = 0.0.0.0
Thu Jan  1 10:37:57 1970 us=816276   push_ifconfig_ipv6_defined = DISABLED
Thu Jan  1 10:37:57 1970 us=816960   push_ifconfig_ipv6_local = ::/0
Thu Jan  1 10:37:57 1970 us=817375   push_ifconfig_ipv6_remote = ::
Thu Jan  1 10:37:57 1970 us=818155   enable_c2c = DISABLED
Thu Jan  1 10:37:57 1970 us=818542   duplicate_cn = DISABLED
Thu Jan  1 10:37:57 1970 us=819004   cf_max = 0
Thu Jan  1 10:37:57 1970 us=819292   cf_per = 0
Thu Jan  1 10:37:57 1970 us=819565   max_clients = 1024
Thu Jan  1 10:37:57 1970 us=820097   max_routes_per_client = 256
Thu Jan  1 10:37:57 1970 us=820372   auth_user_pass_verify_script = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=820819   auth_user_pass_verify_script_via_file = DISABLED
Thu Jan  1 10:37:57 1970 us=821142   port_share_host = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=821424   port_share_port = 0
Thu Jan  1 10:37:57 1970 us=821827   client = ENABLED
Thu Jan  1 10:37:57 1970 us=822136   pull = ENABLED
Thu Jan  1 10:37:57 1970 us=822415   auth_user_pass_file = '[UNDEF]'
Thu Jan  1 10:37:57 1970 us=823915 OpenVPN 2.3.9 mipsel-oe-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [MH] [IPv6] built on May  9 2018
Thu Jan  1 10:37:57 1970 us=824534 library versions: OpenSSL 1.0.2j  26 Sep 2016, LZO 2.09
Thu Jan  1 10:37:57 1970 us=856097 Control Channel MTU parms [ L:1543 D:1210 EF:40 EB:0 ET:0 EL:3 ]
Thu Jan  1 10:37:57 1970 us=857376 Socket Buffers: R=[87380->87380] S=[16384->16384]
Thu Jan  1 10:37:57 1970 us=876010 Data Channel MTU parms [ L:1543 D:1450 EF:43 EB:12 ET:0 EL:3 ]
Thu Jan  1 10:37:57 1970 us=877034 Local Options String: 'V4,dev-type tun,link-mtu 1543,tun-mtu 1500,proto TCPv4_CLIENT,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-client'
Thu Jan  1 10:37:57 1970 us=877406 Expected Remote Options String: 'V4,dev-type tun,link-mtu 1543,tun-mtu 1500,proto TCPv4_SERVER,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-server'
Thu Jan  1 10:37:57 1970 us=879848 Local Options hash (VER=V4): 'db02a8f8'
Thu Jan  1 10:37:57 1970 us=880320 Expected Remote Options hash (VER=V4): '7e068940'
Thu Jan  1 10:37:57 1970 us=881144 Attempting to establish TCP connection with [AF_INET]X.X.X.X:12000 [nonblock]
Thu Jan  1 10:37:58 1970 us=882440 TCP connection established with [AF_INET]X.X.X.X:12000
Thu Jan  1 10:37:58 1970 us=885506 TCPv4_CLIENT link local: [undef]
Thu Jan  1 10:37:58 1970 us=886485 TCPv4_CLIENT link remote: [AF_INET]X.X.X.X:12000
WRThu Jan  1 10:37:58 1970 us=926503 TLS: Initial packet from [AF_INET]X.X.X.X:12000, sid=6ad5002b 02e32352
WWRWRThu Jan  1 10:37:59 1970 us=99156 VERIFY ERROR: depth=1, error=certificate is not yet valid: C=US, ST=CA, L=SanFrancisco, O=OpenVpn, CN=OpenVpn CA, emailAddress=me@mydomain
Thu Jan  1 10:37:59 1970 us=102377 TLS_ERROR: BIO read tls_read_plaintext error: error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed
Thu Jan  1 10:37:59 1970 us=104037 TLS Error: TLS object -> incoming plaintext read error
Thu Jan  1 10:37:59 1970 us=104434 TLS Error: TLS handshake failed
Thu Jan  1 10:37:59 1970 us=106315 Fatal TLS error (check_tls_errors_co), restarting
Thu Jan  1 10:37:59 1970 us=107416 TCP/UDP: Closing socket
Thu Jan  1 10:37:59 1970 us=108402 SIGUSR1[soft,tls-error] received, process restarting
Thu Jan  1 10:37:59 1970 us=109140 Restart pause, 5 second(s)
Thu Jan  1 10:38:04 1970 us=109826 Re-using SSL/TLS context
Thu Jan  1 10:38:04 1970 us=111847 Control Channel MTU parms [ L:1543 D:1210 EF:40 EB:0 ET:0 EL:3 ]
Thu Jan  1 10:38:04 1970 us=112757 Socket Buffers: R=[87380->87380] S=[16384->16384]
Thu Jan  1 10:38:04 1970 us=115866 Data Channel MTU parms [ L:1543 D:1450 EF:43 EB:12 ET:0 EL:3 ]
Thu Jan  1 10:38:04 1970 us=116710 Local Options String: 'V4,dev-type tun,link-mtu 1543,tun-mtu 1500,proto TCPv4_CLIENT,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-client'
Thu Jan  1 10:38:04 1970 us=117097 Expected Remote Options String: 'V4,dev-type tun,link-mtu 1543,tun-mtu 1500,proto TCPv4_SERVER,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-server'
Thu Jan  1 10:38:04 1970 us=117569 Local Options hash (VER=V4): 'db02a8f8'
Thu Jan  1 10:38:04 1970 us=118792 Expected Remote Options hash (VER=V4): '7e068940'
Thu Jan  1 10:38:04 1970 us=119195 Attempting to establish TCP connection with [AF_INET]X.X.X.X:12000 [nonblock]


Re: OpenVPN error #48 betacentauri

  • PLi® Core member
  • 5,403 posts

+247
Excellent

Posted 6 September 2018 - 18:58

Maybe you need to set a proper date.


Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: OpenVPN error #49 Pippin

  • Senior Member
  • 100 posts

+2
Neutral

Posted 6 September 2018 - 19:27

How does that box get it's time?

The log you show, is it after a restart of the box and you have OpenVPN autostart?

 

Problem then could be that OpenVPN starts before the proper time is set.

This was a issue a while back for me too, using OpenATV.


Wou een grap vertellen over UDP maar wist niet of die wel aan zou komen.
HD Quad+, 2x DVB-S2 + OpenATV 5.3 + oscam 1.2_11309 + 2x 1TB HDD + 4GB Stick-> swap, EPG, logs, timeshift + 13.0-19.2-23.5-28.2, 85 cm + Synology DS414, oscam 1.2_11309

Re: OpenVPN error #50 successo4

  • Member
  • 9 posts

0
Neutral

Posted 6 September 2018 - 19:40

The log was done by giving the command
/etc/init.d/ openvpn restart
The decoder has been on for some time and has a brand new firmware without a plugin and therefore without a channel list so the date is unpacked.
However even correcting the date the situation does not change.
If I restart the decoder, the situation does not change
I remind you that in an old image 4.0 I have the same problem current in 6.1.
If I install 6.1 the problem does not exist and it works regularly.
In my opinion the problem is being installed because when creating the tun file in the / dev / net folder in the old openpli 6.1 version it has a size of 1 kb, while in 6.2 it is 0, so empty.
Help 


Re: OpenVPN error #51 Pippin

  • Senior Member
  • 100 posts

+2
Neutral

Posted 6 September 2018 - 19:44

The log show a connection attempt, so tun device is present. Otherwise the log will state that there is no tun device. If you set your box to get NTP time instead of transponder, does it work. I can imagine having no channels and getting time from transponder doesn't work.
Wou een grap vertellen over UDP maar wist niet of die wel aan zou komen.
HD Quad+, 2x DVB-S2 + OpenATV 5.3 + oscam 1.2_11309 + 2x 1TB HDD + 4GB Stick-> swap, EPG, logs, timeshift + 13.0-19.2-23.5-28.2, 85 cm + Synology DS414, oscam 1.2_11309

Re: OpenVPN error #52 Pippin

  • Senior Member
  • 100 posts

+2
Neutral

Posted 6 September 2018 - 19:50

Cannot edit my post. I meant ".....does it work?"
Wou een grap vertellen over UDP maar wist niet of die wel aan zou komen.
HD Quad+, 2x DVB-S2 + OpenATV 5.3 + oscam 1.2_11309 + 2x 1TB HDD + 4GB Stick-> swap, EPG, logs, timeshift + 13.0-19.2-23.5-28.2, 85 cm + Synology DS414, oscam 1.2_11309

Re: OpenVPN error #53 Pippin

  • Senior Member
  • 100 posts

+2
Neutral

Posted 6 September 2018 - 19:55

Looking at my logs, my above post regarding tun is present is not correct. tun device is opened after initial handshake, I should have known that... Anyway, if time is not correct enough, OpenVPN will fail.
Wou een grap vertellen over UDP maar wist niet of die wel aan zou komen.
HD Quad+, 2x DVB-S2 + OpenATV 5.3 + oscam 1.2_11309 + 2x 1TB HDD + 4GB Stick-> swap, EPG, logs, timeshift + 13.0-19.2-23.5-28.2, 85 cm + Synology DS414, oscam 1.2_11309

Re: OpenVPN error #54 successo4

  • Member
  • 9 posts

0
Neutral

Posted 6 September 2018 - 20:15

/usr/bin/ntpdate ntp1.inrim.it

 

I've used this command and it's got there so I think it's a date problem.
Tonight I did the procedure by installing a new firmware with the correct parameters and the date server.
Then I write the results.
Comunuque thank you for the help and for supporting me in making me understand the thing. Thanks friends from Naples.


Re: OpenVPN error #55 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,437 posts

+823
Excellent

Posted 6 September 2018 - 22:35

It is, certificates don't work without the proper time. Install the systemtime plugin, it can run ntpdate when the box boots, avoiding this problem.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: OpenVPN error #56 littlesat

  • PLi® Core member
  • 49,205 posts

+527
Excellent

Posted 6 September 2018 - 22:36

+1

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: OpenVPN error #57 successo4

  • Member
  • 9 posts

0
Neutral

Posted 6 September 2018 - 23:52

I solved by copying the ntpdate file to / usr / bin /.
Then in a scripture created for other things I copied the command
/ usr / bin / ntpdate ntp1.inrim.it
This causes the date to be correct when restarted and then I see the ip of the vpn server.
I want to thank you because with your help I understood why it did not work.
Thanks again from Naples.


Re: OpenVPN error #58 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,437 posts

+823
Excellent

Posted 7 September 2018 - 00:42

Why do you ask for help here if you ignore all questions asked and advice given?

 

You don't need to install stuff manually, and you don't need to make scripts.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users