Jump to content


Photo

Vu+ Uno 4k SE streaming(transcoding) problem

streaming transcoding

  • Please log in to reply
38 replies to this topic

Re: Vu+ Uno 4k SE streaming(transcoding) problem #21 Zolyma

  • Senior Member
  • 92 posts

0
Neutral

Posted 4 February 2020 - 04:17

Thanks for god! That's the reason why it works well!

Re: Vu+ Uno 4k SE streaming(transcoding) problem #22 Zolyma

  • Senior Member
  • 92 posts

0
Neutral

Posted 4 February 2020 - 04:20

I talk about uno4 se transcodig for a long time...
The dm800 just a methapore that not my tv the wrong.

Re: Vu+ Uno 4k SE streaming(transcoding) problem #23 WanWizard

  • Forum Moderator
    PLi® Core member
  • 51,498 posts

+954
Excellent

Posted 4 February 2020 - 09:25

I don't have an Uno 4K SE, only a Duo 4K and Solo 4K.

 

All VU+ 4K boxes however have the same transcoder and streamproxy, so it is unlikely that something that works on one doesn't work on the other.

 

I have a VU+ Zero box in my suitcase for when I travel, that connects to home via OpenVPN, so I can watch remotely, and that uses a transcoded stream (from my Duo 4K) as well. And that works fine.

 

Having said that, the details you have been posting mention port 8001, which is the streaming port, not the transcoding port. And you've been told that authentication with the sid- user doesn't work with the transcoder streamproxy.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (C), Zgemma H6(fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Vu+ Uno 4k SE streaming(transcoding) problem #24 Zolyma

  • Senior Member
  • 92 posts

0
Neutral

Posted 4 February 2020 - 12:51

I tryed the default 8001 it works with pc vlc.
The transcodig not with anything.
1.5MB, 576 size.
Where is the transcoder file?
And on the default 8001 port how stream? Thru a file? Somehow just work, but how? Gstream or what?

Re: Vu+ Uno 4k SE streaming(transcoding) problem #25 WanWizard

  • Forum Moderator
    PLi® Core member
  • 51,498 posts

+954
Excellent

Posted 4 February 2020 - 13:08

8001 is processed by Enigma, it just copies the entire transport stream, as received, to HTTP (identical to the way a recording works). There is no intermediate file (which is why it is latency/jitter sensitive).

 

8002/8003 on a VU+ is processed by the streamproxy process, which is configured through the transcoding plugin. The stream proxy gets the full transportstream from Enigma, routes it through the hardware transcoder, and sends it out over http in H.264/AAC format.

 

You can kill the streamproxy from the commandline, and then run it is the foreground (there is a commandline switch for that) so you can see what it is doing, it will log to the console.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (C), Zgemma H6(fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Vu+ Uno 4k SE streaming(transcoding) problem #26 cekal99

  • New Member
  • 4 posts

0
Neutral

Posted 7 February 2020 - 03:55

Hi again.

 

Could you please help me with trancodning on vu+ uno 4k se. Now I.m on the openpli 6.2 but i tried flash with new 7.2, setup new router and many more. Streaming working local (VLC) and outside network through port 8001. But I cant start transcoding through port 8002 (local and external). Looks like it's closed all the time or somethin wrong with the plugin?

 

streamproxy conf

listen = 8002:transcode
listen = 8003:transcode
size = 480p
bitrate = 2000
profile = baseline
level = 3.1
bframes = 0

 

 

passwd

root:x:0:0:root:/home/root:/bin/sh
daemon:x:1:1:daemon:/usr/sbin:/bin/sh
bin:x:2:2:bin:/bin:/bin/sh
sys:x:3:3:sys:/dev:/bin/sh
sync:x:4:65534:sync:/bin:/bin/sync
games:x:5:60:games:/usr/games:/bin/sh
man:x:6:12:man:/var/cache/man:/bin/sh
lp:x:7:7:lp:/var/spool/lpd:/bin/sh
mail:x:8:8:mail:/var/mail:/bin/sh
news:x:9:9:news:/var/spool/news:/bin/sh
uucp:x:10:10:uucp:/var/spool/uucp:/bin/sh
proxy:x:13:13:proxy:/bin:/bin/sh
www-data:x:33:33:www-data:/var/www:/bin/sh
backup:x:34:34:backup:/var/backups:/bin/sh
list:x:38:38:Mailing List Manager:/var/list:/bin/sh
irc:x:39:39:ircd:/var/run/ircd:/bin/sh
gnats:x:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/bin/sh
nobody:x:65534:65534:nobody:/nonexistent:/bin/sh
messagebus:x:999:998::/var/lib/dbus:/bin/false
rpc:x:998:997::/:/bin/false
rpcuser:x:997:996::/var/lib/nfs:/bin/false
avahi:x:996:995::/var/run/avahi-daemon:/bin/false

 

Openwebif is giving the same file m3u (8001) doesn't matter where Im clickin (streaming or transcding)

#EXTM3U
#EXTVLCOPT--http-reconnect=true
#EXTINF:-1,TVN HD
http://192.168.1.3:8...=2?interlaced=0

 

Is transcoding swich ON all the time in the openpli image?

I was traying also to edit extensions web.py and plugin.py (and then delete *.pyo). 

Port 8002 is opened in the same way like 8001 in firewall, router.

I was trying also  with and without  authorisation in openwebif. (Transcodin setup in Openwebif on PC set to 8002)

 

Do not know where I made a fail..



Re: Vu+ Uno 4k SE streaming(transcoding) problem #27 WanWizard

  • Forum Moderator
    PLi® Core member
  • 51,498 posts

+954
Excellent

Posted 7 February 2020 - 10:36

When I select a transcoding stream (by clicking on the phone icon), I get an m3u with port 8002:

http://172.16.1.56:8002/1:0:19:5225:C99:3:EB0000:0:0:0:?bitrate=500000&width=720&height=576&aspectratio=2&interlaced=0

if you don't, it's a web interface problem. But remember that 6.2-release is old, so that could have issues. I'm pretty sure 7.2-release generates the correct URL.

 

I doubt that in both cases router port forwarding will work, as the URL contains your internal IP, not your public IP (assuming your router does NAT).

Which is a good idea, forwarding your stream ports to the internet is a very bad idea, your box will be part of an illegal IPTV streaming network in no time...

 

Instead, use a VPN to connect to your router.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (C), Zgemma H6(fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Vu+ Uno 4k SE streaming(transcoding) problem #28 Zolyma

  • Senior Member
  • 92 posts

0
Neutral

Posted 7 February 2020 - 11:28

How do we use vpn?
Configuration?

Re: Vu+ Uno 4k SE streaming(transcoding) problem #29 WanWizard

  • Forum Moderator
    PLi® Core member
  • 51,498 posts

+954
Excellent

Posted 7 February 2020 - 11:33

Depends on the capabilities of your router.

 

You could if really needed install OpenVPN on your box (and forward port 1194 on your router to it), but we advice against that if you have other options (most NAS devices also support VPNs) as the box is not a security device, and configuring it requires commandline knowledge.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (C), Zgemma H6(fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Vu+ Uno 4k SE streaming(transcoding) problem #30 cekal99

  • New Member
  • 4 posts

0
Neutral

Posted 7 February 2020 - 11:38

Thanks for your reply.

 

It was the same on new 7.2 -release. That's why I changed to 6.2.

 
On android device with app dreamPlayer the same thing happend. Streaming on 8001 (from outside local network) - impossible to transcode streaming on 8002.
Is there a transcoding plugin in openpli where I can change streaming port? - I found only Transcoding setup (nothing with port changing there). 

 

I wonder if I have a problem with the streamproxy. Maybe it's not running. I will try with this command (on putty?). I'm not expert in this matter. I got only filezilla og win10 (no linux). But maybe I can somehow start this command: 

/etc/init.d/streamproxy.sh start



Re: Vu+ Uno 4k SE streaming(transcoding) problem #31 WanWizard

  • Forum Moderator
    PLi® Core member
  • 51,498 posts

+954
Excellent

Posted 7 February 2020 - 11:45

Streamproxy should start automatically.

 

If you can connect to your box with putty, you can check with:

netstat -tlnp

it should list:

tcp        0      0 :::8002                 :::*                    LISTEN      1779/streamproxy
tcp        0      0 :::8003                 :::*                    LISTEN      1779/streamproxy

To test you can restart streamproxy in foreground mode:

/etc/init.d/streamproxy.sh stop
streamproxy -f

this will start a non-daemon session, with log to the console.

 

It will show you if your box is correctly detected, and when a stream connection happens, it will show you the debugging output.

 

You can stop it again with Ctrl-C, and restart it normally again with

/etc/init.d/streamproxy.sh start

Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (C), Zgemma H6(fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Vu+ Uno 4k SE streaming(transcoding) problem #32 cekal99

  • New Member
  • 4 posts

0
Neutral

Posted 8 February 2020 - 00:21

root@vuuno4kse:~# netstat -tlnp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State                                                                                                  PID/Program name
tcp        0      0 0.0.0.0:139             0.0.0.0:*               LISTEN                                                                                                                   1610/smbd
tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN                                                                                                                   1582/rpcbind
tcp        0      0 0.0.0.0:21              0.0.0.0:*               LISTEN                                                                                                                   1601/inetd
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN                                                                                                                   1578/dropbear
tcp        0      0 0.0.0.0:23              0.0.0.0:*               LISTEN                                                                                                                   1601/inetd
tcp        0      0 0.0.0.0:445             0.0.0.0:*               LISTEN                                                                                                                   1610/smbd
tcp        0      0 0.0.0.0:47903           0.0.0.0:*               LISTEN                                                                                                                   1587/rpc.statd
tcp        0      0 :::8001                 :::*                    LISTEN                                                                                                                   5372/enigma2
tcp        0      0 :::56072                :::*                    LISTEN                                                                                                                   1587/rpc.statd
tcp        0      0 :::139                  :::*                    LISTEN                                                                                                                   1610/smbd
tcp        0      0 :::111                  :::*                    LISTEN                                                                                                                   1582/rpcbind
tcp        0      0 :::80                   :::*                    LISTEN                                                                                                                   5372/enigma2
tcp        0      0 :::22                   :::*                    LISTEN                                                                                                                   1578/dropbear
tcp        0      0 :::443                  :::*                    LISTEN                                                                                                                   5372/enigma2
tcp        0      0 :::445                  :::*                    LISTEN                                                                                                                   1610/smbd
root@vuuno4kse:~# /etc/init.d/streamproxy.sh stop
Stopping Streamproxy: no /usr/bin/streamproxy found; none killed
streamproxy.
root@vuuno4kse:~# streamproxy -f
Checking manufacturer/model: VU+/SoloSE
Checking id: /proc/stb/info/model = dm8000
Checking id: /proc/stb/info/vumodel = solose
Checking manufacturer/model: VU+/Solo2
Checking id: /proc/stb/info/model = dm8000
Checking id: /proc/stb/info/vumodel = solo2
Checking manufacturer/model: VU+/Duo2
Checking id: /proc/stb/info/model = dm8000
Checking id: /proc/stb/info/vumodel = duo2
Checking manufacturer/model: VU+/Solo4k
Checking id: /proc/stb/info/chipset = 7376
Checking manufacturer/model: VU+/Uno4k
Checking id: /proc/stb/info/chipset = 7252s
Checking id: /proc/stb/info/vumodel = uno4k
Checking manufacturer/model: VU+/Uno4kSE
Checking id: /proc/stb/info/chipset = 7252s
Checking id: /proc/stb/info/vumodel = uno4kse
model identified as: VU+ Uno4kSE (bcm7252S)
streamproxy: config_map: auth = true/1
streamproxy: config_map: bframes = 0/0
streamproxy: config_map: bitrate = 2000/2000
streamproxy: config_map: foreground = true/1
streamproxy: config_map: group = /0
streamproxy: config_map: level = 3.1/3
streamproxy: config_map: listen:8002 = 1/1
streamproxy: config_map: listen:8003 = 1/1
streamproxy: config_map: profile = baseline/0
streamproxy: config_map: size = 480p/480
streamproxy: config_map: webifport = 80/80
^C
root@vuuno4kse:~# /etc/init.d/streamproxy.sh start
Starting Streamproxy: streamproxy.
root@vuuno4kse:~# netstat -tlnp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:139             0.0.0.0:*               LISTEN      1610/smbd
tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN      1582/rpcbind
tcp        0      0 0.0.0.0:21              0.0.0.0:*               LISTEN      1601/inetd
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      1578/dropbear
tcp        0      0 0.0.0.0:23              0.0.0.0:*               LISTEN      1601/inetd
tcp        0      0 0.0.0.0:445             0.0.0.0:*               LISTEN      1610/smbd
tcp        0      0 0.0.0.0:47903           0.0.0.0:*               LISTEN      1587/rpc.statd
tcp        0      0 :::8001                 :::*                    LISTEN      5372/enigma2
tcp        0      0 :::8002                 :::*                    LISTEN      6246/streamproxy
tcp        0      0 :::8003                 :::*                    LISTEN      6246/streamproxy
tcp        0      0 :::56072                :::*                    LISTEN      1587/rpc.statd
tcp        0      0 :::139                  :::*                    LISTEN      1610/smbd
tcp        0      0 :::111                  :::*                    LISTEN      1582/rpcbind
tcp        0      0 :::80                   :::*                    LISTEN      5372/enigma2
tcp        0      0 :::22                   :::*                    LISTEN      1578/dropbear
tcp        0      0 :::443                  :::*                    LISTEN      5372/enigma2
tcp        0      0 :::445                  :::*                    LISTEN      1610/smbd
root@vuuno4kse:~#

Looks like problems with streamproxy start. Now its possible to transcode stream outside local network on android device on port 8002. openwebif (both streaming and transcoding buttons giving 8001) is working after manual changing to 8002.

 

more info

root@vuuno4kse:~# opkg list-installed enigma2-plugin-systemplugins-transcodingsetup
enigma2-plugin-systemplugins-transcodingsetup - y-git4734+46dc2c7-r0.0
root@vuuno4kse:~# opkg info enigma2-plugin-systemplugins-transcodingsetup
Package: enigma2-plugin-systemplugins-transcodingsetup
Version: y-git4734+46dc2c7-r0.0
Depends: enigma2-plugins
Status: install user installed
Section: base
Architecture: armv7ahf-neon
Maintainer: OpenPLi team <info@openpli.org>
MD5Sum: 128f3d46cb7332114e975fe2942ef7ad
Size: 17370
Filename: enigma2-plugin-systemplugins-transcodingsetup_y-git4734+46dc2c7-r0.0_armv7ahf-neon.ipk
Source: enigma2-plugins.bb
Description: systemplugins-transcodingsetup  systemplugins-transcodingsetup
Installed-Time: 1580771104


 


Edited by cekal99, 8 February 2020 - 00:22.


Re: Vu+ Uno 4k SE streaming(transcoding) problem #33 littlesat

  • PLi® Core member
  • 50,816 posts

+564
Excellent

Posted 8 February 2020 - 07:47

It seems indeed after a fresh flash the streamproxy is not initially started.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Vu+ Uno 4k SE streaming(transcoding) problem #34 WanWizard

  • Forum Moderator
    PLi® Core member
  • 51,498 posts

+954
Excellent

Posted 8 February 2020 - 10:12

What do you mean "after a fresh flash"? And what is changed so that it does start?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (C), Zgemma H6(fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Vu+ Uno 4k SE streaming(transcoding) problem #35 DinDin

  • Senior Member
  • 29 posts

0
Neutral

Posted 12 February 2020 - 10:37

For streaming outside of the local LAN, Zerotier is also a very interesting thing to try. When i go somewhere i just take my Firestick with Zeroter and dreamPlayer on it and connect with Zerotier directly to device. Work's like a charm.



Re: Vu+ Uno 4k SE streaming(transcoding) problem #36 steef84

  • Member
  • 7 posts

0
Neutral

Posted 16 February 2020 - 16:32

Nice can you point me how to connect firestick to zerotier. Already connected to zerotier network on enigma2 uno4k. Is the an app for firestick? Already own Dreamplayer for FireTV

Re: Vu+ Uno 4k SE streaming(transcoding) problem #37 DinDin

  • Senior Member
  • 29 posts

0
Neutral

Posted 17 February 2020 - 21:43

There is nothing special, read a bit about how to sideload an app on firestick using Downloader app https://www.lifewire...fire-tv-4582671

Then just download ZeroTier one from ApkPure https://apkpure.com/...om.zerotier.one

Connect and create another profile in DreamPlayer.

 

This should be all. Please report.



Re: Vu+ Uno 4k SE streaming(transcoding) problem #38 steef84

  • Member
  • 7 posts

0
Neutral

Posted 19 February 2020 - 19:55

Ahhh that wasn’t too hard to figure out. Thanks. Seems to work properly on firestick 4k and external profile transcoding on dreamplayer. Also for my portable IOS devices. Zerotier is the solution for me for connecting to my local receiver while having my network behind a vpn service! Thanks for pointing this Zerotier out!

Re: Vu+ Uno 4k SE streaming(transcoding) problem #39 DinDin

  • Senior Member
  • 29 posts

0
Neutral

Posted 19 February 2020 - 21:31

I was also suprised when someone told me to use Zerotier for direct connection without opening ports on router.  It really is a great thing.







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users