Jump to content


Photo

transcoding op de xsarius revo4k

xsarius revo4k transcoding

  • Please log in to reply
12 replies to this topic

#1 mk2k

  • Member
  • 14 posts

0
Neutral

Posted 4 June 2020 - 16:28

Hoi,

 

Ik heb zojuist mijn box geflashed met de  openpli-7.2-release-revo4k-20200601_usb.zip

Vervolgens bij de expert instellingen de transcoder settings ingevuld. 

in de openwebif als ik op het telefoon icoon druk krijg ik een foutmelding in vlc. cannot open stream.

 

als ik de normale stream tv icoon gebruik werkt het wel.

 

moet ik een andere / oudere image flashen om te kunnen transcoden op de revo4k ?

 

ik hoor het graag.



Re: transcoding op de xsarius revo4k #2 WanWizard

  • PLi® Core member
  • 60,482 posts

+1,376
Excellent

Posted 4 June 2020 - 16:33

Welke transcoder settings precies?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: transcoding op de xsarius revo4k #3 mk2k

  • Member
  • 14 posts

0
Neutral

Posted 5 June 2020 - 14:08

@wanwizard ik heb gewoon de default settings laten staan die er instaan na het flashen. heb de expert instellingen / transcoder instellingen geopend, vervolgens opgeslagen zonder de parameters aan te passen.

heb zojuist even openatv image geflashed. hier krijg ik wel beeld met de transcoder plugin via port 8002. maar helaas geen geluid. alle geluid opties (aac,mp3,mpg) geprobeerd.

 

dus ik ga even eerst een andere / oudere openpli versie flashen om te kijken of het dan wel lukt om überhaupt de transcoder functionaliteit werkend te krijgen. 



Re: transcoding op de xsarius revo4k #4 WanWizard

  • PLi® Core member
  • 60,482 posts

+1,376
Excellent

Posted 5 June 2020 - 14:15

Check of de streamproxy is geinstalleerd, en of deze draait. De foutmelding suggereert dat er niks luistert op 8002.

 

Ik heb zelf geen Revo, dus ik kan niet checken, ik heb de vraag even in het team gegooid.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: transcoding op de xsarius revo4k #5 mk2k

  • Member
  • 14 posts

0
Neutral

Posted 5 June 2020 - 14:24

heb nu 7.2 geflashed de versie mei 18 2020.

daar lijkt het wel op dat poort 8002 niet reageert.

maar streamproxy is wel gestart (pid 1229) :

streamproxy.jpg


Edited by mk2k, 5 June 2020 - 14:25.


Re: transcoding op de xsarius revo4k #6 WanWizard

  • PLi® Core member
  • 60,482 posts

+1,376
Excellent

Posted 5 June 2020 - 14:29

Wat zegt:

netstat -lnp | grep 8002

?
 

Ik neem aan dat beide tuners actief zijn (correct aangesloten en geconfigureerd), dan wel dat de box in standby staat als je dit test?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: transcoding op de xsarius revo4k #7 mk2k

  • Member
  • 14 posts

0
Neutral

Posted 5 June 2020 - 14:54

ik probeer vanaf de dvb-c tuner te streamen welke ook gewoon werkt (en streamen poort 8001 werkt ook ipv transcoden) en het is een dubbele tuner.

je kan ook pip gebruiken op de revo4k als de box aan staat.

 

dus transcoden werkt ook (iig met openatv) als de box gewoon aan staat en je ziet dan het rode lampje aangaan zodra je gaat transcoden.

 

hij luistert inderdaad niet 8002 (wel 8001) daarna 8002 geprobeerd als box in standby staat:

openpli 7.2-release revo4k
 
revo4k login: root
root@revo4k:~# netstat -lnp | grep 8002
root@revo4k:~# netstat -lnp | grep 8001
tcp        0      0 :::8001                 :::*                    LISTEN        1489/enigma2
root@revo4k:~# netstat -lnp | grep 8002
root@revo4k:~#
 

Edited by mk2k, 5 June 2020 - 14:56.


Re: transcoding op de xsarius revo4k #8 Tech

  • Forum Moderator
    PLi® Core member
  • 12,980 posts

+379
Excellent

Posted 5 June 2020 - 14:59

Er zou iets moeten komen als 

tcp        0      0 :::8002                 :::*                    LISTEN      1538/streamproxy

Het lijkt er dus op dat streamproxy niet draait.


Aan de rand van de afgrond is een stap voorwaarts niet altijd vooruitgang....

Re: transcoding op de xsarius revo4k #9 WanWizard

  • PLi® Core member
  • 60,482 posts

+1,376
Excellent

Posted 5 June 2020 - 15:01

Dan is er een streamproxy (configuratie) issue.

 

Wat is de output van:

killall streamproxy
streamproxy -f

Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: transcoding op de xsarius revo4k #10 mk2k

  • Member
  • 14 posts

0
Neutral

Posted 5 June 2020 - 15:01

klopt. nu de box gereboot en werkt het wel

root@revo4k:~# netstat -lnp | grep 8002
tcp        0      0 :::8002                 :::*                    LISTEN      1340/streamproxy

de output van de commando's\

root@revo4k:~# killall streamproxy
killall: streamproxy: no process killed
root@revo4k:~# streamproxy -f
Checking manufacturer/model: VU+/SoloSE
Checking id: /proc/stb/info/model = dm8000
Checking id: /proc/stb/info/vumodel = solose
Checking manufacturer/model: VU+/Solo2
Checking id: /proc/stb/info/model = dm8000
Checking id: /proc/stb/info/vumodel = solo2
Checking manufacturer/model: VU+/Duo2
Checking id: /proc/stb/info/model = dm8000
Checking id: /proc/stb/info/vumodel = duo2
Checking manufacturer/model: VU+/Solo4k
Checking id: /proc/stb/info/chipset = 7376
Checking manufacturer/model: VU+/Uno4k
Checking id: /proc/stb/info/chipset = 7252s
Checking manufacturer/model: VU+/Uno4kSE
Checking id: /proc/stb/info/chipset = 7252s
Checking manufacturer/model: VU+/Ultimo4k
Checking id: /proc/stb/info/chipset = 7444s
Checking manufacturer/model: VU+/Duo4k
Checking id: /proc/stb/info/chipset = 7278
Checking manufacturer/model: GigaBlue/UE 4k
Checking id: /proc/stb/info/chipset = bcm7252s
Checking manufacturer/model: GigaBlue/Quad 4k
Checking id: /proc/stb/info/chipset = bcm7252s
Checking manufacturer/model: XSarius/Galaxy4k
Checking id: /proc/stb/info/chipset = 7252S
Checking id: /proc/stb/info/hwmodel = galaxy4k
Checking manufacturer/model: Qviart/Lunix3-4k
Checking id: /proc/stb/info/chipset = 7252S
Checking id: /proc/stb/info/hwmodel = lunix3-4k
Checking manufacturer/model: XTrend/ET10000
Checking id: /proc/stb/info/model = et10000
Checking manufacturer/model: Mut@nt/hd2400
Checking id: /proc/stb/info/boxtype = hd2400
Checking manufacturer/model: Zgemma/h9
Checking id: /proc/stb/info/model = h9
Checking manufacturer/model: generic/non-transcoding settopbox
model identified as: generic non-transcoding settopbox (unknown)
streamproxy: config_map: audiolang = /84767
streamproxy: config_map: auth = false/0
streamproxy: config_map: bframes = 0/0
streamproxy: config_map: bitrate = 2000/2000
streamproxy: config_map: foreground = true/1
streamproxy: config_map: group = /5120000
streamproxy: config_map: level = 3.1/3
streamproxy: config_map: listen:8002 = 1/1
streamproxy: config_map: listen:8003 = 1/1
streamproxy: config_map: profile = baseline/0
streamproxy: config_map: size = 720p/720
streamproxy: config_map: webifport = 80/80
 

volgens mij herkend hij hem nu niet goed. is een bcm7252s box naar mijn weten.


Edited by mk2k, 5 June 2020 - 15:04.


Re: transcoding op de xsarius revo4k #11 mk2k

  • Member
  • 14 posts

0
Neutral

Posted 5 June 2020 - 15:10

hij detecteert hem als een dm8000

root@revo4k:~# cat /proc/stb/info/boxtype
dm8000
root@revo4k:~#

chipset is wel goed

root@revo4k:~# cat  /proc/stb/info/chipset
7252S
root@revo4k:~#

root@revo4k:~# cat /proc/stb/info/hwmodel
revo4k

Edited by mk2k, 5 June 2020 - 15:14.


Re: transcoding op de xsarius revo4k #12 WanWizard

  • PLi® Core member
  • 60,482 posts

+1,376
Excellent

Posted 5 June 2020 - 15:17

Als streamproxy antwoord met:

Checking manufacturer/model: generic/non-transcoding settopbox

dan betekent het dat hij geen speciale / afwijkende code heeft voor de betreffende box. Niet dat het dan niet zou kunnen werken.

 

Hij zegt aan het eind dat hij luistert naar 8002 en 8003, dus hij breekt niet af of zo, hij zou het dus gewoon moeten doen.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: transcoding op de xsarius revo4k #13 mk2k

  • Member
  • 14 posts

0
Neutral

Posted 5 June 2020 - 15:57

toch vreemd. even openatv 6.2 terug geflased. 

die gebruiken transtreamproxy 

top - 16:56:19 up 10 min,  1 user,  load average: 1,07, 1,00, 0,58
Tasks: 110 total,   1 running, 109 sleeping,   0 stopped,   0 zombie
%Cpu(s):   0,7/0,5     1[                                                     ]
KiB Mem :  2062924 total,   744276 free,  1188620 used,   130028 buff/cache
KiB Swap:        0 total,        0 free,        0 used.   807004 avail Mem
 
  PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND
 2132 root      20   0  162976  77968  10236 S   1,3  3,8   0:10.29 enigma2
 2327 root      20   0   20000   1632   1360 S   0,7  0,1   0:00.11 transtream+
  932 root      20   0       0      0      0 S   0,3  0,0   0:00.11 high_stndby
  955 root      20   0       0      0      0 S   0,3  0,0   0:00.26 high
 2347 root      20   0    4668   1316    884 R   0,3  0,1   0:00.16 top
    1 root      20   0    1580    468    412 S   0,0  0,0   0:01.77 init
    2 root      20   0       0      0      0 S   0,0  0,0   0:00.00 kthreadd
    3 root      20   0       0      0      0 S   0,0  0,0   0:00.06 ksoftirqd/0
    4 root      20   0       0      0      0 S   0,0  0,0   0:00.06 kworker/0:0
    5 root       0 -20       0      0      0 S   0,0  0,0   0:00.00 kworker/0:+
    6 root      20   0       0      0      0 S   0,0  0,0   0:00.01 kworker/u4+
    7 root      20   0       0      0      0 S   0,0  0,0   0:00.18 rcu_sched
    8 root      20   0       0      0      0 S   0,0  0,0   0:00.00 rcu_bh
    9 root      rt   0       0      0      0 S   0,0  0,0   0:00.00 migration/0
   10 root      rt   0       0      0      0 S   0,0  0,0   0:00.00 watchdog/0
   11 root      rt   0       0      0      0 S   0,0  0,0   0:00.00 watchdog/1
   12 root      rt   0       0      0      0 S   0,0  0,0   0:00.11 migration/1
 

openpli 6.2 ook even geprobeerd, maar hierin zit de transcoding optie niet ingebouwd.

 

maar transtreamproxy -f werkt niet. iets andere applicatie ofzo? 


Edited by mk2k, 5 June 2020 - 16:01.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users