Jump to content


Photo

Wifi dongle is not recognized

wifi rtl8812 driver

  • Please log in to reply
11 replies to this topic

#1 slalo19

  • Member
  • 6 posts

0
Neutral

Posted 17 June 2020 - 12:25

Hello, I just bought a wifi adapter for my Zgemma h5 with openpli 7.2 but when connecting it does not appear as a network adapter.

 

The adapter is a tplink t2u plus with the ralink 8812au chip, I have seen that it is supported by installing an external module and although I have installed it by telnet it still does not work. What I can do? Thanks you.


Edited by WanWizard, 17 June 2020 - 12:26.
fixed formatting


Re: Wifi dongle is not recognized #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 54,906 posts

+1,093
Excellent

Posted 17 June 2020 - 12:27

Did you restart the box after installing the driver?

 

Can you post the output of

lsmod
lsusb

 


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Wifi dongle is not recognized #3 slalo19

  • Member
  • 6 posts

0
Neutral

Posted 17 June 2020 - 12:45

 

Did you restart the box after installing the driver?

 

Can you post the output of

lsmod
lsusb

 

 

Yes, I have installed the module "kernel-module-8812au" and restarted it. The output is:

 
root@h5:~# lsmod
Module                  Size  Used by
nfsd                   98902  11
ipv6                  416963  60
h5                   7705465  11
h5_3                   33169  1 h5
h5_2                   22399  0
h5_1                    6653  3 h5_3,h5_2,h5
root@h5:~# lsusb
Bus 001 Device 001: ID 1d6b:0002
Bus 001 Device 004: ID 04a3:0101
Bus 001 Device 002: ID 2357:0120
Bus 002 Device 001: ID 1d6b:0001
Bus 001 Device 003: ID 05e3:0608
root@h5:~#

Edit: Clarification


Edited by slalo19, 17 June 2020 - 12:47.


Re: Wifi dongle is not recognized #4 WanWizard

  • Forum Moderator
    PLi® Core member
  • 54,906 posts

+1,093
Excellent

Posted 17 June 2020 - 12:52

Please stop formatting your posts, those large letters are very annoying !

 

Device 2357:0120 is currently not supported by the driver, the device is newer than the driver is.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Wifi dongle is not recognized #5 slalo19

  • Member
  • 6 posts

0
Neutral

Posted 17 June 2020 - 12:57

Please stop formatting your posts, those large letters are very annoying !

Device 2357:0120 is currently not supported by the driver, the device is newer than the driver is.

Sorry, I was using the translator and it causes me typographical errors. Is there no way to get it working? If so I will return the adapter.

Enviado desde mi HD1900 mediante Tapatalk

Re: Wifi dongle is not recognized #6 WanWizard

  • Forum Moderator
    PLi® Core member
  • 54,906 posts

+1,093
Excellent

Posted 17 June 2020 - 13:01

I'll have a look.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Wifi dongle is not recognized #7 WanWizard

  • Forum Moderator
    PLi® Core member
  • 54,906 posts

+1,093
Excellent

Posted 17 June 2020 - 13:13

Can you remove the installed driver

opkg remove kernel-module-8812au

and install the attached one instead? And restart your box after you've done so?

Attached Files


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Wifi dongle is not recognized #8 slalo19

  • Member
  • 6 posts

0
Neutral

Posted 17 June 2020 - 13:37

Can you remove the installed driver

opkg remove kernel-module-8812au

and install the attached one instead? And restart your box after you've done so?

 

Yes, I have unistalled the above module using: 

opkg remove kernel-module-8812au*

After I have restarted and trying to install the attachment an error appears: 

root@h5:/var/volatile/tmp# opkg install kernel-module-8812au-4.10.12_4.3.14-r0.0
_h5.ipk
Installing kernel-module-8812au-4.10.12 (4.3.14) on root
Segmentation fault
root@h5:/var/volatile/tmp#






Re: Wifi dongle is not recognized #9 WanWizard

  • Forum Moderator
    PLi® Core member
  • 54,906 posts

+1,093
Excellent

Posted 17 June 2020 - 13:59

Was afraid so, the hardware has specific driver requirements that are not supported by this driver.

 

There is newer source, but integrating out-of-tree drivers into 40 or so different linux kernel versions (we need to support 3.2 to 5.5) is a big pain and lots of work.

 

So don't expect anything soon, or at all...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Wifi dongle is not recognized #10 slalo19

  • Member
  • 6 posts

0
Neutral

Posted 17 June 2020 - 14:24

Was afraid so, the hardware has specific driver requirements that are not supported by this driver.

There is newer source, but integrating out-of-tree drivers into 40 or so different linux kernel versions (we need to support 3.2 to 5.5) is a big pain and lots of work.

So don't expect anything soon, or at all...

Still, thank you very much, you are very kind. I will return the dongle, do you know which one I could buy which supports 5ghz wifi and is compatible? At the moment I have it connected by cable but the ethernet port is only 100mbps, I suppose that with the 5ghz wifi it would go faster. I'm wrong?

Enviado desde mi HD1900 mediante Tapatalk

Re: Wifi dongle is not recognized #11 WanWizard

  • Forum Moderator
    PLi® Core member
  • 54,906 posts

+1,093
Excellent

Posted 17 June 2020 - 14:32

I don't know, I personally stay away from any wireless if possible.

 

A cable is a lot more stable, and for most applications 100Mbps is more than fast enough.

 

Don't forget wifi is a shared medium.

 

If your kids iphone in the bedroom makes a connection to the same AP, your box can report 400Mbps but still only have 1Mbps throughput because the iPhone connection limits the speed of the AP.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Wifi dongle is not recognized #12 slalo19

  • Member
  • 6 posts

0
Neutral

Posted 17 June 2020 - 14:47

I don't know, I personally stay away from any wireless if possible.

A cable is a lot more stable, and for most applications 100Mbps is more than fast enough.

Don't forget wifi is a shared medium.

If your kids iphone in the bedroom makes a connection to the same AP, your box can report 400Mbps but still only have 1Mbps throughput because the iPhone connection limits the speed of the AP.

Okay, I think I'll keep using the cable then. Thank you very much again, greetings

Enviado desde mi HD1900 mediante Tapatalk





Also tagged with one or more of these keywords: wifi, rtl8812, driver

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users