Jump to content


ian1095

Member Since 23 Feb 2013
Offline Last Active 11 Jul 2021 06:46
-----

#670731 serviceapp - gstplayer and exteplayer3

Posted by ian1095 on 18 February 2017 - 16:27

Ok no problem.

 

Its pointless discussing grammar any further. I do hope however Ive manged to convey the message to you that there is a problem regarding the A_  and that Ive eventually managed to make myself clear as to what this problem is and that either yourself or mx3L can address the issue.

 

I will try to be more precise in my terminology in the future.

 

Ian.




#602698 serviceapp - gstplayer and exteplayer3

Posted by ian1095 on 19 October 2016 - 07:38

Ok guys

 

Something is not quite right with the new SSS rtmp ffmpeg patch.

 

When using this patch with

 

- ffmpeg 3.1.4

- exteplayer3 rev: https://github.com/s...f09c36f63f2b5f9

 

If I stream from ITV Player both from Kodi and from an Enigma2 plugin the stream will play perfectly but after exactly 1 minute it will stop. It does this without fail each time and everytime. To be sure I also seeked 5 minutes into the stream and played it from there and sure enough after exactly 1 minute when the stream reached 6 minutes in duration the stream stopped once more.

 

here is the Enigma2 lever 4 debug

< 39187.102> [KodiLauncher] FBUnlock

< 39187.102> [fb] double buffering available!

< 39187.130> [KodiLauncher] RCUnlock

< 39187.137> [SKIN] Parsing embedded skin <embedded-in-'StatusScreen'>

< 39187.146> [SubsSupport] using global config

< 39187.289> [SKIN] Parsing embedded skin <embedded-in-'SubsEmbeddedScreen'>

< 39187.296> [SKIN] Parsing embedded skin <embedded-in-'SubsScreen'>

< 39187.312> [SubsLoader][info] setting block parsing for Parsers

< 39187.324> [SKIN] Parsing embedded skin <embedded-in-'Screensaver'>

< 39187.335> [SKIN] Parsing embedded skin <embedded-in-'HideVBILine'>

< 39187.421> [ePicLoad] setPara max-X=-1 max-Y=-1 aspect_ratio=1.000000 cache=0

resize=0 bg=#FF000000 auto_orient=0

< 39187.421> [WebPixmap] load - already loaded

< 39187.432> [SubsLoader][info] <1-0694-9015-001_CoronationStreet_TX171016.xml?_

_gda__=1476863705_d426504df09f8f31b190b12b4e8d5e71&fileExt=.xml> loading ...

< 39188.426> [decode] trying encoding utf-8 ...

< 39188.427> [decode] trying encoding utf-16 ...

< 39188.437> [decode] decoded with utf-16 encoding

< 39188.438> [SubsLoader][info] looking for '.xml' parser

< 39188.438> [SubsLoader][info] trying parsing with <SubRipParser>

< 39188.494> [SubsLoader][info] trying parsing with <MicroDVDParser>

< 39188.496> [SubsLoader][error] <MicroDVDParser>: cannot parse, FPS not provide

d

< 39188.497> playing 4097:0:0:0:0:0:0:0:0:0:rtmpe%3a//cp72511.edgefcs.net/ondema

nd?auth=eaEctb8dBaOcAbNdDctbUbedkbBbuc0aibdcIaod0aPb0b8and4ambxcIbVaLc2aba4-bybW

Rn-eS-dym4JAnlBsFs&aifp=v002&slist=production/ swfurl=http%3a//www.itv.com/mercu

ry/Mercury_VideoPlayer.swf playpath=mp4%3aproduction/priority/CATCHUP/1/0694/901

5/001/1-0694-9015-001_PC011800_16X9.mp4 swfvfy=true:Coronation Street  - 17/10/2

016

< 39188.497> eServiceApp

< 39188.498> PlayerApp

< 39188.498> BasePlayer

< 39188.498> ExtEplayer3

< 39188.498> PlayerBackend

< 39188.498> eServiceApp::setTarget 0

< 39188.498> eServiceApp::fillSubservices - failed to retrieve subservices, not

supported url

< 39188.499> PlayerBackend::gotMessage - tStart

< 39188.499> PlayerApp::processStart: exteplayer3 "rtmpe://cp72511.edgefcs.net/o

ndemand?auth=eaEctb8dBaOcAbNdDctbUbedkbBbuc0aibdcIaod0aPb0b8and4ambxcIbVaLc2aba4

-bybWRn-eS-dym4JAnlBsFs&aifp=v002&slist=production/ swfurl=http://www.itv.com/me

rcury/Mercury_VideoPlayer.swf playpath=mp4:production/priority/CATCHUP/1/0694/90

15/001/1-0694-9015-001_PC011800_16X9.mp4 swfvfy=true"

< 39188.611> ExtEPlayer3::handleJsonOutput - unhandled key "EPLAYER3_EXTENDED"

< 39189.614> ExtEPlayer3::handleJsonOutput - unhandled key "PLAYBACK_OPEN"

< 39189.681> ExtEPlayer3::handleJsonOutput - unhandled key "OUTPUT_OPEN"

< 39189.732> PlayerBackend::recvStart - status = 0

< 39189.732> PlayerBackend::recvVideoTrackCurrent - status = 0

< 39189.732> PlayerBackend::gotMessage - start

< 39189.732> eServiceApp::gotExtPlayerMessage - start

< 39189.734> PlayerBackend::recvAudioTrackCurrent - status = 0

< 39189.734> PlayerBackend::recvSubtitleTrackCurrent - status = 0

< 39189.738> eServiceApp::getNumberOfSubservices - 0

< 39189.762> PlayerBackend::recvVideoTrackCurrent - status = 0

< 39189.833> [SubsSupport] Service Started

< 39189.834> [SubsLoader][info] changing encoding group to: ['utf-8', 'utf-16',

'windows-1250', 'iso-8859-2', 'maclatin2', 'IBM852']

< 39189.835> [SubsEngine] setSubsDelay - setting delay to 0ms

< 39189.841> eServiceApp::isCurrentlySeekable

< 39189.842> resolved to PLAY

< 39189.842> eServiceApp::unpause

< 39189.842> PlayerBackend::gotMessage - tUnpause

< 39189.842> PlayerBackend::recvResume - status = 1

< 39189.844> eServiceApp::isCurrentlySeekable

< 39189.846> [WebPixmap] load - already loaded

< 39189.847> PlayerBackend::gotMessage - videoFramerateChanged

< 39189.847> eServiceApp::gotExtPlayerMessage - videoFramerateChanged

< 39189.849> [AutoRes] got event evFramerateChanged

< 39189.849> PlayerBackend::gotMessage - videoSizeChanged

< 39189.849> eServiceApp::gotExtPlayerMessage - videoSizeChanged

< 39189.872> [AutoRes] got event evVideoSizeChanged

< 39189.873> PlayerBackend::gotMessage - videoProgressiveChanged

< 39189.873> eServiceApp::gotExtPlayerMessage - videoProgressiveChanged

< 39189.873> [AutoRes] got event evVideoProgressiveChanged

< 39189.924> PlayerBackend::gotMessage - tGetLength

< 39190.847> eServiceApp::signalEventUpdatedInfo

< 39190.852> eServiceApp::getNumberOfTracks

< 39190.852> WaitThread - waiting for 500ms

< 39190.852> PlayerBackend::gotMessage - tAudioList

< 39190.852> WaitThread - in time



< 39190.854> eServiceApp::getTrackInfo = 0

< 39190.866> [AutomaticVolumeAdjustment] service changed

< 39253.070> action: okButton

< 39253.070> action ->  InfobarSeekActions okButton

< 39253.071> action ->  OkCancelActions ok

< 39253.071> unknown action OkCancelActions/ok! typo in keymap?

< 39253.071> action ->  InfobarShowHideActions toggleShow

< 39253.073> [ePicLoad] setPara max-X=-1 max-Y=-1 aspect_ratio=1.000000 cache=0

resize=0 bg=#FF000000 auto_orient=0

< 39253.073> [WebPixmap] load - already loaded

< 39254.240> PlayerBackend::recvStopped - retval = 0

< 39254.240> PlayerBackend::thread_finished

< 39254.240> PlayerBackend::gotMessage - stop

< 39254.240> eServiceApp::gotExtPlayerMessage - stop

< 39254.240> eServiceApp::isCurrentlySeekable

< 39254.241> resolved to PAUSE

< 39254.241> eServiceApp::pause

< 39254.256> [SubsSupport] closing subtitleDisplay

< 39254.258> RemovePopup, id = kodiplayer_seekto

< 39254.265> eServiceApp::stop

< 39254.288> ~PlayerBackend

< 39254.289> ~ExtEplayer3

< 39254.289> ~BasePlayer

< 39254.289> ~PlayerApp

< 39254.289> ~eServiceApp

< 39254.879> [KodiLauncher] FBLock

< 39254.879> [KodiLauncher] RCLock

I then tested an image still using-ffmpeg 3.1.4

but without applying the attached ffmpeg-keep-native-rtmp-support.patch.

 

and with these Exteplayer3 commits reverted

 

https://github.com/s...7cb963e501ed16b and https://github.com/s...b91c43932cdaa4.

 

and there are no such issues with the stream stopping after 1 minute and it plays perfectly for its duration.

 

I hope you guys can sort this as it would be great to apply and use this new patch once this issue is addressed.

 

Ian.
 

Attached Files




#597190 Kodi 15.2 for vusolose, vusolo2 and vuduo2

Posted by ian1095 on 6 October 2016 - 16:29

Very Nice mx3L

 

Just added them.

 

Working perfectly.

 

Ian.




#554223 Pli https certs

Posted by ian1095 on 25 June 2016 - 16:30

Surely its about time you fixed the https certs problem ?

 

So many https sites cannot be connected to now which are perfectly fine when using other images.

 

Come on guys,this is not a trivial issue.

 

Ian.




#517561 Stream stop

Posted by ian1095 on 6 December 2015 - 08:12

THIS UPDATE IS A JOKE !

 

https://github.com/O...c64d537c17bfb48

 

This breaks many third party plugins and for what ?

 

90% of users dont even know what alternate headers and user agents are let alone know how to use and add them to their bouquet list. Whilst its true that its down to plugin writers to fix,all you have achieved here is to create massive amounts of work for the plugin writers. As each and every scraper will need new code added to it.

 

You forget that most plugins cater for other images than just Pli, and whilst adding the fix to the final link in the plugin code will make the plugin work once more with Pli,with this fix,it then also stops the plugin from working on other images such as BH

 

This is an example of the fix now working in Pli but after it being applied it no longer works in BH after this was added to the final link in a scraper.

https://s3.amazonaws.com/otmar-misc-tv/beverlyhillbillies-01-clampettsstrikeoil.mp4#Host=s3.amazonaws.com&User-Agent=Mozilla/5.0 (Windows NT 5.1; rv:42.0) Gecko/20100101 Firefox/42.0&Accept=text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8&Accept-Language=en-US,en;q=0.5&Referer=http://oldtimemoviesandradio.net/otmar-misc-tv/beverlyhillbillies-01-clampettsstrikeoil/&Connection=keep-alive

This seriously needs reverting or at the very least patching properly to allow both methods of adding alternate user agents and headers.

 

Ian.




#378530 TMDB plugin

Posted by ian1095 on 7 October 2013 - 17:08

thank you for the feedback my friend and for the ipk.

 

not everyone is in favor of what we have done here with this plugin,but we personally feel that a plugin once released publicly,should then be available to all,regardless of the image an individual user chooses to use and not restricted to just one type of image or box.

 

if the author doesnt want everyone to be able to use it,then he should keep it private.

 

i hope what we have done helps to make people happy.

 

Ian.