Jump to content


pietjepuk

Member Since 5 Jan 2008
Offline Last Active 04 Mar 2021 12:56
-----

Posts I've Made

In Topic: Upgrade from 4.0 to 6.1 and samba password KO.

3 July 2018 - 12:29

I have similar issues, 

I removed samba with opkg move /etc/samba -. /etc/samba.sav and /var/lib/samba -> /var/iib/samba.sav

 

Did a opkg install samba.

Coupe of issues, no /etc/samba/smb.conf file was installed

No directory /var/lib/samba/private/msg.sock was created ( error from smbs: mkdir failed on directory /var/lib/samba/private/msg.sock: No such file or directory)

 

​Added a smb.conf file as mentioned in a few posts above.

Added:

log file = /tmp/smb.log

log level = 2 auth:10 passdb:4 auth_audit:5

 

[MyMusic]

  comment = Music Library for Sonos

  path = /media/hdd/MyMusic

  read only = no

  guest ok = no

  valid users = root

 

Tried to connect to a share using root:

 

In log file:

[2018/07/03 12:18:55.407123,  5, pid=10766, effective(0, 0), real(0, 0), class=auth] ../source3/auth/auth_util.c:117(make_user_info_map)

  Mapping user [VUDUO2]\[root] from workstation [PBOFFICEMINI]

[2018/07/03 12:18:55.407202,  5, pid=10766, effective(0, 0), real(0, 0), class=auth] ../source3/auth/user_info.c:62(make_user_info)

  attempting to make a user_info for root (root)

[2018/07/03 12:18:55.407254,  5, pid=10766, effective(0, 0), real(0, 0), class=auth] ../source3/auth/user_info.c:70(make_user_info)

  making strings for root's user_info struct

[2018/07/03 12:18:55.407308,  5, pid=10766, effective(0, 0), real(0, 0), class=auth] ../source3/auth/user_info.c:108(make_user_info)

  making blobs for root's user_info struct

[2018/07/03 12:18:55.407358, 10, pid=10766, effective(0, 0), real(0, 0), class=auth] ../source3/auth/user_info.c:159(make_user_info)

  made a user_info for root (root)

[2018/07/03 12:18:55.407406,  3, pid=10766, effective(0, 0), real(0, 0), class=auth] ../source3/auth/auth.c:178(auth_check_ntlm_password)

  check_ntlm_password:  Checking password for unmapped user [VUDUO2]\[root]@[PBOFFICEMINI] with the new password interface

[2018/07/03 12:18:55.407460,  3, pid=10766, effective(0, 0), real(0, 0), class=auth] ../source3/auth/auth.c:181(auth_check_ntlm_password)

  check_ntlm_password:  mapped user is: [VUDUO2]\[root]@[PBOFFICEMINI]

[2018/07/03 12:18:55.407509, 10, pid=10766, effective(0, 0), real(0, 0), class=auth] ../source3/auth/auth.c:190(auth_check_ntlm_password)

  check_ntlm_password: auth_context challenge created by random

[2018/07/03 12:18:55.407618, 10, pid=10766, effective(0, 0), real(0, 0), class=auth] ../source3/auth/auth.c:192(auth_check_ntlm_password)

  challenge is: 

[2018/07/03 12:18:55.407690, 10, pid=10766, effective(0, 0), real(0, 0), class=auth] ../source3/auth/auth_builtin.c:41(check_guest_security)

  Check auth for: [root]

[2018/07/03 12:18:55.407738, 10, pid=10766, effective(0, 0), real(0, 0), class=auth] ../source3/auth/auth.c:233(auth_check_ntlm_password)

  check_ntlm_password: guest had nothing to say

[2018/07/03 12:18:55.407792, 10, pid=10766, effective(0, 0), real(0, 0), class=auth] ../source3/auth/auth_sam.c:75(auth_samstrict_auth)

  Check auth for: [root]

[2018/07/03 12:18:55.407930,  3, pid=10766, effective(0, 0), real(0, 0), class=auth] ../source3/auth/check_samsec.c:400(check_sam_security)

  check_sam_security: Couldn't find user 'root' in passdb.

[2018/07/03 12:18:55.408001,  5, pid=10766, effective(0, 0), real(0, 0), class=auth] ../source3/auth/auth.c:252(auth_check_ntlm_password)

  check_ntlm_password: sam authentication for user [root] FAILED with error NT_STATUS_NO_SUCH_USER

[2018/07/03 12:18:55.408058,  2, pid=10766, effective(0, 0), real(0, 0), class=auth] ../source3/auth/auth.c:315(auth_check_ntlm_password)

  check_ntlm_password:  Authentication for user [root] -> [root] FAILED with error NT_STATUS_NO_SUCH_USER

[2018/07/03 12:18:55.408137,  3, pid=10766, effective(0, 0), real(0, 0), class=auth] ../source3/auth/auth_util.c:1602(do_map_to_guest_server_info)

  No such user root [VUDUO2] - using guest account

 
So smbd still uses local passwd file and not just unix passwd file.
 
Do we need smbpasswd to get the root user in the local smb passwd file?

In Topic: Upgrade error: Cannot satisfy the following dependencies for packagegroup-mac...

11 June 2018 - 19:26

OpenPLi 6 doesn't use gstreamer 0.10, that is from OpenPLi 4. Did you install some plugin that might have this as a dependency?

Most info is in the previous posts, no I did not install gstreamer 0.10.36 nor is it installed on the system.

Here is the opkg command showing the error:

opkg install packagegroup-machine-base

Upgrading packagegroup-machine-base from 1.0-r83.2 to 1.0-r83.3 on root.

Collected errors:

 * calculate_dependencies_for: Cannot satisfy the following dependencies for packagegroup-machine-base:

 * gstreamer (>= 0.10.36.1+git12092+1bcabb9) * libgstvideo-0.10-0 (>= 0.10.36.1+git10186+bdb3316) * libjpeg8 (>= 8d) * 

 * opkg_solver_install: Cannot install package packagegroup-machine-base.

 

None of the packages listed in the error message is installed ( checked with 'opkg list-installed' )

 

 

opkg list-installed | fgrep  gstreamer

gstreamer1.0 - 1.12.4+git17579+a6653b6-r0.0

gstreamer1.0-libav - 1.12.4+git2090+326c741-r0.0

gstreamer1.0-plugin-dvbmediasink - 1.0+git82+16cae1a-r0.0

gstreamer1.0-plugin-subsink - 1.0+git7+2c4288b-r0.3

 

rest of output deleted

 

To me it looks like the package packagegroup-machine-base contains the wrong ( old ) library links.


In Topic: Upgrade error: Cannot satisfy the following dependencies for packagegroup-mac...

11 June 2018 - 18:40

What box and what OpenPli release is this? 

Please see second post


In Topic: Upgrade error: Cannot satisfy the following dependencies for packagegroup-mac...

11 June 2018 - 14:56

Error is caused by trying to upgrade packagegroup-machine-base

Upgrading packagegroup-machine-base from 1.0-r83.2 to 1.0-r83.3 on root.

 

 

Is it possible that the package gma2-plugin-systemplugins-skinselector is linked and older version of the underlying libraries.

I noticed that libjpeg8 is not installed but libjpeg62 is, could this cause the issue?


In Topic: Upgrade error: Cannot satisfy the following dependencies for packagegroup-mac...

11 June 2018 - 14:45

The odd thing is that I cannot find any reference of the gstreamer version nor the libgstvideo version as listed in the error message in the installed package list. Is there a rogue entry in the package list somewhere?

box info:

 

Brand & Model: Vu+ Duo² Chipset: Broadcom 7424 Main Memory: 1260428 kB free / 1408712 kB total Box Uptime: 0:20 Software System OE: PLi-OE Firmware version: OpenPLi 6.2-release (2018-06-01-release-6.2) Kernel / Drivers: 3.13.5 / 3.13.5+20180319-r0.0