Jump to content


Photo

FullBackup

plugin

  • Please log in to reply
359 replies to this topic

Re: FullBackup #81 rtzhjgg0

  • Senior Member
  • 568 posts

+13
Neutral

Posted 1 September 2013 - 13:50

Flashing with automatic-fullbackup_2.8 (Duo2 ,VTi on flash) crashes with:

 

Attached Files


Selfsat H50M4
Ultimo4K /2xTwinS2, VTI, PLi, ATV...
NAS: Qnap221

Re: FullBackup #82 littlesat

  • PLi® Core member
  • 49,694 posts

+543
Excellent

Posted 1 September 2013 - 13:53

Crash logs (.log) files you can just attach here. You do not need to zip them and/or quote them...

 

But this is a strange crash as our message box should now simple....???

 

But you stated VTi image...

 

Likely the VTi image doesn't understand simple message box...that is intend to give a simple popup instead of a full PIG-ed message box and is specially added for PIG-ed skins.


Edited by littlesat, 1 September 2013 - 13:59.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: FullBackup #83 rtzhjgg0

  • Senior Member
  • 568 posts

+13
Neutral

Posted 1 September 2013 - 13:57

Ok, the next one will be no not ziped :)

 

 

The log is with VTi on flash.


Edited by rtzhjgg0, 1 September 2013 - 14:00.

Selfsat H50M4
Ultimo4K /2xTwinS2, VTI, PLi, ATV...
NAS: Qnap221

Re: FullBackup #84 Dimitrij

  • PLi® Core member
  • 6,601 posts

+213
Excellent

Posted 1 September 2013 - 14:00

Flashing with automatic-fullbackup_2.8 (Duo2 ,VTi on flash) crashes with:


TypeError: __init__() got an unexpected keyword argument 'simple'

Plugin not support Vti image,only openPLi.


Edited by Dima73, 1 September 2013 - 14:00.

Lunix3-4K/VU+solo4k(thanks guys to gisclub.tv)


Re: FullBackup #85 rtzhjgg0

  • Senior Member
  • 568 posts

+13
Neutral

Posted 1 September 2013 - 14:08

Only openPLi ? Than I can't test it - sorry.

Plugin not support Vti image,only openPLi.

 


Selfsat H50M4
Ultimo4K /2xTwinS2, VTI, PLi, ATV...
NAS: Qnap221

Re: FullBackup #86 betacentauri

  • PLi® Core member
  • 5,585 posts

+254
Excellent

Posted 1 September 2013 - 19:45

@rtzhjgg0: It should be possible to use gutemines plugin with my binary. Copy only my binary into the bin folder of plugin and rename it to fgwrite.


Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: FullBackup #87 rtzhjgg0

  • Senior Member
  • 568 posts

+13
Neutral

Posted 1 September 2013 - 19:55

ok, i'll try it :)


Selfsat H50M4
Ultimo4K /2xTwinS2, VTI, PLi, ATV...
NAS: Qnap221

Re: FullBackup #88 rtzhjgg0

  • Senior Member
  • 568 posts

+13
Neutral

Posted 1 September 2013 - 20:13

@rtzhjgg0: It should be possible to use gutemines plugin with my binary. Copy only my binary into the bin folder of plugin and rename it to fgwrite.

Indeed, Flash Gordon with your binary can flash perfectly B)


Selfsat H50M4
Ultimo4K /2xTwinS2, VTI, PLi, ATV...
NAS: Qnap221

Re: FullBackup #89 rtzhjgg0

  • Senior Member
  • 568 posts

+13
Neutral

Posted 5 September 2013 - 17:21

TypeError: __init__() got an unexpected keyword argument 'simple'

 

@Dima73
Can you fix somehow this skin problem so we can use FullBackup on all images ?

 

Thanks :)


Selfsat H50M4
Ultimo4K /2xTwinS2, VTI, PLi, ATV...
NAS: Qnap221

Re: FullBackup #90 Dimitrij

  • PLi® Core member
  • 6,601 posts

+213
Excellent

Posted 5 September 2013 - 19:49

TypeError: __init__() got an unexpected keyword argument 'simple'

 

@Dima73
Can you fix somehow this skin problem so we can use FullBackup on all images ?

 

Thanks :)

http://openpli.org/f...ndpost&p=360077


Lunix3-4K/VU+solo4k(thanks guys to gisclub.tv)


Re: FullBackup #91 betacentauri

  • PLi® Core member
  • 5,585 posts

+254
Excellent

Posted 5 September 2013 - 19:57

Well, if that is not compatible with other images then feel free to change it.
But please, it should be fully readable if you change it. And I think this was the problem, or?
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: FullBackup #92 Dimitrij

  • PLi® Core member
  • 6,601 posts

+213
Excellent

Posted 5 September 2013 - 20:07

rtzhjgg0

Replace in /usr/lib/enigma2/python/Plugins/Extensions/FullBackup/

Restart GUI


Lunix3-4K/VU+solo4k(thanks guys to gisclub.tv)


Re: FullBackup #93 rtzhjgg0

  • Senior Member
  • 568 posts

+13
Neutral

Posted 5 September 2013 - 20:43

With this plugin.py, automatic-FullBackup 2.8 can flash without any crash on: on VTi, ViX and BH (Duo2)

Thanks B) B) B)


Selfsat H50M4
Ultimo4K /2xTwinS2, VTI, PLi, ATV...
NAS: Qnap221

Re: FullBackup #94 rtzhjgg0

  • Senior Member
  • 568 posts

+13
Neutral

Posted 6 September 2013 - 07:45

a NAS issue


If I choose BackupLocation=NAS, FullBackup tries to create a backup at /media/net/vuplus/duo2 instead of /media/net/MYSHRENAME/vuplus/duo2 and it fails with 'output file cannot be in the UBIFS root directory'.

my NAS configuration:

 

-------- automounts.xml
share name=MYSHRENAME
mount type=NFS
IP=192.168.1.XXX
sharedir=MYSHAREDIR
hdd_replacement=true
--------- root@vuduo2:~# mount
rootfs on / type rootfs (rw)
ubi0:rootfs on / type ubifs (rw,sync,relatime)
devtmpfs on /dev type devtmpfs (rw,relatime,size=482480k,nr_inodes=90201,mode=755)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
/dev/sda1 on /media/usb type ext4 (rw,relatime,barrier=1,data=ordered)
tmpfs on /var/volatile type tmpfs (rw,relatime,mode=755)
udev on /dev type tmpfs (rw,relatime,size=2048k,mode=755)
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620)
usbdevfs on /proc/bus/usb type usbfs (rw,relatime)
tmpfs on /dev/shm type tmpfs (rw,relatime,mode=777)
automount(pid1568) on /autofs type autofs (rw,relatime,fd=4,pgrp=1568,timeout=5,minproto=2,maxproto=4,indirect)
nfsd on /proc/fs/nfsd type nfsd (rw,relatime)
192.168.1.XXX:/MYSHAREDIR/ on /media/net/MYSHRENAME type nfs (rw,relatime,vers=3,rsize=8192,wsize=8192,namlen=255,hard,nolock,proto=tcp,port=65535,timeo=70,retrans=3,sec=sys,local_lock=all,addr=192.168.1.XXX)
--------
 

Attached Files


Selfsat H50M4
Ultimo4K /2xTwinS2, VTI, PLi, ATV...
NAS: Qnap221

Re: FullBackup #95 gutemine

  • Senior Member
  • 873 posts

+68
Good

Posted 6 September 2013 - 16:46

Bad news is that you discovered a known bug in mkfs.ubifs. Good news is that a patch for this is available and just needs to be applied.

Best news is that the mkfs.ubifs binary I use in my tools already includes this patch. Simply replace the binary and it should work or you will have to wait that somebody compiles a fixed version.


Edited by gutemine, 6 September 2013 - 16:47.


Re: FullBackup #96 rtzhjgg0

  • Senior Member
  • 568 posts

+13
Neutral

Posted 6 September 2013 - 17:52

Hi gutemine :)
i think (but i'm not sure) that ViX and VTi use the same mkfs.ubifs, but their built-in imagemanagers have no problems with my NAS configuration.

Can you upload here this binary with included NAS-patch ?


Selfsat H50M4
Ultimo4K /2xTwinS2, VTI, PLi, ATV...
NAS: Qnap221

Re: FullBackup #97 gutemine

  • Senior Member
  • 873 posts

+68
Good

Posted 7 September 2013 - 10:03

There is no NAS patch, it depends how the root directory is checked, this simply was a mess. With links or wrong protections or no access the check if the image you want to create is below the backuped root failed wrongly.

 

Such a check is needed to prevent that the image you create is part of the image which would mean a never ending image creation session.

 

With your error message it takes only 30 seconds and your favorite search engine to find the commit for the enhanced check. And then you can verify if it is included in the mkfs.ubifs the people are using.

 

If you need the binary it is included in latest dFlash ipk, but it has some other enhancements people maybe will dislike :-)


Edited by gutemine, 7 September 2013 - 10:05.


Re: FullBackup #98 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 7 September 2013 - 11:09

You should be able to use mkfs.ubifs from our feed, no magic involved.

Re: FullBackup #99 Dimitrij

  • PLi® Core member
  • 6,601 posts

+213
Excellent

Posted 7 October 2013 - 05:20

ver. 2.9
-update ofgwrite_v1_4(thank betacentauri)
-added options("Only root with use mtdy device","Only kernel with use mtdx device")
-fix gaps in the name of the directory files


Lunix3-4K/VU+solo4k(thanks guys to gisclub.tv)


Re: FullBackup #100 ColinB

  • Senior Member
  • 732 posts

+28
Good

Posted 30 October 2013 - 12:09

Can someone tell me if the AFB is working for OpenPli 4 on XP1000

 

I cant seem to get it to make a full backup. It can flash backups from Pedro_Newbie backup suite perfect.

Attached Files


Xtrend et8000 7.1-Release

2 x 8/1 DiSEqC  30w 13e 19e 23e 28e   

Astrometa USB Tuner Working DVB-T2 now on Kernel 4.10+  ;)

WD10EARX 1TB

Sandisk 32GB USB for AFB, EPG, Picons & Timeshift

 

ZGemma Star S 7.0-Release

4/1 DiSEqC  30w 13e 19e 28e

Sandisk 8GB USB for AFB, EPG, Picons & Timeshift

 

LG 49UH610V UHD-HDR

UHF/Cable/Sat

 

E-Channelizer

 

 

 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users