Jump to content


Photo

GStreamer 1.0

gstreamer 1.0 openpli

  • Please log in to reply
2520 replies to this topic

Re: GStreamer 1.0 #2481 mamamia

  • Senior Member
  • 70 posts

+1
Neutral

Posted 20 January 2017 - 14:22

New Ultimo 4k & Uno 4k Broadcoms should also be able to play VP9.

● 4Kp60 HEVC and VP9 decode

● Quad 1080p60 HEVC and VP9 decode  

 

Dear Erik, which comparison chart do you mean?

 

It would be really be cool if upcoming Openpli 5 will have support for HEVC and VP9.

 

Is there a roadmap for Openpli 5 release? When is Openpli team planning to release? 

 

Thank you!



Re: GStreamer 1.0 #2482 betacentauri

  • PLi® Core member
  • 6,748 posts

+289
Excellent

Posted 20 January 2017 - 14:30

We can only support both if the drivers support it. We don't write the drivers. So VU has to add it. Afaik HEVC support is included. VP9 i don't know.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: GStreamer 1.0 #2483 Rob van der Does

  • Senior Member
  • 7,732 posts

+184
Excellent

Posted 20 January 2017 - 14:43

VP9 should be supported by the Ult-4k & UNO-4k, but not by the Solo-4k.



Re: GStreamer 1.0 #2484 Erik Slagter

  • PLi® Core member
  • 46,581 posts

+530
Excellent

Posted 20 January 2017 - 15:17

VU+ has enabled wmv and h265:

--with-wmv --with-pcm --with-eac3 --with-h265

@mamamia: whether a codec is supported, is most often not determined by the capabilities of the hardware, but by money. The manufacturer decides which codecs are licensed from Broadcom and only those are enabled. The exact gstreamer config has little to do with that.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: GStreamer 1.0 #2485 ostende

  • Senior Member
  • 69 posts

0
Neutral

Posted 24 January 2017 - 00:14

where can i added this file 

Attached Files



Re: GStreamer 1.0 #2486 vaskee

  • Member
  • 1 posts

0
Neutral

Posted 31 July 2017 - 16:39

Hello,

is gstreamer package available also for sh4 architecture? (fortis box and it's clones).

I am missing two components. gst-bad-fragmented and gst-bad-rtmp

 

 I was able to find packages for download only in mipsel architecture. Thank you!


Edited by vaskee, 31 July 2017 - 16:39.


Re: GStreamer 1.0 #2487 WanWizard

  • PLi® Core member
  • 56,610 posts

+1,178
Excellent

Posted 31 July 2017 - 17:42

We don't do SH4 boxes, so you won't find them here.

 

You'll have to find an image with source for your box, and compile it yourself, that will also give you the required packages. You can't just pick other compiled packages, even if they are for the same architeture, changes are they won't work.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

Because to health reasons, I will not be active very often anymore.


Re: GStreamer 1.0 #2488 Trial

  • Senior Member
  • 1,033 posts

+30
Good

Posted 1 August 2017 - 07:58

Hi,

> I am missing two components. gst-bad-fragmented and gst-bad-rtmp

check which gstreamer your image uses. I think starting with 1.0 the plugins are not called gst- anymore they use gstreamer1.0- instead.

 

Try in telnet

opkg list | grep -bad-

 

ciao



Re: GStreamer 1.0 #2489 ozzsurf

  • Senior Member
  • 131 posts

+3
Neutral

Posted 20 October 2017 - 17:29

can audio codec alaw

run in gstreamer-1.0 openpli 6.0



Re: GStreamer 1.0 #2490 ozzsurf

  • Senior Member
  • 131 posts

+3
Neutral

Posted 21 October 2017 - 12:52

can anyone help to install audio codec alaw

is it in your feeds

gstreamer-1.0 openpli 6.0

is this right it finds nothing

opkg install gstreamer1.0-plugins-bad-alaw

 

thanks



Re: GStreamer 1.0 #2491 mrvica

  • Senior Member
  • 932 posts

+55
Good

Posted 21 October 2017 - 14:37

I´ve seen only good-alaw



Re: GStreamer 1.0 #2492 ozzsurf

  • Senior Member
  • 131 posts

+3
Neutral

Posted 21 October 2017 - 18:16

I´ve seen only good-alaw

 

 

wheres that then

 

opkg install gstreamer1.0-plugins-good-alaw

 

theres nothing there



Re: GStreamer 1.0 #2493 mrvica

  • Senior Member
  • 932 posts

+55
Good

Posted 21 October 2017 - 18:57

you can search the web for it, install it manually, it goes into /usr/lib/gstreamer-1.0, it is for mipsel

 

 

Attached Files



Re: GStreamer 1.0 #2494 ozzsurf

  • Senior Member
  • 131 posts

+3
Neutral

Posted 22 October 2017 - 13:19

@mrvica

 

thanks

i did search the web the ones i found where for gstreamer-0.10

which did not work

 

 

the one you posted dont work

are you sure its for gstreamer-1.0,



Re: GStreamer 1.0 #2495 mrvica

  • Senior Member
  • 932 posts

+55
Good

Posted 22 October 2017 - 14:12

it is definetly 1.0 for mipsel, maybe it needs registering, kind of gst-register, it is out of my scope



Re: GStreamer 1.0 #2496 mrvica

  • Senior Member
  • 932 posts

+55
Good

Posted 22 October 2017 - 14:42

you can download it from here as .deb packages, you can extract them with 7-zip

https://packages.deb....0-plugins-good



Re: GStreamer 1.0 #2497 WanWizard

  • PLi® Core member
  • 56,610 posts

+1,178
Excellent

Posted 22 October 2017 - 15:08

Isn't it a better solution to see what is missing, and adjust the build to fix this, instead of fiddling with external binaries from dubious sources?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

Because to health reasons, I will not be active very often anymore.


Re: GStreamer 1.0 #2498 ozzsurf

  • Senior Member
  • 131 posts

+3
Neutral

Posted 22 October 2017 - 15:30

whats missing is the gstreamer-1.0,audio alaw codec

to fix it find and install the right gstreamer-1.0, audio alaw codec

 

not fixed yet



Re: GStreamer 1.0 #2499 WanWizard

  • PLi® Core member
  • 56,610 posts

+1,178
Excellent

Posted 22 October 2017 - 17:02

And "gstreamer1.0-plugins-good-alaw", which is in the feeds, is the wrong one?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

Because to health reasons, I will not be active very often anymore.


Re: GStreamer 1.0 #2500 ozzsurf

  • Senior Member
  • 131 posts

+3
Neutral

Posted 23 October 2017 - 10:48

And "gstreamer1.0-plugins-good-alaw", which is in the feeds, is the wrong one?

 

you post in riddles
 

?????????????????????????????







Also tagged with one or more of these keywords: gstreamer, 1.0, openpli

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users