Jump to content


Photo

GStreamer 1.0

gstreamer 1.0 openpli

  • Please log in to reply
2520 replies to this topic

Re: GStreamer 1.0 #2501 WanWizard

  • Forum Moderator
    PLi® Core member
  • 50,046 posts

+899
Excellent

Posted 23 October 2017 - 11:25

You ask for the alaw codec, and my reply is "it is in the feeds, just install it".


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: GStreamer 1.0 #2502 ozzsurf

  • Senior Member
  • 119 posts

+3
Neutral

Posted 23 October 2017 - 12:09

You ask for the alaw codec, and my reply is "it is in the feeds, just install it".

 

 

opkg install gstreamer1.0-plugins-good-alaw

 

theres nothing there



Re: GStreamer 1.0 #2503 WanWizard

  • Forum Moderator
    PLi® Core member
  • 50,046 posts

+899
Excellent

Posted 23 October 2017 - 13:03

What image are you running?

root@h3:~# opkg install gstreamer1.0-plugins-good-alaw
Installing gstreamer1.0-plugins-good-alaw (1.12.00+git16633+27f40ec) on root.
Downloading http://downloads.openpli.org/feeds/openpli-6-release/mips32el/gstreamer1.0-plugins-good-alaw_1.12.00+git16633+27f40ec-r0.0_mips32el.ipk.
Configuring gstreamer1.0-plugins-good-alaw.
root@h3:~# 

Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: GStreamer 1.0 #2504 Trial

  • Senior Member
  • 991 posts

+29
Good

Posted 23 October 2017 - 15:02

Hi,

why riddle? Did you take a look with

opkg list | grep alaw

to see if it is on the feed and if it is simply install it?

 

When I tried to activate my FosCam WiFi-Cam I had the same problem and I had to install on that image alaw also by hand.

 

ciao



Re: GStreamer 1.0 #2505 WanWizard

  • Forum Moderator
    PLi® Core member
  • 50,046 posts

+899
Excellent

Posted 23 October 2017 - 15:46

No riddles whatsover:

root@hd2400:~# opkg list | grep alaw
gstreamer1.0-plugins-good-alaw - 1.12.00+git16633+27f40ec-r0.0 - GStreamer plugin for alaw  GStreamer plugin for alaw
root@hd2400:~#

If you are not clear about what you do, and don't answer questions like what box and what image you're using, how do you expect people to help you?

 

And yes, you do need to install it by hand, by default an OpenPLi image only installed what is absolutely nessecary, contrary to other images, which install everything but the kitchen sink, and as a result are slow as a snail...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: GStreamer 1.0 #2506 ozzsurf

  • Senior Member
  • 119 posts

+3
Neutral

Posted 26 October 2017 - 15:42

anyway after piss balling about trying to get the alaw codec from the feed

i got it and installed it

it dont work so i used readelf to open the .so

i think a lot more files are needed for this alaw codec to work

 

see file below

Attached Files



Re: GStreamer 1.0 #2507 WanWizard

  • Forum Moderator
    PLi® Core member
  • 50,046 posts

+899
Excellent

Posted 26 October 2017 - 15:46

Quite possible. Gstreamer isn't my thing, so I have to pass you on to someone with more knowledge about the subject.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: GStreamer 1.0 #2508 foxbob

  • Senior Member
  • 301 posts

+11
Neutral

Posted 26 October 2017 - 18:14

And can you give a couple of audio files for testing?



Re: GStreamer 1.0 #2509 raza05

  • New Member
  • 1 posts

0
Neutral

Posted 31 October 2019 - 15:16

Hi

I am new to the forum I have problem with gstreamer 1.0 on wetek play 2 here is the dcc screen shot attachment it gives dependency error if any one could help me to resolve this issue ll be appreciated

thanks

Attached File  DCC Screen.JPG   97.3KB   7 downloads



Re: GStreamer 1.0 #2510 Frenske

  • Forum Moderator
    PLi® Core member
  • 22,827 posts

+211
Excellent

Posted 31 October 2019 - 15:22

Wetek Play isn't supported by OpenPLi anymore and certainly not the Wetek Play 2. Sorry but you'll have to seek for support somewhere else. 

Perhaps the one that created that specific image for your Wetek Play 2, as our latest image is OpenPLi 4 from 12/2018.


Mijn schotel is een T90 met 10 LNB's. Daarnaast voor de fun nog een draaibaar systeem met een Triax TD 78.

Dreamboxen heb ik niet meer. Verder nog een een VU+ duo2 met 500Gb harddisk + een VU+ Uno, Zero, Solo 4K, Ultimo 4K, Zero 4K, Uno 4Kse. + ook nog een Xtrend ET4000. Daarnaast heb ik ook nog diverse andere modellen w.o. een Formuler F4, ET8500, ET7500, Mut@nt 2400HD, Xsarius Fusion HD se en verder nog wel het e.e.a. waarmee op verzoek vanalles wordt getest. Iemand moet het tenslotte doen. ;) :)

Voor centrale opslag van media gebruik ik een Qnap 219P met tweemaal 2 Tb harddisks.

-------------------------------------------------------------------------------------------
Many answers to your question can be found in our wiki: Just one click away from this "solutioncentre".

Als ik alles al wist hoefde ik ook niets te vragen. If I had all the knowledge I had no questions at all.

Re: GStreamer 1.0 #2511 WanWizard

  • Forum Moderator
    PLi® Core member
  • 50,046 posts

+899
Excellent

Posted 31 October 2019 - 15:41

The main reason btw for dropping support was that the manufacturer failed to implement gstreamer 1.0, which is why we couldn't release an OpenPLi 6 image for the Wetek Play.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: GStreamer 1.0 #2512 Trial

  • Senior Member
  • 991 posts

+29
Good

Posted 31 October 2019 - 20:42

Hi,

the plugins do not start with gst anymore instead gstreamer1.0 is used so you cannot find gst-plugins for >=1.0

 

ciao



Re: GStreamer 1.0 #2513 crystal-13

  • Member
  • 9 posts

0
Neutral

Posted 24 December 2019 - 22:47

VC-1 (in mkv) and wmv playing. Is this possible? openpli 7.1 gstreamer - 1.14.4

Re: GStreamer 1.0 #2514 Erik Slagter

  • PLi® Core member
  • 45,416 posts

+503
Excellent

Posted 26 December 2019 - 10:38

IIRC there are known issues with VC1 on VU+. I have reported it some time ago.


Edited by Erik Slagter, 26 December 2019 - 10:39.

* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: GStreamer 1.0 #2515 littlesat

  • PLi® Core member
  • 50,030 posts

+549
Excellent

Posted 26 December 2019 - 12:35

Latest broadcom drivers do not support older codex anymore.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: GStreamer 1.0 #2516 Taykun345

  • Senior Member
  • 1,193 posts

+31
Good

Posted 26 December 2019 - 13:29

We can expect that more and more devices will lost support for older codecs in the future. "Xvid" for example.

Sent from my HTC U11 using Tapatalk
Army MoodBlue HD skin modification by me: https://github.com/T...-MoodBlueHD-mod
Matrix10 MH-HD2 skin modification by me: https://github.com/B...-MX-HD2-OpenPli
MetrixHD skin modification by me: https://github.com/T...xHD-WPstyle-mod
Slovenian translation for OpenPLi E2: https://github.com/T...ion-for-OpenPLi

Re: GStreamer 1.0 #2517 Erik Slagter

  • PLi® Core member
  • 45,416 posts

+503
Excellent

Posted 27 December 2019 - 10:22

"xvid" = "divx" = "mpeg 4 asp" = actually mpeg 4 video codec (as opposed to mpeg 4 advanced video codec = h264).

 

The dm800 already didn't support mpeg4 vc. Mpeg4 vc is a disaster (according to the DVB guys...), it's an "improved" version of mpeg2, but the improvements are marginal and it also imposes all sorts of limitations. That's why DVB never adopted it. And nowadays it's also very obsoleted (released end 1990's, and it already has TWO successors).

 

So I think it can be very well defended that support for mpeg 4 vc is dropped. Mpeg2 is still supported as it's still part of DVB, which mpeg4 vc isn't.

 

On the other hand, VC-1 is still actual. It was meant to be a competitor to h264 from Microsoft, but never got really foothold. But it's still actual. But also it has never been part of DVB so manufacturers are free to not implement support.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: GStreamer 1.0 #2518 crystal-13

  • Member
  • 9 posts

0
Neutral

Posted 27 December 2019 - 20:04

On the other hand, VC-1 is still actual.

It can be found (VC-1) in many blyray discs (and remuxes), and can not be played on VU+

By the way, wmv 9 codec is playable, but wmv 8 can not be played. May be it can be possible in the future?



Re: GStreamer 1.0 #2519 WanWizard

  • Forum Moderator
    PLi® Core member
  • 50,046 posts

+899
Excellent

Posted 27 December 2019 - 20:22

Blueray rips you mean?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: GStreamer 1.0 #2520 betacentauri

  • PLi® Core member
  • 5,703 posts

+258
Excellent

Posted 27 December 2019 - 23:22

Better don’t expect that it will be possible in future. Buy a real mediaplayer. A satellite receiver is build to playback DVB content and wmv, vc-1,... are no codecs used in DVB streams. Manufacturer don’t want to pay license fees for something that is not really “necessary”.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04





Also tagged with one or more of these keywords: gstreamer, 1.0, openpli

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users