Jump to content


Photo

Mountprobleem Vu+ Duo. sec=ntlm (opgelost)

Vu Duo

  • This topic is locked This topic is locked
8 replies to this topic

#1 40H3X

  • PLi® Contributor
  • 3,559 posts

+116
Excellent

Posted 15 December 2015 - 11:15

Onlangs liep ik tegen het probleem aan dat een netwerk share niet wilde mounten in een Vu Duo. Na de toevoeging in de options sec=ntlm werd de share gemount, een probleem dat volgens mij gerelateerd is aan de kernel 3.9.6#1. Nu zag ik in de updates dat de kernel en modules meeliepen, is er zicht op een upgrade m.b.t. de kernel voor de Duo?


Hardware: Vu+ Uno 4k SE - Samsung HM500JI 500GB 2.5 inch - Amiko Viper Combo HDD - Edision OS mio 4K - Spycat Mini Plus - Vu+ Zero - Vu+ Duo - WD 1TB - Fuba 78 cm - Tripleblock LNB Quad 19.2/23.5/28.2 - NAS 4TB RAID 1
Software : OpenPLi - OScam - Settings van Hans  -  Autotimer  -  EPGImport


Re: Mountprobleem Vu+ Duo. sec=ntlm (opgelost) #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 50,676 posts

+924
Excellent

Posted 15 December 2015 - 11:17

De kernel versie wordt gedicteerd door de drivers, die door de fabrikant tegen een bepaalde kernel versie zijn gecompileerd. Daar hebben wij dus helemaal geen invloed op.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H ©, Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Mountprobleem Vu+ Duo. sec=ntlm (opgelost) #3 Frenske

  • Forum Moderator
    PLi® Core member
  • 23,061 posts

+213
Excellent

Posted 15 December 2015 - 12:33

Aangezien dit voorlopig nog niet opgelost is heb ik deze maar even vastgepind voor het geval dat de vraag opnieuw gesteld wordt. ;) Dan is het antwoord snel gevonden.
Mijn schotel is een T90 met 10 LNB's. Daarnaast voor de fun nog een draaibaar systeem met een Triax TD 78.

Dreamboxen heb ik niet meer. Verder nog een een VU+ duo2 met 500Gb harddisk + een VU+ Uno, Zero, Solo 4K, Ultimo 4K, Zero 4K, Uno 4Kse. + ook nog een Xtrend ET4000. Daarnaast heb ik ook nog diverse andere modellen w.o. een Formuler F4, ET8500, ET7500, Mut@nt 2400HD, Xsarius Fusion HD se en verder nog wel het e.e.a. waarmee op verzoek vanalles wordt getest. Iemand moet het tenslotte doen. ;) :)

Voor centrale opslag van media gebruik ik een Qnap 219P met tweemaal 2 Tb harddisks.

-------------------------------------------------------------------------------------------
Many answers to your question can be found in our wiki: Just one click away from this "solutioncentre".

Als ik alles al wist hoefde ik ook niets te vragen. If I had all the knowledge I had no questions at all.

Re: Mountprobleem Vu+ Duo. sec=ntlm (opgelost) #4 HPPli

  • Senior Member
  • 1,471 posts

+27
Good

Posted 15 December 2015 - 23:09

Onlangs liep ik tegen het probleem aan dat een netwerk share niet wilde mounten in een Vu Duo. Na de toevoeging in de options sec=ntlm werd de share gemount, een probleem dat volgens mij gerelateerd is aan de kernel 3.9.6#1. Nu zag ik in de updates dat de kernel en modules meeliepen, is er zicht op een upgrade m.b.t. de kernel voor de Duo?

Misschien wil je de voorlopige oplossing ofwel soort van workaround beter en uitvoeriger omschrijven in een HowTo ?? 


Edited by HPPli, 15 December 2015 - 23:10.


Re: Mountprobleem Vu+ Duo. sec=ntlm (opgelost) #5 40H3X

  • PLi® Contributor
  • 3,559 posts

+116
Excellent

Posted 16 December 2015 - 09:45

Allereerst wordt er in het Topic en de Tags (door mij) verwezen naar de Vu Duo, dit is omdat mijn vraag betrekking had op een update van dit type box, maar deze box heeft niks heeft te maken met de (eventuele) oorzaak van het mislukken van een cifs share en de oplossing hiervan.

 

De oorzaak had in mijn geval te maken met de gebruikte versie van de kernel van de box en de share. Deze wordt voorlopig voor wat betreft de Duo niet meer geupdate (zie opmerking #2 van WanWizard). Met een recentere kernel zoals bv. de Vu Zero met kernel versie 3.13.5 is er geen probleem.

 

Lees eventueel dit http://ubuntuforums....d.php?t=2230952

 

Voor sommige shares lukt het niet deze met cifs te mounten (cq. onder verbindings beheer groen te krijgen). Als je kernel versie 3.9.6 (Menu-Informatie-Ontvanger) hebt kan het zijn dat je een cifs share niet gemount krijgt, ondanks dat je de gegevens nauwgezet hebt ingevoerd. Zoals de link hierboven al uitgelegd heeft dat te maken met het ontbreken van een optie die nodig is om sommige shares te mounten, dit betekent dus dat het ook (share)medium afhankelijk is. Dus bij een box met kernel 3.9.6 is de hieronder beschreven oplossing bij de ene NAS/Router wel en bij de andere niet nodig.

 

De oplossing is simpel, echter helaas (IMHO) niet via de GUI (Graphical User Interface) uit te voeren (hier is al meer over geschreven Google even op “site:openpli.org sec=ntlm” zonder de “”).

 

-Onder verbindingsbeheer vul je de gegevens m.b.t. je share zo volledig mogelijk in.

-Daarna log je bv. met Telnet in op je box (er zij ook andere manieren)

-Je gaat naar /etc/enigma2

-Dan edit je bv. met vi de file automounts.xml

-Hier voeg je onder opties sec=ntlm toe, dus dan staat er bijvoorbeeld zoiets:

<options>rw,sec=ntlm</options>

 

Afsluiten en opnieuw mounten cq. je box opnieuw opstarten en als dit de oorzaak was kan je nu je share benaderen ;)


Edited by 40H3X, 16 December 2015 - 09:50.

Hardware: Vu+ Uno 4k SE - Samsung HM500JI 500GB 2.5 inch - Amiko Viper Combo HDD - Edision OS mio 4K - Spycat Mini Plus - Vu+ Zero - Vu+ Duo - WD 1TB - Fuba 78 cm - Tripleblock LNB Quad 19.2/23.5/28.2 - NAS 4TB RAID 1
Software : OpenPLi - OScam - Settings van Hans  -  Autotimer  -  EPGImport


Re: Mountprobleem Vu+ Duo. sec=ntlm (opgelost) #6 WanWizard

  • Forum Moderator
    PLi® Core member
  • 50,676 posts

+924
Excellent

Posted 16 December 2015 - 11:36

Als toelichting:

 

Vanaf een bepaalde versie van de kernel is de cifs security default veranderd van "ntlm" naar "ntlmv2".

 

Dat is geen probleem als de server kant recent genoeg is, een box met een up to date kernel, een Linux of Windows server (of desktop), of een NAS. Dat is wel een probleem als de server kant een oude samba draait, en dus nog "ntlm" verwacht en geen "ntlmv2" praat. In dat geval moet je die "sec=ntlm" optie toevoegen om het security niveau te verlagen. Dit speelt volgens mij alleen bij de oude generatie VU+ boxen.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H ©, Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Mountprobleem Vu+ Duo. sec=ntlm (opgelost) #7 40H3X

  • PLi® Contributor
  • 3,559 posts

+116
Excellent

Posted 17 December 2015 - 14:06

Nog een kleine "note to file":

 

Het komt aan de server zijde (oude samba) nogal eens voor bij wifi routers (oa. Asus) waar op de USB poort een schijfje wordt geshared in het LAN.

 

(btw. is dit IMHO een veel betere (als het om data sharing in huis gaat) en vooral goedkopere oplossing dan een klassieke NAS met HDD's. Zo heeft een AP met een USB schijfje eraan veel minder bewegende delen en dus ook minder kans op mankementen, daarbij is het ook nog eens volkomen geruisloos).

;)


Edited by 40H3X, 17 December 2015 - 14:08.

Hardware: Vu+ Uno 4k SE - Samsung HM500JI 500GB 2.5 inch - Amiko Viper Combo HDD - Edision OS mio 4K - Spycat Mini Plus - Vu+ Zero - Vu+ Duo - WD 1TB - Fuba 78 cm - Tripleblock LNB Quad 19.2/23.5/28.2 - NAS 4TB RAID 1
Software : OpenPLi - OScam - Settings van Hans  -  Autotimer  -  EPGImport


Re: Mountprobleem Vu+ Duo. sec=ntlm (opgelost) #8 Erik Slagter

  • PLi® Core member
  • 45,454 posts

+504
Excellent

Posted 17 December 2015 - 14:47

Of een USB stick of SSD sharen ;) Sowieso geniet een 2.5" disk altijd de voorkeur, minder warmte, minder verbruik en minder herrie.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Mountprobleem Vu+ Duo. sec=ntlm (opgelost) #9 WanWizard

  • Forum Moderator
    PLi® Core member
  • 50,676 posts

+924
Excellent

Posted 6 April 2017 - 14:43

Nog even ter verduidelijking:

 

Dit is dus nodig als je een CIFS connectie maakt van een box met een oude kernel (3.x) naar een box met een nieuwe kernel (4.x), ongeacht het merk van de box. Oud naar Oud, en Nieuw naar Nieuw werkt zonder verdere toevoegingen.

 

Als je via de mount manager een mount maakt, wijzig dan de "mount opties" van "rw" naar "rw,sec=ntlm".


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H ©, Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 






Also tagged with one or more of these keywords: Vu Duo

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users